Contribute
Register

[SUCCESS] Dimitris' Built: GA-B75M-D3V - i3-3225 (now i5-3570K) - Sapphire RX 560

Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
Dimitris' Built: GA-B75M-D3V - i3-3225 - Sapphire RX 560


Components

Intel i3-3225 Ivy Bridge Processor
(no longer available - to be replaced with an i5-3570k)

Alpenfohn Sella CPU Cooler
(not available on Amazon.com or Newegg.com)

Gigabyte GA-B75M-D3V Motherboard
(no longer available)

8GB Adata Premier Pro DDR3 1600MHz Memory (AD3U1600W8G11-R)
https://www.amazon.com/dp/B007UHFW2W/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=9SIAFJ678T8144

4GB Corsair Vengeance DDR3 1600 MHz Memory (CMZ4GX3M1A1600C9)
https://www.amazon.com/dp/B004CRSM48/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=N82E16820233141

ENERMAX 82 PRO 425 W PSU
(no longer available)

SanDisk Ultra II 240GB SATA III 2.5-Inch SSD (SDSSDHII-240G-G25)
https://www.amazon.com/dp/B00M8ABEIM/?tag=tonymacx86com-20
https://www.newegg.com/Product/Product.aspx?Item=9SIA12K75S2102

Western Digital Green 640GB HDD
https://www.newegg.com/Product/Product.aspx?Item=9SIAAEE4SF4834

Western Digital Green 800GB HDD
https://www.amazon.com/dp/B006GDVREI/?tag=tonymacx86com-20 (1TB version)

Sapphire RX 560 Pulse 2GB Graphics Card
https://www.newegg.com/Product/Product.aspx?Item=N82E16814202320 (4GB version)
https://www.amazon.com/dp/B077WDBWGG/?tag=tonymacx86com-20 (4GB version)

NZXT Case (no data for model)
(no longer available)

Tp-Link TL-WN722N WLAN USB stick
https://www.newegg.com/Product/Product.aspx?Item=N82E16833704045
https://www.amazon.com/dp/B0141JKZYQ/?tag=tonymacx86com-20

LG M2362D 27 HD Monitor
(no longer available)

Logitech G413 Keyboard
https://www.newegg.com/Product/Product.aspx?Item=N82E16823126494
https://www.amazon.com/dp/B06XR5MWGM/?tag=tonymacx86com-20

AROKH X-3 Mouse
(not available)


Comments

Well, I follow the site for many years and managed with its help to built 4 systems, so far, starting back to 2008 with an ASUS eepc !!!!
A few days ago we replaced my assistant's hackintosh with a brand new build, so I was left with bits and pieces of computer parts.
The goal was to try and build a stable and fast OS X desktop with the left over parts and perhaps improve a few of its weaknesses, if necessary.
I am posting this thread about my finished build, which proves that you can do miracles with some and some scrap and some more modern parts.

All of the components were pre owned.

After the installation I decided to buy:
a) a used i5-3570K from ebay for 70 euros,
b) a better than the stock intel CPU cooler (Alpenfohn Sella for 20 euros),
c) a bluetooth usb adapter and
d) the Sapphire RX 560 Pulse 2GB graphics card. Since the system is very stable and can replace the old iMac 27 (mid 2010) at my office, a need for a more capable GPU arose.


INSTALLATION NOTES
There is nothing specific to report.
I followed, as always, the excellent guide here:
https://www.tonymacx86.com/threads/...ojave-on-any-supported-intel-based-pc.259381/
for the UEFI Settings and the installation

POST-INSTALLATION NOTES (MultiBeast)
Uefi Boot Mode
Audio:
AppleALC
Disk: 3rd party SATA
Misc: FakeSMC, FakeSMC Plugins, FakeSMC HWMonitor
Network: IntelMausiEthernet v.2.4.0
USB: 7/8/9 series USB support (and, if i remember correctly, Remove XHCI Port Limit)
Bootloader: Clover UEFI Boot Mode
Graphics Configuration: Core graphics Fixup (Lilu and WhateverGreen)
System Definitions: iMac 14.2

Third party drivers
WiFfi Drivers:
https://www.tp-link.com/us/download/TL-WN722N_V3.html#Driver

All went perfectly fine, and I soon booted to a fully working 10.14.2 desktop.

The only problem was Quicklook and Preview for jpg files. The only thing that worked was NoVPAJpeg.kext which you can find here: https://github.com/vulgo/NoVPAJpeg


POST - INSTALLATION UPGRADES
a) One week later I purchased an Sapphire Radeon RX560 2GB Pulse since I am planning to buy a better high resolution monitor.
I just plugged it in, rebooted and that was it !!! Even HDMI sound works.
I didn' t make any changes to the BIOS. I didn't disable the Internal GPU (HD 4000). The system recognizes the IGPU as working .

b) The installation of the Alpenfohn Sella was very easy.

c) I have already ordered a Bluetooth USB stick ..... but alas has not yet arrived.

d) In the next few days I will receive the i5-3570k and post updates.

So far everything works. Even messages.

The only problem I faced had t do with the RAM. I installed the 8gb ADATA on the first slot and the 4gb CORSAIR on the second. Half of the times and after a cold boot only, the motherboard would not post and made a repeated short beep sound. It would automatically reboot, beep again, reboot again and post normally. After a normal boot a soft reboot would not repeat the problem.
This was solved after I changed the position of the ram dims. However the installation of the cpu cooler complicated things since the higher profile of the corsair ram created spacing problems and when I changed the position of the ram dims, I had beeps and no posts again.
A bit of love (aka violent force) solved the problem for good.

I am posting some pictures of the full setup, the Desktop and some Geekbench results (taken while using the hackintosh with the i3-3225).

Screenshot 2019-01-12 at 15.49.06.png

Screenshot 2019-01-12 at 16.38.53.png

Screenshot 2019-01-12 at 16.37.44.png

Screenshot 2019-01-12 at 17.09.45.png


Under load temperatures (geekbench):

Screenshot 2019-01-12 at 16.35.57.png


Finally, the hackintosh 's temporary working place :

IMG_20190112_155148.jpg


Thanks to all of you. This community has made this possible !!!!!!!
 

Attachments

Last edited:
Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
UPDATE 17-1-2019

I finally installed the i5-3570K.
I encountered many boot failures and got a bit afraid. However after loading optimized defaults and changing the settings I can finally boot stably again.

STRANGE THING: with the i3-3225 the system recognized both GPUs (I had left the igpu enabled in bios) and worked with the rx560. However now the osx cannot see the igpu (HD 4000). Moreover the clover boot menu screen is in lower resolution.
Why is that?????
I am posting benchmark results with the I5-3570K stock.

Screenshot 2019-01-17 at 22.28.48.png
 
Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
Update 18-1-2019

1. After a bit of tweaking and lame overclocking (the b75m-d3v has no serious capabilities) I managed to squeeze out a bit more performance. Idle the cpu at 26-30 C and under full load (yes > /dev/null & yes > /dev/null & yes > /dev/null & yes > /dev/null & for 20 minutes) at 51 C max.
Screenshot 2019-01-18 at 23.25.49.png

2. I deactivated the IGPU since i cannot solve something that is not a problem after all.
3. The low resolution at the clover boot screen was corrected by turning off CSM in BIOS.
4. I deactivated debugging in clover config.plist and the system boots much faster.

In all i am very happy with the system, and the only thing left is a fan controller so that i can lower down the noise of the 4 case fans
 
Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
UPDATE 21-1-2019

Ok ... this is the final update of the building of the setup.

Using a dvi-d to HDMI adapter and then an HDMI to VGA adapter I, finally, managed to get two displays going on seperate GPU.

Screenshot 2019-01-21 at 22.23.29.png

The first LG -23" now works on the RX560.
The second, an older LG 19" now works on the IGPU HD4000.

The set up in now complete and moving to the office to replace my imac 27" mid 2010 with two new HD displays side by side.

IMG_0180.JPG
 
Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
Update February 2019

Finally at its working place.
  1. DIY monitor stand.
  2. Dual monitor setup.
  3. Creative speakers
  4. And some cable managment
led to this

388669



388670
 
Joined
May 16, 2019
Messages
1
Motherboard
Gigabyte
CPU
i5 3570
Graphics
Intel
Hey there!

Thanks for sharing this. I have the same board and processor so this is really a good guide.

Unfortunately, after the MultiBeast, I got into the black screen with a mouse cursor.

Any idea what must have caused this?
 
Joined
Jun 27, 2012
Messages
12
Motherboard
GA B75M-D3v
CPU
i7 3.39 GHz Quad-Core Intel Core i7
Graphics
NVIDIA GeForce GT 710
Mobile Phone
iOS
Good Day, Sir hasodikis! Can you share to me your SSDT for GA B75M-D3V, please.
 
Joined
Nov 3, 2012
Messages
59
Motherboard
Gigabyte GA-B75M D3V
CPU
i5-3570K
Graphics
RX 560
Mac
iMac, MacBook, MacBook Pro, Mac mini
Mobile Phone
Android
Funny thing is that for this installation ... I didn't even drop or patched DSDT or SSDTs.

In my EFI/ACPI/patched folder its only this.
 

Attachments

Joined
Aug 7, 2010
Messages
18
Motherboard
Gigabyte Z170X-Ultra Gaming
CPU
i5-6600K
Graphics
R9 270X
Mac
MacBook Air
Mobile Phone
Android
I made a Hackintosh for my mother-in-law with this board & a Core i3-3225 back when they were new parts. This build only started giving me trouble at Mojave, and now Catalina. I was able to get it running with 10.15.4 and 10.15.5, but the 10.15.5 Supplemental Update broke the integrated graphics, now it runs in low resolution without acceleration. I tried a fresh install with the latest copy of Catalina (10.15.5 w/Supplemental Update) and the video problem persists. Any ideas?
 
Top