Contribute
Register

[SUCCESS] Dell Precision T5500 - Quadro4000|Xeon X5680 (MacOS10.12.X)

Joined
Sep 19, 2010
Messages
85
Motherboard
Dell T5500 (Tylersburg 5520)
CPU
X5670
Graphics
RX 580
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
I've tried multiple times to try and boot my T5500 w/ 1050Ti with a High Sierra legacy boot stick, but it kernel panics regardless of which boot options I try (tried PCIRootUID=1, PCIRootUID=4, nv_disable=1 and nvda_drv=1) No matter which I choose, it kernel panics after spending 4 or 5 minutes booting. The KP dump goes by too fast too read, then immediately reboots.

Any suggestions? How can I prevent the immediate reboot after KP so I can read the output?
 
Joined
May 20, 2016
Messages
26
Motherboard
ASUS Z97-AR
CPU
Intel Core i7-4790K
Graphics
Nvidia GTX 1070
Mac
iMac, Mac Pro
Mobile Phone
Android, iOS
I've tried multiple times to try and boot my T5500 w/ 1050Ti with a High Sierra legacy boot stick, but it kernel panics regardless of which boot options I try (tried PCIRootUID=1, PCIRootUID=4, nv_disable=1 and nvda_drv=1) No matter which I choose, it kernel panics after spending 4 or 5 minutes booting. The KP dump goes by too fast too read, then immediately reboots.

Any suggestions? How can I prevent the immediate reboot after KP so I can read the output?
Dont use nvda_drv=1, it wont work bevore you installed the nvidia driver.

Boot with -v and see which error comes bevore it kernel panics and google for the error.
 
Joined
Feb 4, 2013
Messages
18
Motherboard
Asrock Z97 extreme4
CPU
i7 3,5Ghz Kic2duo
Graphics
gtx 760, gtx titan x
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
SE
Mobile Phone
iOS
Hello!

first of all, thank you for writing up your guide, It has been a haven during my struggle of making my T5500 behave well.

QUESTION: do you have your video card in the PCI (upper) slot by any chance?

It seems my T5500 will comply best with the PCIRootUID=1 ....
although i'm still not sure if this is key to a successful install...
I think I have as much chance of succeeding with or without:
PCIRootUID=1 kext-dev-mode=1

I'm using an nvidia Titan X in pci slot n:2. Second from below.
it is a maxwell card so its very friendly to macos x
(these were the ones that were supported before the 1080 etc. Pascal series)

I am doing a High Sierra install with apfs ssd format...
(apfs: because you have to move on at some point anyway.)

only the audio does not seem to work at all.
I got the LAN to work once. :thumbup:
I have done many reInstalls because sometimes my EFI partition was unaccessible...

I would advise to unplug every USB device and use your installer USB in the
rear ports, as the front ports are connected through a flimsy cable, and feel
like they are more likely to cause problems.

I also noticed, which might help people with trouble installing on this T5500;
that the drive system switched back to RAID from RAID/AHCI at some point.

Also, do enable hyperthreading, and speedstep, and everything! (except from VT-d of course)
because I only had 12 threads to my disposal before I realised this.
afterwards, a glorious 24 threads.:headbang:

I use it for video editing. it is a bit faster than my i7 but i prefer Xeon stability
(the i7 on an asrock z97 board crashed on me a few times, also has no Ecc ram,
which ticks me off when converting big batches of video :beachball:)

anybody else golden tips for audio? :banghead:
is the appleHDAdisabler supposed to go in the EFI partition or S/L/E?
is the latest version of voodooHDA (2.9d10 instead of 2.8.8) also good?
i just want it to function!! i'm using a usb audio thing and my OCD doesnt
like that workaround ;)
 
Joined
Feb 4, 2013
Messages
18
Motherboard
Asrock Z97 extreme4
CPU
i7 3,5Ghz Kic2duo
Graphics
gtx 760, gtx titan x
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
SE
Mobile Phone
iOS
I've tried multiple times to try and boot my T5500 w/ 1050Ti with a High Sierra legacy boot stick, but it kernel panics regardless of which boot options I try (tried PCIRootUID=1, PCIRootUID=4, nv_disable=1 and nvda_drv=1) No matter which I choose, it kernel panics after spending 4 or 5 minutes booting. The KP dump goes by too fast too read, then immediately reboots.

Any suggestions? How can I prevent the immediate reboot after KP so I can read the output?
dont do nvidia injection in the unibeast 8.0 installer
maybe change your USB stick - I can't explain why but that seems to do the trick sometimes.
nv_disable=1 and nvda_drv=0
 
Joined
Aug 10, 2016
Messages
4
Motherboard
X58
CPU
2X Xeon X5650
Graphics
MSI GTX 970
Mobile Phone
iOS
I
High Sierra installed with no problem.
Do you use his config ? I have intall nvdia for sierra ;it requires restart to effective but restart no help because its keep require restart again,i cant change resolution.

Edited: I haved find Nvidia web driver. in boots screen clover I chose option uncheck inject nVidia then check nVidia web driver.
after that I go to Mac then install App on My Mac. dual screen work ok.
Now sound need to fix. I have to inject kext but still no sound( I don't know where to choice in sound (system preference) )

EDITED: I have done all things. but no chance for fix sound so i've just bought usb sound + mic world perfect for me.(in my country only 1.2 dollar for this device :">)
 
Last edited:
Joined
Mar 22, 2011
Messages
12
Motherboard
Mac OS X 10.7.4
CPU
Intel i7 2600K
Graphics
SAPPHIRE VAPOR-X HD 5770 1GB GDDR5
Mac
Classic Mac
Mobile Phone
Greetings partners.

I installed MacOS Sierra 10.12.0 and updated 10.12.6 without problems, but I feel that Sierra is slower than other OS. I like OS X 10.8.5, although I could only install it with a single processor, but it is really fast.
I would like to install Mavericks, but it has been impossible for me.

Dell Precision T7500 Workstation specifications:

- Two Intel Xeon processors X5675 3.07Ghz a glorious 24 threads
- 24GB DDR3 1333
- SSD SATA III SanDisk 520GB Extreme Pro on IO Crest SI-PEX40057 4 Port SATA III PCIe 2.0 x2 HyperDuo Raid (Marvell 88SE9230)
- nVidia GTX 680 4GB
- SONNET Gigabit Ethernet Adapter Presto Gigabit Pro PCIe
- Sound Card USB ASUS XONAR U7 MK II
- Inateck USB 3.0 4 Ports PCI-E

The only bad thing is that, sometimes, the shutdown is slow.

Installation method:
- Unibeast
- Multibeast with BIOS legacy and DSDT edited
- TRIM Support

For more details go to https://www.tonymacx86.com/threads/how-to-install-os-x-yosemite-using-clover.144426/

A million thanks to Tonymac and all the people who donated hours of disinterested work for the sake of collective knowledge.
 
Joined
Feb 4, 2013
Messages
18
Motherboard
Asrock Z97 extreme4
CPU
i7 3,5Ghz Kic2duo
Graphics
gtx 760, gtx titan x
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
SE
Mobile Phone
iOS
Hello friends of the T5500,

I just wanted to share some info.
I have a 2x 2,66 6 core T5500,
which gives me a heartwarming 24threads.

I have also succeeded in installing the very latest High Sierra with legacy boot ,
NOT inject Nvidia because that wouldn't work.

as we speak, I have the thing kind of running:
the OP's kext for network, BCM5754
or the voodoo HDA audio (from multibeast)
didn't work... :-/

but what I would like to report is that through the
NVenabler64 kext:
https://www.osx86.net/files/file/1778-nvenabler64kext/

my QUADRO FX 4800 (!non- mac version!!)

works. (kinda-)

installed with kextwizard and repaired permissions on S/L/E

at least, a little bit: the graphics are still a little weird, so further testing needed.

and I get this system info:
Screen Shot 2018-01-11 at 03.30.57.png




just wanted to mention this, it is kind of a big progress for me :-D
but I dont think the Quadro fx4800 is worth the stress, i'm getting a GTX 480 soon...

I am all ears for an audio and nic solution, though...
 
Joined
Feb 4, 2013
Messages
18
Motherboard
Asrock Z97 extreme4
CPU
i7 3,5Ghz Kic2duo
Graphics
gtx 760, gtx titan x
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
SE
Mobile Phone
iOS
a little update:

i figured out that having the BCM5754D.kext inside:

/System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/

makes it work!

and I edited the plist like suggested in the first OP post
from where you can also download the kext

edit: ALTHOUGH... the strangest thing: copying a 2GB file over network seems to break the network connection requiring a restart afterwards.. hmm :think:
 
Last edited:
Joined
Feb 4, 2013
Messages
18
Motherboard
Asrock Z97 extreme4
CPU
i7 3,5Ghz Kic2duo
Graphics
gtx 760, gtx titan x
Mac
MacBook Air, MacBook Pro, Mac Pro
Classic Mac
SE
Mobile Phone
iOS
the audio chip is this:

ADI1984A

and it works with this specific edited AppleHDA.kext, attached
without the voodooHDA pref pane.
I can even get 24 bit 192KHz output! that's a great DAC.

Screen Shot 2018-01-11 at 23.33.28.png
 

Attachments

Last edited:
Top