Contribute
Register

[Success] Dell Alienware M15 R2 i9 9880HK 2080 maxQ

Joined
Apr 27, 2020
Messages
20
Motherboard
Alienware M15 R1 motherboard
CPU
Intel i7 8750H
Graphics
GTX 1060
in the r2 we have many options for thunderbolt 3, make sure your bios is up to date

Also try putting this in your patched folder

Wow I didn't know that R2 had much more stuffs! Thanks for the file USB infection didn't worked out for me for the momunt I'll use your file and try it again! Thanks!
 
Joined
Apr 27, 2020
Messages
20
Motherboard
Alienware M15 R1 motherboard
CPU
Intel i7 8750H
Graphics
GTX 1060
in the r2 we have many options for thunderbolt 3, make sure your bios is up to date

Also try putting this in your patched folder

Sorry for the late notice, I was trying this and that I went to sleep with no success. Does your hackintosh says that you have a thunderbolt driver?
 
Joined
Oct 24, 2018
Messages
92
Motherboard
Dell Alienware m15 r2 - 1.3.9 - Clover
CPU
i9-9880HK/HM370
Graphics
UHD 630, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
no it does no say that I have thunderbolt in system report, but it does work
 
Joined
Oct 24, 2018
Messages
92
Motherboard
Dell Alienware m15 r2 - 1.3.9 - Clover
CPU
i9-9880HK/HM370
Graphics
UHD 630, 1920x1080
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello everyone, because I am trapped inside because of covid-19, I decided to get 10.15.4 working

What is working:
-Intel HD graphics hardware execration
-Audio and internal mic using AppleALC using ID 15 (thank you macpeet)
-Headphone port working (use ./install.sh from within the headphonejackfix folder) Thank you Feartech
-Keyboard and touchpad with gesture support
-Backlight and Volume control
-Battery in status bar
-Webcam
-Full sleep support (in terminal use "Sudo pmset hibernatemode 0")
-Thunderbolt 3 (with hutplug) (See Bios photos for my settings)
-Bluetooth
-USB 3.0 and 2.0 differentiation and recognition (USB Inject All With SSDT-UIAC-ALL)
-CPU Fan Control using HW Monitor
-Ethernet for the Killer E3000 (See Ethernet Info)
-Wifi using EW7811Ln USB - see " https://www.tonymacx86.com/threads/...11ln-usb-wifi-dongle-to-work-on-10-15.297199/ "

Whats not working
-Nvidia 2080 MaxQ
-HDMI (directly connected to Nvidia)
-Display Port (directly connected to Nvidia)
-Intel wifi 6 AX200 (waiting for AppleIntelWifiAdapterV2 or itlwmx project update)
-Headphone Microphone
-GPU Fan Control using HW Monitor
-Keyboard Backlight Controll
-Power Button to sleep

Problems I came across:
-My computer came with a sk hynix pc601 NvmeSSD and the drive is not compatible so I had to disable the drive from being detected from boot. I disabled the second NVME port (if you don't need this then remove SSDT-DiscreteSpoof-EVO-Plus.aml from ACPI/patched)
-I couldn't get the windows key to work, and after pulling my hair out I found out that Function keys are set in the bios. I was playing with function keys and pressed Fn+f6 Which locks the windows key. Just press Fn+f6 again to unlock
-I am quad booting Windows 10, Manjaro, Kali, and Mac OS. I have all three other operating systems on one NVME and Mac OS on the other. For the longest time I would sometimes restart my computer and get a Support Assist - Pre Boot System Performance Check before I was able to Start Clover. I believe that I was getting this issue because I did not have my clocks set properly in each OS. To fix this I corrected my clocks for each os, (in windows using Regedit) and have not got the problem again.


I hope this helps
-My current EFI folder below
-Make sure to change SMBIOS info to get iMessage and FaceTime to work
I have an update for anyone interested. I took the plunge and changed over to open core, and though there is a bit of a learning curve, it was well worth it and I am glad I made the change.

I am uploading my OC folder as a reference, From what I understand, Open core is a lot pickier then clover and should be created custom for each computer, so you should not just copy my folder

Now I am on Big Sur 11.0.1

What is working:
-Intel HD graphics hardware execration
-Audio and internal mic using AppleALC using ID 15 (thank you macpeet)
-Keyboard and touchpad with gesture support
-Backlight and Volume control
-Battery in the status bar
-Webcam
-Full sleep support (in terminal use "Sudo pmset hibernatemode 0")
-Thunderbolt 3 (with hutplug) (See Bios photos for my settings)
-Bluetooth
-Intel wifi 6 AX200 (AirportItlwm)
-USB 3.0 and 2.0 differentiation and recognition (USB Inject All With USBPorts.kext)
-CPU and GPU Fan Control using HW Monitor, RPM Control with Mac Fan Control
-Ethernet for the Killer E3000 (LucyRTL8125Ethernet)
-Power Button to sleep (Works as should, and Control + power button Brings up Toggle Menu)

What's not working
-Nvidia 2080 MaxQ (not Supported)
-HDMI (directly connected to Nvidia, and Disabled with SSDT-dGPU-Off)
-Display Port (directly connected to Nvidia and Disabled with SSDT-dGPU-Off)
-Headphone Microphone (If anyone knows apple alc patching, any help would be cool)
-Keyboard Backlight Control, (i figured out that it is controlled in windows with f24 but am stuck)
 

Attachments

  • Screen Shot 2020-11-22 at 5.31.31 AM.png
    Screen Shot 2020-11-22 at 5.31.31 AM.png
    93.6 KB · Views: 4
  • OC.zip
    77.6 MB · Views: 3
Top