Contribute
Register

<< Solved >> [SUCCESS] CATALINA 10.15.3 HP Z440 WORKSTATIONS E5-1660 v4, SAPPHIRE NITRO+ RX 5700 XT

trs96

Moderator
Joined
Jul 30, 2012
Messages
22,500
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
I am using a nvidia Kepler card
"The Rules Said"

Profiles are mandatory so that others can assist you. They are only for listing components and details of your primary system you are seeking assistance for or your latest system. Since they are viewable under your avatar they need to kept as small as possible and limited to one system only.

You will also need to start your own support thread to get help with the install.
 
Joined
Nov 24, 2019
Messages
15
Motherboard
HP Z440 (X99)
CPU
E5-1660 V4
Graphics
Quadro M4000
I am using a nvidia Kepler card quadro k420 which should be natively supported.
mount efi driver and delete EFI folder in this driver and replace with attack efi folder below. i hope it can work for you.
 

Attachments

  • EFI.zip
    29.8 MB · Views: 523
Joined
Jan 26, 2017
Messages
35
Motherboard
HP Envy X360 y13
CPU
Kaby Lake 7500U
Graphics
Intel HD 620
Mac
  1. Mac mini
Mobile Phone
  1. iOS
mount efi driver and delete EFI folder in this driver and replace with attack efi folder below. i hope it can work for you.

thanks for the folder.

I tried with it, it got the error just like with my own configuration "AMF: Only 248/256 slide values are usable! Valid slides: 8-255
+++++++++++++++++++++++"

I googled the error, someone said it is a new issue in Catalina of Clover, people suggested to use OpenCore instead of Clover, not sure if that really the case.
 

Attachments

  • IMG_3530.JPG
    IMG_3530.JPG
    4 MB · Views: 130
Last edited:
Joined
Nov 24, 2019
Messages
15
Motherboard
HP Z440 (X99)
CPU
E5-1660 V4
Graphics
Quadro M4000
thanks for the folder.

I tried with it, it got the error just like with my own configuration "AMF: Only 248/256 slide values are usable! Valid slides: 8-255
+++++++++++++++++++++++"

I googled the error, someone said it is a new issue in Catalina of Clover, people suggested to use OpenCore instead of Clover, not sure if that really the case.
sory i don't know but it work fire for my previous of quadro M4000. now i uppload worked EFI for AMD graphcis boot with some change boot parameter for nividia. if you can install success contact to me. i can folow you for nividia install drive.
 

Attachments

  • EFI.zip
    8.4 MB · Views: 302
Joined
Jan 26, 2017
Messages
35
Motherboard
HP Envy X360 y13
CPU
Kaby Lake 7500U
Graphics
Intel HD 620
Mac
  1. Mac mini
Mobile Phone
  1. iOS
sory i don't know but it work fire for my previous of quadro M4000. now i uppload worked EFI for AMD graphcis boot with some change boot parameter for nividia. if you can install success contact to me. i can folow you for nividia install drive.
thanks again for the help @khoaha19 , this time the installer was able to boot the machine correctly. but i found it can't format the SATA SSD in the installer Disk Utility which is pretty weird. the error of that is
"unable to write to the last block of the device"

I swapped to other SSD and also tried other SATA port, still same..
 
Joined
Nov 24, 2019
Messages
15
Motherboard
HP Z440 (X99)
CPU
E5-1660 V4
Graphics
Quadro M4000
thanks again for the help @khoaha19 , this time the installer was able to boot the machine correctly. but i found it can't format the SATA SSD in the installer Disk Utility which is pretty weird. the error of that is
"unable to write to the last block of the device"

I swapped to other SSD and also tried other SATA port, still same..
first time you cannot erase one partition. backup your data and erase whole disk by disk utility and repartiotion.
 
Joined
Sep 8, 2019
Messages
29
Motherboard
HP Z440
CPU
E5-1620 V3
Graphics
W7100
Mac
  1. Mac Pro
i dont know but my device is below.

View attachment 448438

That's good and you seem to have turbo boost to 3.8Ghz too. Does it keep working after going to sleep?

I checked the EFI you posted, and you have both xcpm kernel patches for 10.15.2 and nullcpupowermanagement.kext. I don't think the kernel patches are needed for your processor, because they should not do anything in 10.15.3, it's probably just nullcpupowermanagement.kext that makes it work. Can you disable the xcpm patches and see if you still get boosting to 3.8ghz? If so and still works after sleep, I might upgrade my z440 to a e5-1660 v4 so I can stop worrying about kernel patches.

thanks
 
Joined
Nov 24, 2019
Messages
15
Motherboard
HP Z440 (X99)
CPU
E5-1660 V4
Graphics
Quadro M4000
That's good and you seem to have turbo boost to 3.8Ghz too. Does it keep working after going to sleep?

I checked the EFI you posted, and you have both xcpm kernel patches for 10.15.2 and nullcpupowermanagement.kext. I don't think the kernel patches are needed for your processor, because they should not do anything in 10.15.3, it's probably just nullcpupowermanagement.kext that makes it work. Can you disable the xcpm patches and see if you still get boosting to 3.8ghz? If so and still works after sleep, I might upgrade my z440 to a e5-1660 v4 so I can stop worrying about kernel patches.

thanks

Yes you are right. don't need any kernel patches. you can use below option for power manager!
1. not use acpi ssdt pm + faceCPUID(0x0306F2 on config.list) + nullcpupowermanagement.kext
All work with sleep but CPU Freq max is 3200Hz
2. use acpi ssdt pm + do not use fafceCPUID + nullcpupowermanagement.kext
All work with sleep and CPU Freq max is 3800Hz
I have try all from 10.15.2, 10.15.3, 10.15.4 beta.
Below the picture is cpu pm after sleep on 10.15.4 beta.

I will attact final my EFI(with acpi ssdt pm patched). All work fine with my Z440. use it you can stop worrying about kernel patches.

Screen Shot 2020-02-11 at 21.54.10.png


Note: do not install 10.15.4 beta now. prefer HDR do not working true.(it proplem from apple not on hackintosh so you can wait for apple fix it on new version).
 

Attachments

  • EFI.zip
    8.4 MB · Views: 329
Top