Contribute
Register

[SUCCESS] blouse's "Hack Pro" :: i9-9900K + Z390 Aorus Pro + Vega 64 + TB3 + USB3 :: 100% working

Joined
Jan 18, 2019
Messages
247
Motherboard
Z390 M Gaming
CPU
i9-9900
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I removed 5700 XT SSDT (I have RX 580) and dAGMP still no luck.
I also tried CaseySJ's method you pointed out, still no luck.

However, this method for some reason works:
1. In config.plist, ENABLE PATCH --> XPRW change Method
2. Add SSDT-GPRW.aml to EFI/Clover/ACPI/Patched.

It seems like USB header thing is the issue, my guess is that the patch above disable USB completely during sleep?
Now the sleep works great. The 'drawback' I have to press power button to wake, I can live with that.

Thank you so much for all the help!


That's really odd. The only other difference between our setups is your Vega 64. Try removing the 5700XT SSDT in ACPI > Patched and the dAGMP kext.
BIOS settings all normal?
It wasn't needed on my system but have a look at the sleep / wake fix posted over here:
 
Last edited:
Joined
Mar 30, 2010
Messages
153
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
It seems like USB header thing is the issue, my guess is that the patch above disable USB completely during sleep?
Now the sleep works great. The 'drawback' I have to press power button to wake, I can live with that.

Thank you so much for all the help!
Glad you have it sorted now!
 
Joined
Apr 21, 2011
Messages
18
Motherboard
Gigabyte Aorus Pro
CPU
i9-9900K
Graphics
RX580
Mac
  1. MacBook Pro
I simply can not get my Aorus Pro to boot reliably without OsxAptioFix2Drv-free2000.efi

Was hoping that someone might be able to help me out with this?

I've made a new thread where I give some more detail:


Not sure if it's better to ask with a new thread or within this one :)

Thanks!
 
Joined
Mar 30, 2010
Messages
153
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
I simply can not get my Aorus Pro to boot reliably without OsxAptioFix2Drv-free2000.efi

Was hoping that someone might be able to help me out with this?

I've made a new thread where I give some more detail:


Not sure if it's better to ask with a new thread or within this one :)

Thanks!
I get that every now and again with OCQuirks as the memory fix and have most of my PCI slots used. It used to happen every second boot but much less frequently now.
 
Joined
Apr 21, 2011
Messages
18
Motherboard
Gigabyte Aorus Pro
CPU
i9-9900K
Graphics
RX580
Mac
  1. MacBook Pro
I get that every now and again with OCQuirks as the memory fix and have most of my PCI slots used. It used to happen every second boot but much less frequently now.

Oh! Well that's interesting, because your OCQuirks EFI that you posted a little while back is one of 2 that I tried. The EFI I'm using now is a bit of a mishmash of yours combined with the one I had been using for the past year, before I tried using OCQuirks earlier this week.

That's just the way it is with this board then? I wonder why it's happening less frequently for you now. The boot error wouldn't bother me so much if I didn't feel that it messed around with my Sonnet Express Thunderbolt chassis... the chassis just doesn't connect if the computer has rebooted at some point, and all these failed boots mean that I keep having to unplug the chassis and blablabla... it's just one less thing to worry about when I use OsxAptioFix2Drv-free2000.efi

My other hack right now is based on the Designare running CaseySJ's flawless EFI... that computer just runs so reliably with OCQuirks.

But you do still get the little circle now and then?
 
Joined
Mar 30, 2010
Messages
153
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
Yes it will throw the prohibited sign occasionally which I guess means our mem maps are right on the edge when booting with multiple add on devices. I have the Titan Ridge PCI-e, Fenvi 919, firewire card, fan controller and every USB port connected.
 
Joined
Apr 21, 2011
Messages
18
Motherboard
Gigabyte Aorus Pro
CPU
i9-9900K
Graphics
RX580
Mac
  1. MacBook Pro
Yes it will throw the prohibited sign occasionally which I guess means our mem maps are right on the edge when booting with multiple add on devices. I have the Titan Ridge PCI-e, Fenvi 919, firewire card, fan controller and every USB port connected.

I'm not using OCQuirks just yet, but I have managed to make my system work with OsxAptioFix3Drv by changing my SMBIOS to iMacPro1,1 and disabling the iGPU. So that's an improvement :)

A question for you: My current EFI is based on yours, and I've been wondering about all those aml files in ACPI/origin... where did you get all of those from?
 
Joined
Jan 1, 2020
Messages
15
Motherboard
Gigabyte Aorus Pro Z390
CPU
Intel I9 9900K
Graphics
Sapphire Radeon Vega 64 8GB Nitro +
I'm not using OCQuirks just yet, but I have managed to make my system work with OsxAptioFix3Drv by changing my SMBIOS to iMacPro1,1 and disabling the iGPU. So that's an improvement :)

A question for you: My current EFI is based on yours, and I've been wondering about all those aml files in ACPI/origin... where did you get all of those from?
I would assume he got then by pressing F4 in clover
 
Joined
Mar 30, 2010
Messages
153
Motherboard
Gigabyte Aorus Z390 Pro
CPU
i9-9900KS
Graphics
RX 5700 XT
A question for you: My current EFI is based on yours, and I've been wondering about all those aml files in ACPI/origin... where did you get all of those from?
From page 1 on this thread. I assume the OP used F4 to get them.
 
Top