Contribute
Register

[SUCCESS] blouse's "Hack Pro" :: i9-9900K + Z390 Aorus Pro + Vega 64 + TB3 + USB3 :: 100% working

Joined
Nov 27, 2018
Messages
248
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Thanks for looking @psedog. Regarding the kexts, I don't remember seeing EFICheck or RTCMem referenced in any of the guides, are they necessary? ...
I used them to troubleshoot an issue I was having, but never removed them as they don't seem to be hurting anything, lol. I will remove them when I get home now that you brought it up :lol:
 
Joined
Nov 27, 2018
Messages
248
Motherboard
GIGABYTE Z390 AORUS PRO WIFI
CPU
i7-8700K
Graphics
Vega 64
Mac
MacBook, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Joined
Feb 24, 2016
Messages
36
Motherboard
Gigabyte AORUS Z-390 Elite
CPU
i9-9900K
Graphics
Radeon VII
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
You have to go to Disk Utility and format the disk before it will show up there.
Yesterday I was working on it and got my HD back on screen. After 2 attempts, I got to install and configure everything, but today I can't boot again...

Let's begin all the work again.
I'm downloading 10.14.6 now...

I'm almost asking for some working EFI to try here... hehehehe
 
Last edited:
Joined
Jun 30, 2012
Messages
82
Motherboard
MSI Krait Gaming 3x
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
Yesterday I was working on it and got my HD back on screen. After 2 attempts, I got to install and configure everything, but today I can't boot again...

Let's begin all the work again.
I'm downloading 10.14.6 now...

I'm almost asking for some working EFI to try here... hehehehe
its better to do clean and build up EFI by yourself as other EFI might have files which might create issue to boot ,with basic drivers and kext read first post you must be able to boot fine as your system is good enough to boot mac os fine just a little reading might help
 
Joined
Feb 24, 2016
Messages
36
Motherboard
Gigabyte AORUS Z-390 Elite
CPU
i9-9900K
Graphics
Radeon VII
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
iOS
its better to do clean and build up EFI by yourself as other EFI might have files which might create issue to boot ,with basic drivers and kext read first post you must be able to boot fine as your system is good enough to boot mac os fine just a little reading might help
My first Hack was a i7-3770. It was simple and easy...
But this last was working fine. After a Gigabyte crazy BIOS that magically desappeared with my HD's...
Till this point I'm in a bad trip... kkkkkkkk
 
Joined
Jun 30, 2012
Messages
82
Motherboard
MSI Krait Gaming 3x
CPU
i7-6700K
Graphics
RX 580
Mac
iMac
Mobile Phone
iOS
My first Hack was a i7-3770. It was simple and easy...
But this last was working fine. After a Gigabyte crazy BIOS that magically desappeared with my HD's...
Till this point I'm in a bad trip... kkkkkkkk
Reflash your BIOS and keep just the hard drive you wish to install on connected , i have faced the same concern long time back and reflashing bios solved with just 1 HD connected: i.e., Samsung SSD.
Hope it helps
 
Joined
Aug 28, 2012
Messages
61
Motherboard
GA Z390 AORUS PRO
CPU
i9-9900K
Graphics
Vega 64
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
512K, iMac, LC, Plus, Portable, Power Mac, PowerBook, Quadra, SE, Xserve
Heya Blouse,

When trying to install Clover to the USB stick, I'm not seeing an option to "Customize" after I choose the drive to install to. Is there a step I'm missing? Thx!
 
Last edited:
Joined
Dec 2, 2011
Messages
47
Motherboard
Gigabyte Z390 AORUS PRO WIFI
CPU
i7-9700K
Graphics
Vega 56
Mac
MacBook Air, MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Figured out my video issues during OpenCL/Metal Geekbench tests... turns out, blindly following guides in haste is not advisable :) The device properties for the Vega 64 fan control in the first post can likely be revised for 10.14.5+ users. I removed it from my Clover config, and everything is hunky dory. Guess I should have realized that Vega 56 != Vega 64.

Screen Shot on 2019-07-29 at 21-16-41.png
 
Joined
Nov 24, 2010
Messages
88
Motherboard
Gigabyte GA-Z370-Gamer 7
CPU
I7-8700k
Graphics
Vega 64
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
Great Build. I just upgraded mine to a Gigabyte Designare with i9-9900k. Everything works great. TB3 does not eject disks on sleep but I cant get hot-patch working. I have the patches installed but I'm not sure i have done it correctly. What am i missing in clover? Do i need to point to the SSDT? I am not well versed on ssdt patches at all.

I had to modify the fans on the Sapphire Nitro+ Vega 64. The fans would not run under Mojave even with the fan speed fix. I disconnected the fans from the card and hooked them to the motherboard with the CPU being the input. It is always cool now even under heavy rendering.
 
Top