Contribute
Register

[Success] b1's "Mac Mini Killer" with macOS Mojave: i7-8700 | Gigabyte Z370N | RX560 | 16GB RAM

Joined
Apr 24, 2019
Messages
19
Motherboard
Z370N
CPU
i5 9600K
Hello @endrus,

1)It's working perfectly everything is recognized.
2) I updated the BIOS to F12 but still get the kernel panic and look like it's the same
3) I did exactly the same as explained on the github page of @b166ar

Don't really know what to do !
 
Joined
Jul 24, 2018
Messages
29
Motherboard
GA-Z370N
CPU
i5-8400
Graphics
RX 570
Mobile Phone
Android
@endrus @b166ar @FBelix @moosh
Do you think the last version 10.14.5 can cause the kernel panic on installation boot ?
It's hard to tell what the problem can be as no one here is using that particular CPU, no error reporting and b166ar's approach is a clean vanilla config.

Depending on your experience and how much time / effort you want to put in this build might try other tutorials with patches that are somehow easier to follow or downgrade to earlier Mojave nevertheless High Sierra and work your way up.
 
Joined
Dec 7, 2017
Messages
25
Motherboard
Gigabyte Z270P-D3
CPU
i5-7500
Graphics
RX 560
Mobile Phone
iOS
Hi! I have a setup with an i5-7500 and RX 560. I seem to have partial hardware acceleration, but sometimes things are very slow and apps like Final Cut and Quicktime (While recording) can get extremely laggy and freeze.
Do you have your display plugged into the dGPU or iGPU? Thanks!
 
Joined
Jul 24, 2018
Messages
29
Motherboard
GA-Z370N
CPU
i5-8400
Graphics
RX 570
Mobile Phone
Android
Hi! I have a setup with an i5-7500 and RX 560. I seem to have partial hardware acceleration, but sometimes things are very slow and apps like Final Cut and Quicktime (While recording) can get extremely laggy and freeze.
Do you have your display plugged into the dGPU or iGPU? Thanks!
You need your display to be connected to eGPU, not the motherboard's iGPU socket if you want to use the graphic card. Make sure the iGPU is allowed in BIOS for JPEG encodign and flawless sleep setting etc. as well as it's configured well.
 
Joined
Apr 24, 2019
Messages
19
Motherboard
Z370N
CPU
i5 9600K
Hey guys I managed to install Mojave on my computer. The kernel was due to the UHD 630 from my CPU. The EFI config from @b166ar was injecting a bad ig-platform-id and device-id. If anyone need a good EFI for the i5 9600K CPU just ask to me. I'm going to check this Tutorial to inject the good ig-platform-id and device-id.
 
Top