Contribute
Register

[Success] b1's "Mac Mini Killer" with macOS Mojave: i7-8700 | Gigabyte Z370N | RX560 | 16GB RAM

Joined
Jan 1, 2015
Messages
32
Motherboard
Gigabyte Z370N Wifi
CPU
Intel i5 8400
Graphics
RX580
Mac
  1. iMac
Hello guys thanks for the great work and support, when I try to update to 10.14.4 it hangs on this screen and keeps blinking (am on dual screen setup the other screen turns black while updating) and nothing changes at all (tried @b166ar fix but still the same ) am attaching my EssentialsList so you guys have a look, Thanks
395494
 

Attachments

  • EssentialsList-2019-03-27 20.04.53.zip
    110.7 KB · Views: 38
Joined
Nov 8, 2011
Messages
117
Motherboard
Z390M-ITX/ac
CPU
i7-9700K
Graphics
Vega 64
I made an EssentialsList dump of my system while all the disks are loaded and subsequently, one without. Could this help narrow down the issue of my on-board motherboard SATA ports only loading intermittently?
 

Attachments

  • With_Disks-EssentialsList-2019-03-28 08.22.11.zip
    385.6 KB · Views: 28
  • No_Disks-EssentialsList-2019-03-28 08.34.47.zip
    380.5 KB · Views: 25
Last edited:
Joined
Jul 1, 2018
Messages
393
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
  1. MacBook
Mobile Phone
  1. iOS
Hello guys thanks for the great work and support, when I try to update to 10.14.4 it hangs on this screen and keeps blinking (am on dual screen setup the other screen turns black while updating) and nothing changes at all (tried @b166ar fix but still the same ) am attaching my EssentialsList so you guys have a look, Thanks
View attachment 395494

Hi! Your config.plist is super messy and over configured :crazy:. But mine is not suitable for you, because you are using Internal Graphics. You should try @xmark EFI. It is similar to mine, but configured for HD630.
 
Joined
Jul 1, 2018
Messages
393
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
  1. MacBook
Mobile Phone
  1. iOS
Joined
Jul 1, 2018
Messages
393
Motherboard
GIGABYTE Z370N
CPU
i7-8700
Graphics
RX 560
Mac
  1. MacBook
Mobile Phone
  1. iOS
Fenvi site has a newer driver that than the Apple Bootcamp driver you have which is:
http://en.fenvi.com/en/download_zx.php?s=4&page=3 Use the FVT919 driver for Windows 10.
Your driver: DriverVer=07/24/2015, 7.35.118.40 from Bootcamp 6x
Newer driver: 7.35.317.3 dated 2016
DriverVer=02/03/2016, 7.35.317.3
CatalogFile = BCM43XX.CAT
CatalogFile.NTamd64=BCM43XX64.CAT

Thanks. I will try it.
 
Joined
Nov 8, 2011
Messages
117
Motherboard
Z390M-ITX/ac
CPU
i7-9700K
Graphics
Vega 64
Ha! Look like Mojave doesn't work with ZFS file system. And all your external disks are using ZFS.

It looks like you need a special driver for this — https://justinscholz.de/2018/06/15/an-extensive-zfs-setup-on-macos/

Hi and thanks for continuing to help. I think the ZFS is a red herring. Mojave does work well with ZFS by many other users, including myself on my other (X99) system. It relies on a kext.

I am sure this is a more low-level problem with MacOS and this board because on a fresh Mojave install, before the ZFS kext is installed, the disks show up at boot with the `initialize disk` prompt. (still the disks either show up or do not - seemingly at random)

I have tried a whole bunch of old AHCI/SATA injector kexts but none make the disks appear. AHCI_Intel_Generic_SATA.kext does make Intel Series 20 Chipset appear instead of just Generic AHCI Controller - but that is all.

For this kind of random problem. I am wondering if Aptio may part of it? If there is not enough memory for the loading of the disks?
 
Joined
Sep 21, 2013
Messages
4
Motherboard
Gigabyte Z370N WIFI
CPU
i5-8600T
Graphics
UHD 630
Mac
  1. Mac mini
in case someone is interested: using F11c, F11 and F12 is entirely possible using the following settings via the modified grub based efi shell (posting F10 CFG lock address as well).

WARNING don't use this if you don't know what you are doing!

check:

Code:
setup_var ADDRESS

set:

Code:
setup_var ADDRESS VALUE

example (F12 System Time and Alarm Source):

Code:
setup_var 0x507
returns 0x0
Code:
setup_var 0x507 0x1
sets Legacy RTC
Code:
setup_var 0x507
returns 0x1

# F10

CFG Lock
setup_var 0x585
Disabled => 0x0 (this is what you want)
Enabled => 0x1 (default)

# F11 / F12

System Time and Alarm Source
setup_var 0x507
ACPI Time and Alarm Device => 0x0 (default)
Legacy RTC => 0x1 (this is what you want)

CFG Lock
setup_var 0x5A4
Disabled => 0x0 (this is what you want)
Enabled => 0x1 (default)
 

Attachments

  • bootx64.efi
    2.4 MB · Views: 114
Joined
Jul 12, 2016
Messages
25
Motherboard
GA-Z370N-WIFI
CPU
i5-8400
Graphics
UHD 630
Mobile Phone
  1. iOS
Thank you themaxx32000, this is very helpful.
Hopefully Gigabyte will release the next BIOS updates with a dedicaded entry to choose the System Time and Alarm Source from. This would make things easier in the future...
Maybe its a good idea to write them a ticket about this. If we as a hackintosh scene mention this to Gigabyte they should consider implementing this...

Do you know if the address 0x507 is consistent on past and future the Bios versions?
 
Last edited:
Joined
Sep 21, 2013
Messages
4
Motherboard
Gigabyte Z370N WIFI
CPU
i5-8600T
Graphics
UHD 630
Mac
  1. Mac mini
as there are hundreds of options of which Gigabyte chose to not display them in their latest BIOS versions – including cfg lock – I highly doubt this will change with upcoming releases. as for your second question:

the address is very likely to change so always extract IFRs and double check addresses before re-applying any settings via setup_var!
 
Top