Contribute
Register

[success at the end] High Sierra on msi H310M pro-v & I3 8100

Joined
Mar 13, 2012
Messages
49
Motherboard
ASRockZ390 Extreme 4
CPU
i7-9700K
Graphics
RX 580
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hi guys!
I must finished to install OS X High Sierra to and old and unused PC found in my wife's office thanks to your help!
After three years I booted again a workstation run-in windows 10 and after about a Femto-Second I stated that I cannot use It anymore...
I tried install OS X then but I got a problem during pendrive boot: the infamous still waiting for root device error.
I tried to use different os version (High Sierra, Mojave, Catalina) but nothing happens. I changed three different usb pendrive (all usb 2.0) but nothing changed. Tried to use all 2.0 ports at the beginning and then 3.0 after; unsuccessful.
I tried to add USBInjectAll.kext in /EFI/CLOVER/kexts/Other/ and XHCI-300-series-injector.kext in /EFI/CLOVER/kexts/Other/
At the end thanks to this post https://www.tonymacx86.com/threads/...stalling-high-sierra.254794/post-1767701using this config.plist patch all worked fine!!!


<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>USB 10.13.4+ by PMHeart</string>
<key>Disabled</key>
<false/>
<key>Find</key>
<data>
g32UDw+DlwQAAA==
</data>
<key>InfoPlistPatch</key>
<false/>
<key>MatchOS</key>
<string>10.13.x</string>
<key>Name</key>
<string>com.apple.driver.usb.AppleUSBXHCI</string>
<key>Replace</key>
<data>
g32UD5CQkJCQkA==
</data>
</dict>
</array>


So I just would like to says thanks to all of you because with your support, patience and passion help our community to be a special place where to learn.
Thanks Antonio
 
Last edited:
Top