Contribute
Register

[SUCCESS] ASUS Z270 ROG Maximus IX Hero - i7-7700K - 32GB RAM - Intel HD 630

Joined
Aug 22, 2017
Messages
356
Motherboard
Z390 Designare
CPU
i9-9900k
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Updated to the latest Lilu and Whatevergreen and lost DisplayPort connectivity. Only HDMI works but even then unreliably. I'm running Mojave 10.4.6 with a Sapphire RX580 8GB. Any ideas?

IGNORE my signature. I still have the Z270 System in addition to my Z390.
 
Joined
Apr 4, 2017
Messages
1,061
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
Do you have all the hackintosh-related kexts in EFI->Clover->kexts->other?
 
Joined
Oct 29, 2017
Messages
14
Motherboard
ASUS Maximus Hero IX Z270-1301
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
JCMunsonII, I have built my system following your hardware. However, I cannot get it to boot. I have some very basic questions, primitive even. Can you recommend anyone that may be able to offer consulting, or would this thread endure some very noobie questions?
 
Joined
Apr 4, 2017
Messages
1,061
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
Ask away!

Hopefully you have read through all the updates, etc.?
 
Joined
Apr 4, 2017
Messages
1,061
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
04/06/2020 10.15.4 Update

Updated to 10.15.4.

1. NOTE: ***DO NOT USE Clover r5109!!!*** That version caused my system to drop both Bluetooth and USB ports! r5108 works just fine.
2. Back up your system. I use Carbon Copy Cloner. This is SOP when doing updates.
3. Updated Clover Configurator.
4. Updated Clover to version 5108 (choose "Install anyway" if given the compatibility warning during that update).
5. Update, via Clover Configurator, Lilu, WhateverGreen, and AppleALC kexts.
6. Install the update. System will reboot two or three times (I lost count) and then you should be good to go. If Clover does not automatically choose the "Installer Preboot from Preboot", you must choose that on both reboots.

Update installed without any issues (aside from figuring out the r5109 problem).

Note on the r5109 issue: I had no idea it had a problem until the update finished and then got the login screen - but without keyboard or mouse. My usual mouse runs off the Fenvi Bluetooth, and my keyboard is USB. No USB ports worked and of course Bluetooth was out. I eventually fixed the issue by replacing both CLOVERX64.efi and BOOTX64.efi with the r5108 versions using Clover's Shell 64 utility. Note that the keyboard and mouse work fine at the Clover boot selection screen - just not after.

I am probably going to have to go to OpenCore after this version, but not sure yet - lots to learn there!
 
Joined
Apr 4, 2017
Messages
1,061
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
04/10/2020 10.15.4 Supplemental Update

Updated to 10.15.4 - Supplemental.

1. NOTE: ***DO NOT USE Clover r5109!!!*** That version caused my system to drop both Bluetooth and USB ports! r5108 works just fine. See previous update!
2. Back up your system. I use Carbon Copy Cloner. This is SOP when doing updates.
3. Install the update. System will reboot two or three times and then you should be good to go. If Clover does not automatically choose the "Installer Preboot from Preboot", you must choose that on both reboots.

Update installed without any issues.
 
Joined
Jan 4, 2015
Messages
18
Motherboard
asus rog maximus ix hero z170
CPU
7700k
Graphics
hd630 and 5700xt
Mobile Phone
  1. iOS
waiting for OpenCore solution for exactly the same config...
 
Top