Contribute
Register

[SUCCESS] ASUS Z270 ROG Maximus IX Hero - i7-7700K - 32GB RAM - Intel HD 630

Joined
Sep 20, 2017
Messages
56
Motherboard
ASUS Z270 MAXIMUS IX HERO
CPU
i7-7700K
Graphics
RX 580
Yes. Please post your EFI folder. I'd like to compare differences with mine. TIA!!
Can you post yours as well? I am always interested to see how other builded it up. If you see some strange things in mine, please tell me. Hope i will learn some new stuff...
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,106
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Can you post yours as well? I am always interested to see how other builded it up. If you see some strange things in mine, please tell me. Hope i will learn some new stuff...
Mine is always available in my Z370 build thread, including my OpenCore EFI. Link is below in my signature.

Thanks for the EFI! I'll report back if I have any success.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,106
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Can you post yours as well? I am always interested to see how other builded it up. If you see some strange things in mine, please tell me. Hope i will learn some new stuff...
I spent the last hour and a half trying every imaginable configuration and can't get FileVault working with Clover on Catalina 10.15.1.
 
Joined
Sep 20, 2017
Messages
56
Motherboard
ASUS Z270 MAXIMUS IX HERO
CPU
i7-7700K
Graphics
RX 580
I spent the last hour and a half trying every imaginable configuration and can't get FileVault working with Clover on Catalina 10.15.1.
oh no. Did you try the same drivers a i did? I found out that rebuilding the kextcache with kextutility destroys my new kext, so i've just installed them with kextbeast and skipped the part with kextutility. :confused: Don't know why but the first time i've encountered this was with the virtualsmc kexts.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,106
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
oh no. Did you try the same drivers a i did? I found out that rebuilding the kextcache with kextutility destroys my new kext, so i've just installed them with kextbeast and skipped the part with kextutility. :confused: Don't know why but the first time i've encountered this was with the virtualsmc kexts.
Yes, I used the same drivers you did but thought that maybe you had different versions that worked but that didn't pan out... I even tried using the versions of kexts you had. Again, no success...

I stopped putting kexts in /Library/Extensions/ long ago, so kext cache definitely wasn't an issue for me.

All the kexts from Acidanthera were intended to be injected by the bootloader...
 
Joined
Sep 20, 2017
Messages
56
Motherboard
ASUS Z270 MAXIMUS IX HERO
CPU
i7-7700K
Graphics
RX 580
Yes, I used the same drivers you did but thought that maybe you had different versions that worked but that didn't pan out... I even tried using the versions of kexts you had. Again, no success...

I stopped putting kexts in /Library/Extensions/ long ago, so kext cache definitely wasn't an issue for me.

All the kexts from Acidanthera were intended to be injected by the bootloader...
What problems do appear, if you try to boot it? Do you use the FileVault prebooter in Clover?
Thanks for the hint with /L/E/ and EFI. I will put Acidanthera-kexts from now on only in my EFI. Did you find some other unfitting things in my EFI, that i could improve?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
15,106
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
What problems do appear, if you try to boot it? Do you use the filevault preebooter in clover?
Thanks for the hint with L/E and Efi so i will put Acidanthera-kexts from now on only in my Efi. Did you find some other unfitting things in my efi, that i could improve?
Booting starts off normally. I get to the login screen and I'm able to enter my password.

Then macOS starts to load... It starts normally, then slows to a crawl. When it finally finishes, it blinks to a black screen. I can see an move the mouse arrow but everything else remains black. If I press the mouse button, the mouse cursor disappears and everything is black.

Again, FileVault worked fine on Catalina 10.15.0. It only broke with 10.15.1.

OpenCore works fine.

Everything seemed fine. You can put kexts in /EFI/CLOVER/kexts/Other/ so it can work across whatever version of macOS you try to load.
 
Joined
Apr 4, 2017
Messages
1,056
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Updated to 10.15.1 late last week.

Needed to download the linked kexts - Lilu, AppleALC, and WhateverGreen as linked through the post here as Clover Configurator didn't see the updated kexts.

Once backed up, I started the update process. As per the previous update, had to manually select the Install Preboot on Preboot drive to begin the installation process, and after the reboot, did so again.

Update installed without any issues.
 
Joined
Sep 25, 2012
Messages
1,310
Motherboard
Asus Z270 Maximus IX HERO
CPU
i7-7700K
Graphics
GTX 1080 Ti
Mac
Mac Pro
Mobile Phone
iOS
I can't seem to update my Clover.

Currently I'm at version 4630. The "Update" feature of the Control Panel does not work.
Clover Configurator will let me update all the way to 5980 but my machine won't recognize the boot drive if I install 5980.
I went to SourceForge for the latest Clover and they won't download any new ones anymore, saying that I need to go to GitHub,
GitHub only contains the source files (at least I can't find a downloadable) and I'm not about to try and compile a version using Xcode...

Am I stuck with 4630 forever? Is there somewhere I could D/L a newer version? Do I even need to for this rig?

I'm still on High Sierra 10.13.6 since I don't feel like replacing my 1080Ti...
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,465
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I can't seem to update my Clover.
...
Am I stuck with 4630 forever? Is there somewhere I could D/L a newer version? Do I even need to for this rig?
...
r4961 is available at the tonymacx86 Downloads > Clover Builds. r50xx will be added real soon now.
 
Top