Contribute
Register

[SUCCESS] ASUS Z270 ROG Maximus IX Hero - i7-7700K - 32GB RAM - Intel HD 630

Joined
Sep 20, 2017
Messages
49
Motherboard
ASUS Z270 MAXIMUS IX HERO
CPU
i7-7700K
Graphics
RX 580
Ok. I see. Maybe lets start from a different angle. Did you download just the update of the osx or the full version of Mojave? What size does it have? Maybe you should download once again from here and rebuild one bootable usb.
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,046
Motherboard
ASUS ROG MAXIMUS X HERO Z370
CPU
i7-8700K
Graphics
RX 580
Mac
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
...
For example, does the bootable USB need the full macOS and not an upgrade or combo upgrade?
...
You need the full installer. The Combo Update only works on the installed system.

Additionally, you'll need to install your Vega as the GTX 1070 won't work correctly with Mojave.
 
Joined
Apr 4, 2017
Messages
1,016
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
@StGeorge1 - I saw the email concerning "shouldn't it just work." If you are using the Combo Update, no, you need the full installer. I also found the 14,2 definition to be unstable with this motherboard. I can't speak to how it would work with Mojave as I'm not using it.

I suggest starting over, making sure to look for the changes needed for Mojave that I'd implemented.
 
Joined
Apr 4, 2017
Messages
1,016
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
As long as he puts the Vega card in, that should work just fine.
 
Joined
Oct 29, 2017
Messages
13
Motherboard
ASUS Maximus Hero IX, BIOS 1301
CPU
i7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Thanks so much! I have now downloaded the full macOS and created the boot drive. I will use the iMac 18,3 definition. 2 questions: should I add the JCMunsonII recommendations (and Stork recs) to the TonyMac instructions, even though they were for the Sierra build? And, must the Vega 64 be installed from the beginning, rather than adding it once I've been successful booting? You guys are saving my project from certain death!
 
Joined
Apr 4, 2017
Messages
1,016
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Read through the setup guides for Mojave that TonyMac has created and use that. Read through my guide to find the BIOS setting changes to facilitate Mojave.

You *should* be able to leave the Vega 64 card in during installation as the OS should natively see it.
 
Joined
Apr 4, 2017
Messages
1,016
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Update to 10.14.6

Overall: update went without issues (despite appearances).

1. First, make sure to back up/clone your system (note that I didn't do this, thankfully wasn't needed) using your favorite tool, such as Carbon Copy Cloner.
2. Update Clover Configurator, "CC".
3. Update your kexts (CC has a "kext installer" that is much improved and is great to use). Updates were needed for Lilu.kext, Whatevergreen.kext, and AppleALC.kext.
4. At the date of this writing (7/31/2019) DO NOT update Clover. Clover has a directory change under the hood and it may cause your system to not boot. There are notes about it in the 10.14.6 thread.
5. Start the update.
6. There will be several restarts. Expect purple lines during each restart past initial up to the log-in screen. At the final stage, your screen may be black for a while - don't panic, give it time, your login screen will display in a few minutes.
7. You should be good-to-go!
 
Joined
Oct 29, 2017
Messages
13
Motherboard
ASUS Maximus Hero IX, BIOS 1301
CPU
i7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
One step forward! :)

I was successful booting to 10.14.5. Vega64 GPU is working. In MultiBeast, I ran into problems, and now I cannot reboot. I'm hoping I don't have to re-install. Here is what I did:
1. Changed BIOS as per JCMunsonII "BIOS Setup" (though I could not find XHCI Handoff).
2. Changed SMBIOS to "iMac18,3" and Binaries Patching to "0x05060E3"
3. Per JCMunsonII, jumped to Stork's Installation notes (Sierra Build) for MultiBeast tweaks.
4. In MultiBeast, selected:
- Quick Start > UEFI Boot Mode
- (I skipped the Audio drivers for now)
- Drivers > Misc > FakeSMC Plugins
- Drivers > Misc > FakeSMC HWMonitor
- Drivers > Network > Intel > IntelMausiEthernet
- Drivers > USB > USBInjectAll.kext
- Bootloaders > Clover v2.4K r 4063 UEFI Bood Mode + Emulated NVRAM
- (I skipped all graphics options. I'm using Vega64)
- I had in "Build", Customize > Sys Def > iMac > iMac 18,3
5. I saved this configuration.
6. I selected the drive "Mojave" (and not the opt. "Install Mojave" or something sim.), and I selected "Install"

It installed successfully.

I noticed, however, that neither the drive "Mojave" nor my system name were not present in Finder. It seemed that this would be needed to navigate to S/L/E and install "AppleHDA.kext" - per the JCMunsonII audio changes of "01/31/2018 - 02/01/2018 13.3 Supplemental Update..." So, I rebooted. My system would then crash each time I was 1/2 way through the Apple progress bar during bootup. I tried Verbose. From the Clover screen, I also tried booting from both the Mojave Installer (which prompted me to reinstall MacOS) and from by NVME drive "Mojave". Neither worked, despite making the above SMBIOS changes, etc).

At this point, I don't know what else to do. If I can boot again, I'd gladly use the Install_Tools reporting - if that would helpful to diagnose.

I am sure it is operator error, but I'm out of guesses and appreciate any guidance. Thank you!
 
Joined
Apr 4, 2017
Messages
1,016
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
@StGeorge1 - So, you booted to 10.14.5, but attempted to install over it? I'm a little confused...
 
Top