Contribute
Register

[SUCCESS] ASUS Z270 ROG Maximus IX Hero - i7-7700K - 32GB RAM - Intel HD 630

Joined
Apr 4, 2017
Messages
1,054
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
I will get that to you in the morning and a little more.

One overall question I have is whether an XCPM SSDT is needed given the processor is supported...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,623
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I will get that to you in the morning and a little more.

One overall question I have is whether an XCPM SSDT is needed given the processor is supported...
You can use SSDT for CPU power management or you can use PluginType=True. One or the other. I prefer the later.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,623
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
@pastrychef - here you go...
Please try this config.plist. I have also included the latest AppleALC, Lilu, and WhateverGreen.

Also, please remove CodecCommander.kext and Shiki.kext from your /EFI/CLOVER/kexts/Other/ folder. They are no longer needed.
 

Attachments

Joined
Apr 4, 2017
Messages
1,054
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Thank you for that. I had updated the kexts yesterday, so didn't need those.

After re-supplying the serial numbers, etc., still no joy on hardware acceleration. I did compare the two configs - nice to be able to drop a few changes.

IOReg attached.
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,623
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Thank you for that. I had updated the kexts yesterday, so didn't need those.

After re-supplying the serial numbers, etc., still no joy on hardware acceleration. I did compare the two configs - nice to be able to drop a few changes.

IOReg attached.
I don't see your IGPU anywhere. Are you sure it is enabled in BIOS?
 
Joined
Apr 4, 2017
Messages
1,054
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
Aha!

Setting Primary Display to PEG, and enabling IGFX Multimonitor support did the trick! A case of "that doesn't exactly mean what you think it means" in the BIOS settings... Yay! :D

Leaner and cleaner - I like that!
 
Joined
Apr 4, 2017
Messages
1,054
Motherboard
ASUS Z270 ROG MAXIMUS IX HERO
CPU
i7-7700K
Graphics
Vega 64
Mac
iMac
Mobile Phone
iOS
OK, for those who haven't been following...

For a long time now, I have not been able to get hardware encoding to show up as supported. That is now solved. Starting with Post #628, through Post #639, you'll see what was done. If you use @pastrychef 's Config, be sure to re-supply your various IDs & S/Ns in the SMBIOS section.

Also, some cleanup too - only have the custom USB port patch in the ACPI\Patched folder now, and a reduced number of supporting kexts in the CLOVER\kexts\Other folder.

And now I'll be testing sleep...
 
Top