[SUCCESS] ASUS Z270 ROG Maximus IX Hero - i7-7700K - 32GB RAM - Intel HD 630

Apr 4, 2017
Vega 64
Mobile Phone
JMunsonII's Build:
ASUS Z270 ROG Maximus IX Hero - i7-7700K - Intel HD 630

Tools Needed​
Making the UniBeast Installation Key​
BIOS Setup​
Installation Notes​
Fixing On-board Graphics​
Fixing Hardware Sensors​
Fixing Power Management​
Fixing USB Ports​
Fix SAT0 to SATA​



INTEL i7-7700K Processor



G.Skill TridentZ RGB DDR4-3200 32GB RAM


NOTE: It may, or may not, be in stock - item should match the one in this list.



NOTE: The Amazon & Newegg listings are not identical. Amazon has a sixpack only, Newegg has the 3-pack.

Already Owned

Apple Full-size USB Keyboard
What can I say, I use the number pad a bit...

Logitech Wireless Mouse
This was actually an interesting thing. I started off with my MX1000 laser mouse, however, it caused bad screen issues - skipping cursor, CMD-TAB glitching, etc. So, I used a bit newer wireless mouse (uses the Unifying receiver) and the problems disappeared. Be aware that older mice can cause strange screen/system problems.



A couple of years ago an acquaintance of mine was showing off his Hackintosh, extolling its virtues. I inquired, and the details he provided gave me the itch to potentially replace my existing iMac with such a machine. The 2008 iMac 27, Core2Duo (sporting 6GB RAM), was getting long-in-the-tooth and replacing it was going to be a reality a little sooner than later. A couple years later, and I am now writing this from my Hackintosh - "Heroica" - so-named in honor of Stork's HERO build.

Stork's build was/is a complete inspiration - and paved the way for me to attempt this version. Where his build uses the 100-series board and a Skylake processor, I chose to go with the newer 200-series board and the Kabylake processor. While neither of my chosen components are yet factually supported by Apple at the time of this writing, given that both are updates to the previous series, it should work as well as Stork's build turned out. Stork's build went smooth-as-butter, and while I expected some challenges with this build, I also hoped for a very smooth build and was definitely rewarded with that in the end.

I recommend you take a moment and read through Stork's build now, as it is the foundation on which this build is created. Stork did a great job with the write-up, and please reference it as-needed while following this guide.

You'll also want to make careful note of this thread - it contains information vital to Kabylake/200-series chipsets installations.

I'll close this section by adding my sincere thanks to @tonymacx86 for this site and all being done here, Stork for the inspiration for this particular build, and @RehabMan for his generous assistance, code, and kexts. Many thanks to others for their use of this board, code, and kexts to get these machines working.

The Build

I decided on creating a Hackintosh as my current '08 iMac is slowly ceasing to function, not to mention being 9+ years old. It is amazing how long the machine has lasted. Alas, my finances haven't been as stellar as that machine's fortitude, and Apple's rather high cost for "older" hardware deterred me from another iMac (in addition to the more gimmicky things they are doing lately). Looking at a CustoMac vs. an iMac really convinced me to go the CustoMac route.

Stork's excellent build description and recommendation of the ASUS motherboard, and my consequent examination of same, "sold me" on this platform. I'm not new to building PCs, however, it had been a while. I can say that PC hardware has really come a long way.

It was a delight to build this computer. I absolutely love the case. Sure, it is a little bigger in terms of it being more square, but, the room inside and its airflow make for a wonderful installation and maintenance. In my opinion you get a heck of a great case for the money.

Installation of the OS

The following assumes you've built your computer (or had it assembled by someone else), and are ready to proceed with installing macOS on it.

Do note that Kabylake series chips/chipsets are not currently natively supported by macOS, so a few changes/additions will be made to this process. Read each part carefully.

CAVEAT: I'm not a macOS expert, so if you get stuck: post here if it is relative to this guide, or, post in the relevant forum on this board to receive proper help. Be sure to attach proper file sets depending upon the help you need. Read FAQ, "Problem Reporting" here.

Tools Needed
You will need the following software to install and configure macOS:
  • XCode, PList Editor Pro, or similar for editing PLists. DO NOT USE TEXTEDIT!
  • Clover Configurator (see Making... section)
  • IO Registry Explorer
  • MaciASL
Making the UniBeast Installation Key
In my case, I had to start with El Capitan, as the age of my iMac was too old for Sierra. So, you'll need to follow this guide to create the install key. With regard to formatting disks, the screens have changed - you only need 1 partition for creating the key, so do not concern yourself over that part. Erase the disk, giving it a name, using GUID for Partition Table, and Mac OS Extended (Journaled) as the file system. You'll want to erase the actual disk first, then the volume under it (NOTE: That second step may be unnecessary, I did it "just to be sure"). If, for some reason, Erase is unavailable, you'll find plenty of help on the web to address it. You can create that part of the install disk via Terminal if necessary.

With regard to your new box, while I am certain it doesn't matter which of the USB 2.0 ports you use on the board, I used the one labeled for BIOS updates. I do recommend using a 16GB key as you'll likely hit the 8GB limit. NOTE: You MUST use a USB 2.0 key only! Do NOT use a USB 3.0 key - the installation will not even start.

[NOTE: If you wish to attempt to use a USB 3.0 key, please see this reply, and it may only work for Sierra. I have not tried it myself, and the board suggests sticking with a USB 2.0 key in any case.]

I also recommend putting MultiBeast, KextBeast, and Clover Configurator on the USB key so you don't have to download them later.

For El Capitan, you can also reference Stork's guide.

BIOS Setup
I recommend updating the BIOS before starting. This is easily done via Ethernet as the motherboard has the facility to update that way. Alternatively, if you can't connect your soon-to-be CustoMac to the Internet, you can download the update to a USB key (you can use the one you created to install the OS) and perform the BIOS flash that way. See the motherboard's User Manual for a how-to - it is a trivial operation.

I do recommend that you look through the various BIOS pages so you can familiarize yourself with the layout and options available - you may need them at some point.

Some of the BIOS items are not immediately visible - be sure to page down or scroll down to find all the options. Also, some of the settings may be, by default, already set. An online version of the BIOS manual can be found here.

In the BIOS, you want to set the following (while in Advanced Mode):

  • Load Optimized Defaults
Extreme Tweaker​
  • AI Overclocker Tuner > X.M.P.
  • Extreme Tweeking > Enable
Advanced Items​
  • System Agent (SA) Configuration > VT-d > Disable
  • PCH Configuration > IOAPIC 24-119 > Disabled
  • USB Configuration > Legacy USB Support > Auto
  • USB Configuration > XHCI Hand Off > Enabled
  • APM Configuration > Power on by PCI - E/PCI > Disabled
Boot Menu​
  • Fast Boot > Disabled
  • Secure Boot > OS Type > Other OS
  • Boot Option 1 > USB installer thumb drive (the UEFI choice if there are two entries)
If you are using the FENVI card, be sure to disable the onboard WiFi controller and Bluetooth controller.​
If you are planning on running some other OS as a Virtual Machine (via Parallels for instance), be sure to turn on Intel Virtualization support.​

Finally, Exit > Save Changes​

If you have your build configured as mine is spec'd, you'll also want to set your fan curves to Silent and change their mode to PWM. The motherboard's User Guide explains the screens fairly well - they are nicely straightforward.

Installation Notes

After you have set the BIOS, the next thing is to boot to the USB, make some quick changes to the Clover bootloader, and then install the OS - which should go very smoothly if all is set correctly.

Once you boot to the USB key, you will need to make three changes to the Clover bootloader. Once Clover loads, press the right arrow key to get to the Options menu. You must make these changes every time you boot until you use Clover Configurator, or a PList editor, to make these changes permanent (I HIGHLY recommend Clover Configurator). NOTE: This portion is for the version of Clover used to install El Capitan as per the guide previously cited.

Clover's entry system is a little tricky - use the Enter key to edit the field, and Enter again to exit the edit process. If you cannot move between the options, you are still in the edit process - press Enter to exit the edit process. A slight clue is also where the cursor is located, so keep an eye on that. Lastly, if you are using the same monitor I am, Clover will be really tiny - that is normal as you're using a 4k screen.

Under the SMBIOS menu, change both the Product Name and Board Version to read iMac14,2.

Under the Binaries Patching menu, edit the Fake CPUID to read 0x0506E3 (the Skylake CPU ID). As the Kabylake processor is not supported, but IS compatible with most, if not all, the Skylake instructions, we are able to spoof the ID with success.

Now you should be able to boot into the installer and install the OS. Then follow the Post-Installation portion of the guide with the following notes:

  1. Reference Stork's Installation Notes for post-installation goodies.
  2. For the Sound option, I did not choose anything - instead I later downloaded and installed the VoodooHDA drivers from its site. As I was not installing Sierra, the choices presented did not work with my particulars. If you are installing Sierra, follow Stork's recommendations.
  3. After MultiBeast installed certain kexts, the system gave an error message and then reset - resulting in a failed boot. If this happens to you, don't worry, it is easily fixed with a little work. If that happens, and if you boot in verbose mode (select a boot device, press spacebar, then "Boot in verbose mode") and have the last line shown being ACP or ACPI, then you have some kexts that didn't get registered correctly. They will need to be removed from L/E (not deleted, just temporarily moved elsewhere), then reinstalled with KextBeast. To fix this, you'll boot back into the installation, use Terminal (under Utility), and then remove those kexts from L/E to get back into El Capitan, then reinstall them with KextBeast. See this post. You can also find the proper terminal commands on the web (such as this one).
Clover Configurator

At this point you should have a running installation. You'll want to open Clover Configurator and set the FakeCPUID (in Kernal and Kext patchs) and also the SMBIOS information (use the Wizard to assist here) so you don't have to continually do so at boot time.

Clover Configurator will attempt to auto-open the default config.plist, however, if the EFI volume is not mounted, it will complain. It can initiate the mount for you (Mount EFI), and you'll then need to open the config.plist (bottom left icon). Be sure you are editing your installed version, NOT the version on the USB key.

Fixing On-board Graphics
After the software is installed, you will have a minimally operational version of macOS. There is still quite a bit to do. The first thing I tackled was the graphics.

In Clover Configurator:
  1. set the IntelGFXID to 0x19168086 (in Devices),
  2. the ig-platform-id to 0x19120000 (in Graphics),
  3. apply the "Skylake Glitch Fix," (Devices, Add Properties section):
    Device: IntelGFX
    Key: AAPL,GfxYTile
    Value: AQAAAA==
    Value Type: Data
  4. Next, in Acpi, in the DSDT section, add:
    Comment: Rename GFX0 to IGPU
    Find: 47465830
    Replace: 49475055
    Comment: Rename HECI to IMEI
    Find: 48454349
    Replace: 494d4549
  5. and install both FakePCIID.kext and FakePCIID_Intel_HD_Graphics.kext.
  6. reboot.
Fixing Hardware Sensors
Fixing the hardware sensors is pretty straight-forward. You simply need to install Rehabman's FakeSMC kexts. Then you can install Intel's Power Gadget, and also HWMonitor. If all is working, you'll get graphs on Power Gadget, and data in HWMonitor.

NOTE: CPU Power Management is fixed in the next section.

Fixing Power Management
Addressing power management requires a custom SSDT that gets put in Clover's ACPI->Patched folder. You'll generate this using the script. The script, and documentation, is here.

You'll use MaciASL to compile it, then put the compiled version in CLOVER\ACPI\Patched. It should be named SSDT.aml.

[The above was left in for posterity - it can be done as an interim step to the better method - just below.]

Please reference Rehabman's guide here. You will need MaciASL for this step.

Fixing USB Ports
Fixing the USB ports is a bit of a time-consumer. However, it isn't difficult at all to do. You'll need to use IO Registry Explorer.

For reference, see Rehabman's guide here.

Take the following steps:
  1. Open IO Registry Explorer and navigate down to the USB ports section. They'll have identifiers such as HSxx and SSxx (where "xx" is a two-digit number).
  2. Using a USB 2.0 key/device, plug it in to each port, noting the number in IORE & physical location on your computer.
  3. Do the same with a USB 3.0 key in each of the 3.0 ports.
  4. Next, you'll have to decide which ports you're willing to sacrifice - you can only have a maximum 15. SS ports count as 2 each.
  5. Now, following Rehabman's guide, create a custom SSDT that disables the required number of ports to get your system at or below 15 ports.
  6. Compile that with MaciASL.
  7. Place the compiled file in CLOVER\ACPI\PATCHED.
  8. Reboot
  9. In IO Registry Explorer, count how many USB ports are shown - there should only be 15 or less.
NOTE: It wasn't immediately obvious to me from reading the guide, so do note that USB 2.0 ports that correspond to an SS port should have a "USB Connector" value of 3. The guide notes the appropriate values for the ports otherwise.

Once you have a set of correct USB ports, you can then disable the port limit patch - Clover Configurator->Kernel and Kext patches->AppleUSBXHCIPCI patch. I chose not to delete it "just in case."

Fix SAT0 to SATA
You'll need to open Clover Configurator and add the following to the DSDT Patches section:
Comment: Rename SAT0 to SATA
Find: 53415430
Replace: 53415441
Reboot after applying the change. You can verify the change in IO Registry Explorer.

System ID
Before you can use iTunes, iMessage, iCloud, etc., you'll need to set the system IDs. To do that, I HIGHLY recommend you follow An iDiot's Guide to iMessage.

Upgrading to Sierra 10.12.4
To upgrade El Capitan to Sierra 10.12.4, see this thread. I did not have any problems with the upgrade.

Updating to Sierra 10.12.5
To upgrade El Capitan/Sierra to Sierra 10.12.5, see this thread. After applying the recommended kexts, then doing the upgrade, I did not encounter any problems.

What Works
Everything but what's in the next section.

What Doesn't Work
  • Sleep. - this is a known problem relating to the IGPU currently in use (5/26/2017 - now working due to different video card and native power management - see Updates below).
  • iTunes DRM movies. This is an HDCP problem and I think linked to my display, but not sure. (5/26/2017 - now working due to nVidia video card + lilu + shiki + -shikigva boot flag)
  • iBooks/XCode - with the nVidia Web Drivers, iBooks is broken due to a signing problem that nVidia cannot address as Apple controls the signature certificate(s) needed for that application. SEE 7/7/2017 UPDATE FOR FIX. XCode is resolved by using this method here. It is not possible to resolve iBooks with that method - the application will break.
  • Amazon streaming in HD - HDCP problem. While I have theories, bottom line is I do not know why this doesn't work. I remain uncertain if it is actually a hardware issue as there seems to be no test suite to determine the actual issue. I believe I have this working - once I found where to disable to the IGPU (see below where I added the nVidia card), Amazon no longer seems to complain. Sadly, it doesn't appear to have been fixed after all. Darn you Amazon!!!
Final Thoughts

It took me about a week to get this machine together, mostly because I was working with Rehabman to correct things, like the USB ports and power management, so the time was spent in forum-tag and research. Well-spent time I might add.

Do take the time to read Rehabman's guides, you'll find the information therein very useful.

Also, putting this machine together was an incredible experience and worth every minute!

The following benchmark is just for the CPU. The IGPU isn't really worth benchmarking. I will be putting in an nVidia 1070 card however, and may post a benchmark following that installation.

5/22/2017 - The system would not stay in shut down state - would wake up at some point. So, checked the "FixShutdown_0004" setting in Clover Configurator->ACPI->Fixes, first group. System now stays off.

5/25/2017 - "Installed" a Logitech MX Master mouse. Works brilliantly with the system OOB - Bluetooth even!

5/25/2017 - Installed an nVidia 1070 FTW2 card using the following method:
  1. In Clover Configurator, uncheck Graphics->Inject Intel.
  2. In Clover Configurator, check System Parameters->NvidiaWeb
  3. In Clover Configurator, remove ACPI->Rename GFX0 to IGPU and remove Rename HECI to IMEI
  4. In Clover Configurator, Graphics->ig-platform-id, remove entry.
  5. Save and exit Clover Configurator.
  6. Ensure proper SMC kexts are installed (see this post).
  7. Download & install the nVidia web drivers.
  8. Shut down & physically install the card
  9. Restart and go into BIOS.
  10. Disable IGPU and/or set the graphics to the inserted card (PEG). NOTE: On this board there does NOT appear to be a way to designate the PEG as primary and/or disable the Intel IGPU. I believe the presence of the card does that automagically, so I did not change anything in BIOS. I leave this step here in case someone else's board does have that option. In BIOS, you can disable iGPU by going to: System Agent (SA) Configuration > Graphics (under VT-d) > Primary Display. Set the Primary Display to PEG.
  11. Save & exit.
  12. Boot into macOS.
  13. Use the nVidia drivers.
  14. Rescaled display. NOTE: If you have strange window appearances, check that application for a theme - could be the theme (as was the case in Firefox after I resized its window - the theme didn't fit the new window size).
  15. Added Clover->ACPI->Change PEGP to GFX0. That came from this thread.
  16. Also, implemented this SSDT.
  17. Restart.
  18. If you have installed the VoodooHDA drivers as I have, you will need to re-configure the sound as it will have dropped due to the PEGP. Open System Preferences and reconfigure the VoodDooHDA section.
The video card appears to be operating normally - yay! And, it also fixed the iTunes HDCP problem. :)
And with that video card installed, the benchmark for the CPU has improved:​

5/26/2017 - Implemented native power management as per guide.
  1. Read and follow guide.
  2. As there were no power management selections that I made in Clover, there wasn't anything there to do.
  3. Remove the SSDT.aml patch (the one made from, and replace with patch from guide.
  4. Reboot.
  5. Follow RehabMan's checklist:
[ ] Check in ioreg that X86PlatformPlugin is loaded​
[ ] Use AppleIntelInfo.kext to check pstates (do a variety of tasks while monitoring)​
[ ] Run a benchmark (eg. GeekBench) to check for reasonable/comparable performance​
[ ] Test sleep/wake​
In my case, everything works now (AFAIK)!!!​
6/5/2017 - Installed an LG BH16NS40 BD/DVD reader/writer. This one also uses the super multi disk (128GB!), though I haven't tried it yet. Do not know if the super multi disk will work, and am not sure I can get 4k working (so far I haven't). The system recognizes the drive via a generic driver. Perhaps if I can get a "native" or "manufacturer" driver, things might be a little different. Plays Blu-Ray disks just fine in VLC! :)

6/14/2017 - The only problem I have with the case so far is that when the radiator fans spin up the grill cover rattles. I have my radiator mounted to the "ceiling". I'll have to work on silencing that part if at all possible.

6/14/2017 - A few minutes later... a small paper shim between the front clips and cover did the trick - silence is golden! :)

6/26/2017 - The rattling grille saga continues... The paper shims no longer did the trick, so I wrote Corsair about it. In the meantime, I left the shims in and removed the two screws that secured the grille to the case. The grille isn't going anywhere, so that's not a problem. The grille has ceased its rattling. I removed the screws as I noticed earlier removing them (to remove the grille) stopped the excess rattling. They must have relieved some sort of pressure which may have caused undue buckling in the grille components (nothing to do with the shims), hence the rattle. So, for now, it isn't rattling. We'll see what Corsair has to say on the subject.

7/7/2017 - Thanks to @pastrychef 's Gene build, iBooks now works by doing the following:
  1. Re-enable the on-board graphics as per initial build. You might also want to reference Pastrychef's post here.
  2. Make sure you have moved the Rename GFX0 -> IGPU PRIOR TO the nVidia PEGP -> GFX0!!! Otherwise, you'll end up with graphics card overlap and it won't work.
  3. Set the ig-platform-id to 0x19120000. 0x19120001 will NOT work with iBooks.
  4. Reboot, and temporarily move your monitor cable to the IGPU input. - no longer necessary.
  5. In BIOS, Advanced, System Agent (SA) Configuration > Graphics (under VT-d) > Primary Display -> AUTO, and set the DVMT Prealloc to 512 (1024 will NOT work!).
  6. Save & reboot, moving the monitor cable back to the nVidia card.
  7. At the present moment, iBooks will give you some icon glitches. Strangely, these seem to resolve themselves, but the Apple menu remains glitched when not selected. I think there is a fix for that somewhere... After a few reboots, all the icons seem to have fixed themselves. Clarity on the icon bug: If one switches books a few times (two or three will do), the reading pane corrects itself (must be a cache item), and quitting/restarting iBooks fixes the Apple logo. Goofy how/why that works, but that's Apple for ya... ;)
7/18/2017 - Thanks to user @mlg , this post, iBooks is now corrected. MLG wrote a kext that allows the nVidia drivers to be officially recognized by MacOS so they can load into protected space - all w/o violating security. WTG!!!

7/20/2017 - Updated the build to 10.12.6 successfully, but post-update needed a little work:

1. As an nVidia card is in my system, I had to change the required build. However, the method here did not work for me. Instead, I, ultimately, copied the kext out to the desktop, opened the Info.plist with XCode, made the required change (set IOKitPersonalities -> NVDAStartup -> NVDARequiredOS to 16G29), saved, installed kext via KextBeast (got the "improperly installed" error - ignore), and restart. This was done post-update, however, pre-update should work fine.
2. The update installed fine with no issues - I did not change any Clover configuration settings yet.
3. Post-update, I removed the FakeCPUID (Kernel and Kext Patches), disabled the Y-Tile fix (Devices ->Add Properties), changed the ig-platform-id to 0x59120000 as per here, and set the IntelGFXID to 0x59128086 as per here. InjectIntel remains TRUE.

7/21/2017 - changed ig-platform-id to 0x59120003. This enables QuickSync. With mlg's kext (above), I now have iBooks & QuickSync coexisting on my system.

Screen Shot 2017-07-21 at 7.46.40 AM.png

7/24/2017 -
Migrated from 14,2 to 18,3 as that more closely matches the hardware in-use. It is not necessary to do this as 14,2 does work. Please reference this thread before doing so.

The steps are:
  1. You may wish to back up your system.
  2. Mount your EFI partition.
  3. Duplicate your current Clover config.plist and rename it to config142.plist (or something so you'll know what it is). This is ultra-important in case you want to go back to 14,2 - you won't lose your working settings.
  4. Open Clover Configurator.
  5. Open your current config.plist.
  6. Change your SMBIOS to 18,3. This will wipe out your serial numbers, board id, UUID, etc.
  7. Save your config.plist.
  8. Quit Clover Configurator.
  9. Sign out of iCloud. You can save copies of the data iCloud suggests if you wish - I did.
  10. Reboot.
  11. Follow the Idiots' Guide to iMessage and re-generate the proper IDs for i-stuff usage.
  12. Everything else should work as before.
You will need RehabMan's updated USBInjectAll.kext to facilitate this sysdef.

Overall, my system performance hasn't really changed. Although I did notice that USB ejection works - previously it would get 'stuck.' Only time will tell as to whether this is a "proper" move or not. :)

NOTE: Handoff is not working. AirDrop is fine.

7/24/2017 - Handoff is now working. Problem was not in 18,3, but a "bug" in how Handoff operates. Fix was to open Bluetooth preferences on both the Hack and the iPhone (putting both in discovery/pair mode), and pair the devices. You'll get warnings about "can't connect to this network." Ignore that. Handoff started working immediately post a successful pairing.

8/4/2017 - Graphics card benchmark performed. GeekBench had an update, and it may be that the newer system profile also allowed it to function:


10/19/2017 - High Sierra Upgrade - "Growing Isn't Without Pain"

I've successfully installed High Sierra.

It took 1.5 days to do so - I had a few kexts to trouble-shoot (find and remove) and some learning to do. Please read through everything BEFORE you do anything.


  1. Install the latest version of Clover. Run that for a few days before moving to High Sierra just to be sure it isn't going to cause you trouble.
  2. Backup/clone your system at this point - just in case.
  3. Make sure you have the latest kexts installed. In particular, RehabMan has released (here) a new set of FakeSMC kexts that I've now got in place, replacing my existing sensor kexts with his builds. You'll also need to make sure you have the latest Lilu and Shiki kexts. I did download (and initially installed them), but am not now currently using, Intel/NVidiaGraphicsFixup kexts - they KP'd my system.

    Shiki is used for DRM protection in iTunes - you can't play protected content without it.

  4. If you wish, backup/clone your system again at this point - just in case.
  5. Make sure you do NOT have the NVidiaWebLibVal kext installed - it WILL KP your system.

    NOTE: You may wish to remove these kexts AFTER you have done the initial installation of High Sierra (or at the time of the first KP). You will have to go into Recovery mode, use Terminal, and manipulate the kexts at that point. Beware, though, it isn't for the squeamish and you should be a little comfortable with the command line. I spent quite a bit of time doing just that in Terminal over the past couple days.

  6. You also do not need NVidiaGraphicsFixup if you are running a 1070 card as I am. As noted above, this KP'd my system. I can't vouch for others, but, if you are using the web drivers with this system, you should not need it.
  7. Follow the Direct Update Guide. BE SURE to copy over the apfs.efi as directed!
  8. The tricky part is when you get to the NVidia drivers update. It should automagically update without a hitch except for an error message you will need to "continue" past. I would also update the CUDA drivers before restarting. As an extra added measure, I suggest opening a Terminal window (post driver installation) before restarting and type:

    sudo touch ./Library/Extensions/ ./System/Library/Extensions/
    I do not know if the above is needed, however, it can't hurt to do it.

    After installation of the drivers, if you choose not to "touch" the directories, restart your system. If you get a KP, be prepared for some Recovery & Terminal fun.
  9. If all goes smoothly, you should have your system back up and ready to go.
You might notice the Clover labeling is a little odd - mine display as "internal_hfs" (except for "recovery"). I don't know what the "fix" is for that, if any. You can still tell what the drives are by the names as you scroll through them.

Thanks to the mods - @BreBo, and @Stork, who's posts and pointers helped me quite a bit. And whoever it was that posted about the NVidiaWebLibVal being rolled into NVidiaGraphicsFixup and resulting KP if you didn't remove the former.

Hopefully I've not forgotten anything - it has been a long, essentially, 2 days...

11/08/2017 - High Sierra 10.13.1 Update
This version of updating went smoothly - be sure to read the update guide in the forum.

My steps:

1. Updated Clover Configurator.
2. Updated Clover (4289 as of the time of this writing).
3. Downloaded new APFS.efi (link in the forum guide post).
4. Copied new apfs.efi to Clover->drivers64UEFI
5. Used Carbon Copy Cloner to back up system.
6. Run the update via the App Store.
7. On reboot, be sure to boot from "Install macOS from Macintosh HD" (or similar language) to install the update - as per forum guide.
8. After installation, install new nVidia driver.
9. After reboot, install new CUDA driver.
10. Good to go!

11/09/2017 - Installed Latest Voodoo HDA
Updated VoodooHDA to 2.9.0d10 today.

NOTE: You may have to change the iGain setting to 0 (otherwise you get lots of noise, and it may not be changed in the control panel). This is done by copying the kext out of S/L/E, opening the info.plist in the kext, editing the iGain setting (in iOSKitPersonalities) changing the 90 to 0. Then use Kextbeast to reinstall back to S/L/E and L/E (I seem to have it in both places though not quite sure why - prolly only needed in S/L/E).

12/7/2017 - 13.2 Update
Ran the update. Be sure to install the latest apfs.efi, Lilu, and Shiki before running the update otherwise you'll get a KP and constant restart. Install went fine, updated nVidia web drivers fine, though CUDA complains of needing an update (at this point).

12/8/2017 - CUDA Update
NVidia released a new CUDA driver update (see this post). Preferences no longer complains about CUDA needing an update.

01/22/2018 - 13.2 Supplemental Update and Sound
From 1/15-1/21 I attempted to implement the "official" sound (AppleHDA) according to Toleda's guide in the sound forum. Unfortunately, it didn't work out. I did, in fact, brick my system for a while (my fault, I was trying to neaten things up and moved kexts into L/E that need to stay in CLOVER/kexts/other) until I found a method to obtain a download of High Sierra on my old iMac (thankfully!!! and so I could move those kexts from L/E back to CLOVER/kexts/other; I could NOT get in to MacOS any other way), otherwise, I might have been completely toast and would have had to reinstall from scratch (which would have SUCKED) then do a complete restore from my last good backup.

In the process, I DID manage to clean up Voodoo a little bit - somehow two copies of the files ended up in the works and I think were hosing system sleep. I am not sure how that happened. Part of the AppleHDA implementation is, of course, to get rid of all that, which I did.

So, in the end, I'm back on VoodooHDA as I was before, but with a more recent VoodooHDA kext than I had prior as well. Things seem to be alright soundwise though I'm not on AppleHDA.

The supplemental update installed without a hitch, and the updated NVidia drivers applied themselves as they usually do.

NOTE: As of this date Hardware Encoding is NOT functional, and VDADecoderChecker reports an error that I can't seem to resolve. When looking for an answer, I did see a note from NVidia that stated they don't support hardware encoding any more. I suppose when the price of the iMac Pro cards comes down to Earth, I may just have to leave my beloved NVidia card behind (this is a Mac after all) and put in an AMD card (shudder).


1. ALWAYS make sure you have a BOOTABLE MacOS 'something' that is current to your OS level that IS NOT your 'master' system.
2. Be careful what kexts you move and where - they all can't go in L/E and a number of them likely must be in CLOVER/kexts/other.
3. ALWAYS make sure you have a current, complete, backup of your system - you never know what might brick it when you try to make changes.

01/31/2018 - 02/01/2018 - 13.3 Supplemental Update and Sound
First, as the 13.3 update became available, I read through the guide to see what's needed to be done. In my case nothing seemed to be required - except for a backup, which Time Machine was politely obliging.

The update installed without a problem.

The sound issue still bothered me, so I decided to tackle it again. I noticed that when playing a movie in iTunes, the voice track would intermittently play. I wondered if this was either VoodooHDA or something to do with video hardware decoding. I figured I now knew more about configuring for sound than video hardware decoding, so I decided to start there.

While I never did figure out was actually wrong, I did get this working.


1. Completely remove all VoodooHDA related components, including from any Time Machine or CCC backups (and/or anything the system can directly reference). Reference.
2. Install a restored copy of AppleHDA.kext (put on desktop, using KextBeast to install to S/L/E). Reference. In High Sierra, using Pacifist, you can find AppleHDA.kext in the same directory into which it installs.
3. Undo any changes from previous attempts at getting sound working, if you have done anything.
4. If you have any AppleHDA references in your Clover Config.plist Kexts to Patch section, either remove or disable them (removing is generally recommended).
5. Rebuild cache & restart. All on-board audio references should be missing.
6. CodecCommander.kext, Lilu.kext, and Fake_PCIID.kext were already in place, . I don't know if they are/are not necessary (particularly CodecCommander.kext), but that's what's on my system. I have these in E/C/k/o. Restart if you install these.
7. Use option II.2. from the Audio guide, and ONLY II.2 - NOT 1 or 3. I put AppleALC in E/C/k/o.
8. Restart. You should have audio devices and no sound.
9. Edit your Clover config.plist as per #2, third bullet, in Quick Fix guide. I did not execute the first/second bullets.
10. Restart.

You should have sound.

02/02/2018 - BIOS update to 1203
Updated the motherboard BIOS to 1203 from 1009. Bit of a leap I must say. I tried to save my BIOS settings (you can do this under Tools), but, as I didn't fully grock how that worked, I effed that and had to start my BIOS setting from scratch (no biggie). The BIOS setup did freeze on me a couple times - I ended up saving part of the BIOS settings, rebooting, and continuing which cleared up the issue. I did, also, finally figure out how to save BIOS information, so, hopefully this won't happen again.

02/22/2018 - 10.13.3 Supplemental Update
Updated Clover Configurator, updated Clover to r4411, and applied the OS update. No problems to report.

04/02/2018 - 10.13.4 Update
Updated to 10.13.4.

Backup/clone your system first.


1. Update Clover Configurator (if using).
2. Update to latest Clover (if not already).
3. Copy latest apfs.efi to EFI>Clover>drivers64UEFI, replacing the existing apfs.efi.
4. Install latest Lilu, IntelGraphicsFixup, and NVidiaGraphicsFixup (new versions of the latter two are available as of the date of this post). Mine are in EFI>Clover>kexts>Other, so I just overwrote those versions.
5. If you want to backup/clone again, do so now.
6. In the App Store, go to Updates and start the update process.
7. Upon reboot, make sure the Installer is selected (Clover should auto-select that for you).
8. My system rebooted twice - so do expect that. First reboot was back to the installer, second reboot went into MacOS.
9. After installation, if using an NVidia card, you'll be prompted to install the NVidia drivers. Do so and restart.
10. After restart, you should also be prompted to install CUDA drivers if you are using them. If you were not prompted, go to the CUDA preferences. Install those drivers.

10.13.4 is now installed!

04/27/2018 - 10.13.4 Supplemental Update
Updated to 10.13.4 Supplemental Update

Backup/clone your system first.


1. Update Clover Configurator (if necessary).
2. Update to latest Clover version (if not already).
3. Copy latest apfs.efi to EFI>Clover>drivers64UEFI, replacing existing apfs.efi.
4. In the App Store, go to Updates and start the update process.
5. After reboot, make sure the Installer is selected (Clover should auto-detect that for you).
6. You may have one or two reboots - this is normal.
7. After installation, you will be prompted to install latest NVidia drivers (if using their card(s)). Do so and restart.
8. CUDA had not been updated as of the time of this writing, however, when it is, update that as well.

10.13.4 Supplemental Update is now installed!

06/04/2018 - 10.13.5 Supplemental Update
Updated to 10.13.5 Supplemental Update

Backup/clone your system first.


1. Update Clover Configurator (if necessary).
2. Update to latest Clover version (if not already).
3. Copy latest apfs.efi to EFI>Clover>drivers64UEFI, replacing existing apfs.efi.
4. In the App Store, go to Updates and start the update process.
5. After reboot, make sure the Installer is selected (Clover should auto-detect that for you).
6. You may have three reboots - this is normal.
7. After installation, you will be prompted to install latest NVidia drivers (if using their card(s)). Do so and restart.
8. CUDA had not been updated as of the time of this writing, however, when it is, update that as well.

10.13.5 Supplemental Update is now installed!

07/10/2018 - 10.13.6 Supplemental Update
Updated to 10.13.6 Supplemental Update

Backup/clone your system first.


1. Update Clover Configurator (if necessary).
2. Update to latest Clover version (if not already). !!! IMPORTANT !!! See note below about Clover!
3. Copy latest apfs.efi to EFI>Clover>drivers64UEFI, replacing existing apfs.efi.
4. In the App Store, go to Updates and start the update process.
5. After reboot, make sure the Installer is selected (Clover should auto-detect that for you).
6. You may have two reboots - this is normal.
7. After installation, you will be prompted to install latest NVidia drivers (if using their card(s)). Do so and restart.
8. I had a CUDA update available, so I installed that as well.

10.13.6 Supplemental Update is now installed!

Clover's version r4586 (and likely forward) may temporarily "break" your installation - it may render your machine non-bootable IF you do not have the following two files present in your drivers64UEFI folder: AptioMemoryFix.efi, and ApfsDriverLoader.efi.

The Clover group made a change that deletes "obsolete" files, but, does not supply the replacements. It removes OsxAptioMemoryFix drivers and now uses the above two files instead. With this change you also do not need to copy a new APFS.efi file each update - you may move/remove APFS.efi from the drivers64UEFI folder (I moved it to a safe place - just in case).

To prevent a problem, download those two "new" files from here and here, run the Clover update, then install the needed files in your drivers64UEFI folder if necessary.

For reference on this issue, see this thread.

08/28/2018 - Hardware Acceleration enabled.
For a long time now, I have not been able to get hardware encoding to show up as supported. That is now solved. Starting with Post #628, through Post #639, you'll see what was done. If you use @pastrychef 's Config, be sure to re-supply your various IDs & S/Ns in the SMBIOS section.

Also, some cleanup too - only have the custom USB port patch in the ACPI\Patched folder now, and a reduced number of supporting kexts in the CLOVER\kexts\Other folder.

DO update Clover Configurator and Clover itself before doing the above if you haven't already.

09/17/2018 - Vega64 Installed
Vega 64 card arrived over the weekend, so swapped out the NVidia 1070 FTW from EVGA for the MSI Radeon Vega 64 OC Air Boost card. Nothing needed doing in terms of system prep - just swapped the cards and turned the system back on. Screen settings/scale were preserved.

I also took the opportunity to clean the inside of the case - wow, a lot of dust. Not really visible through the side, however, definitely dusty. Semi-annual cleaning may be in order.

I can't remark on "system smoothness" yet, though with the current setup (minus the NVidia card), everything is operating as expected. There is a perceptible fan running on the video card. The Corsair Air case is like a European car on the road - you can feel every bump, and the case allows you to hear every noise. The fan isn't a horrible thing (definitely FAR less noise than the older server I have sitting next to me), but I may have to install that fan kext if I notice anything odd about it. The NVidia fans, if they ever even came on, were practically silent.

09/24/2018 - Vega64 Feedback
I am happy to report that everything is, indeed, smoother and working much better. Well, it should be, considering that Apple supports these chips natively. Yes, I did have to adjust the fans using a kext, and that made things a lot better.

I do wish that the NVidia drivers were better as I would prefer an NVidia card, but perhaps NVidia really can't do much about that.

So, if you are considering building your own machine, consider a Vega 64 instead - a reference style cooler is a safer bet than the non-reference variety.

09/26/2018 - Mojave
Updated to Mojave - no issues.


1. Back up system (I used Carbon Copy Cloner).
2. Update Clover.
3. Update kexts.
4. Download & install Mojave. I believe I had two reboots (I didn't count).
5. Enjoy Mojave!


10/8/2018 - Networking quit, resolved through kext updates
After a brief moment of "Oh, S***!" when both my WiFi and Ethernet stopped working this morning, the problem is now resolved.

WiFi mysteriously fixed itself after a third restart. Ethernet was resolved by installing the current version of IntelMausiEthernet.kext (2.4 as of this writing). While I was at it, I checked my other kexts and noted that FakeSMC.kext was also newer, so installed that (version 1800, and the associated sensor kexts).

11/13/2018 - 10.14.1 Update
When the patch for 10.14.1 came out, after ensuring Clover, Clover Configurator, Lilu, and WhateverGreen were up to date, installed the patch with no issues. Feel free to check out the patch thread here.

12/06/2018 - 10.14.2 Update

1. Backup/clone current system.
2. Update Clover Configurator.
3. Update Lilu, WhateverGreen, and AppleALC kexts.
4. Update Clover installation.
5. Backup/clone updated system.
6. Download & run the OS update.
7. System rebooted twice and installation proceeded without any issues.

10.14.3 Update
I'm sure when I did this, but, it went buttery smooth (after making sure all kexts were updated & Clover as well). Likely very close to when that update was issued as I try to stay on top of the releases.

04/04 - 04/05/2019, 04/09/2019 10.14.4 Update

This one's title is "Growing Isn't Without Pain!"

First, the story: It was a dark and stormy night... Just kidding! As the previous update went very well, I didn't think much of this one. Bad thinking. I read the update thread, seemed the usual update process - update your kexts and Clover and off you went into the sunset, no troubles. Boy was that wrong! I downloaded and began the installation process for the update and that seemed to go along swimmingly, until it KP'd after I believe it had finished and was on the final boot. After some attempts at trying to find the issue (I narrowed it down to graphics-related), I finally had to give in and seek help.

Enter @pastrychef - with his assistance I was able to get the machine back into business. It had finally actually started to load back to the desktop, however, I had the "second monitor" needed issue (needed to plug my monitor's other inputs into an HDMI port on the card so the system would display the desktop), and finally got backin. The proper procedure is below.

@manHands provided an (early?) release of WhateverGreen.kext (v1.2.8) that restored the iGPU. That, and with certain kext eliminations, now give me hardware acceleration - yippie!

10.14.4 introduces some under-the-hood changes, so be sure to back up/clone your system!

OK, second, the procedure (I use Clover Configurator, so this will be from that standpoint):

1. First, make sure to back up/clone your system (note that I didn't do this, thankfully wasn't needed) using your favorite tool, such as Carbon Copy Cloner.
2. Update Clover Configurator, "CC".
3. Update your kexts (CC has a "kext installer" that is much improved and is great to use).
4. Update Clover.
5. I suggest rebooting to make sure it all works, then backup/clone again.
6. Go back into CC and mount the EFI partition.
7. Go to your EFI drive, and in the Other folder, be sure to remove (or move to another folder location) all sensor kexts, and XHCI-200-series-injector.kext. You should have AppleALC.kext (if you are using that method for sound), Lilu.kext, WhateverGreen.kext (be sure it is at least 1.2.8, which you can find here if it hasn't been added to the CC kexts installation), IntelMausiEthernet.kext, FakeSMC.kext, and Vega_tab64.kext. Your setup may differ a little of course. The important thing is that any kext with "sensor" in it should be removed along with the injector kext as noted. You can always add the sensor kexts back and see if the system KPs (and you are comfortable using Terminal in Recovery Mode so you can fiddle with the kexts to get back in your system in case of KP).
8. Now run the udpate. It will reboot at least once, likely twice.
9. You should be good-to-go!

One final note - I did update the BIOS version to the latest whilst attempting to get back up and running, so you may wish to do so. Don't forget that when you do so, you'll need to re-configure the BIOS to proper settings. If you are going to update the BIOS, I suggest doing so before running the 10.14.4 update.

Update to 10.14.5

Overall: update went without issues (despite appearances).

1. First, make sure to back up/clone your system (note that I didn't do this, thankfully wasn't needed) using your favorite tool, such as Carbon Copy Cloner.
2. Update Clover Configurator, "CC".
3. Update your kexts (CC has a "kext installer" that is much improved and is great to use). I only needed to update AppleALC.kext.
4. Update Clover.
5. Start the update.
6. There will be 3 restarts - 1 initial, 2 during the update. Expect purple lines during each restart past initial up to the log-in screen.
7. You should be good-to-go!

Purple lines did appear during the installation, as well as post-installation to initial log-in post installation. Admittedly, expected the first set of purple lines, but not the second, nor the third set - a bit freaky, but all went well - progress bar continued to move during the installation phase with the lines on the screen. The last set, prior to log-in, was a bit scary as the screen blacked out for a bit, though the hard disk light kept going. I left it alone and the log-in screen eventually came up - whew! :D

The first set of purple lines led to an update progress screen showing 37 minutes remaining, the second led to one showing 44 minutes remaining. I point this out as it appeared the system reached a kp and simply rebooted back to the initial update phase. Thankfully it had not.

Update to 10.14.6

Overall: update went without issues (despite appearances).

1. First, make sure to back up/clone your system (note that I didn't do this, thankfully wasn't needed) using your favorite tool, such as Carbon Copy Cloner.
2. Update Clover Configurator, "CC".
3. Update your kexts (CC has a "kext installer" that is much improved and is great to use). Updates were needed for Lilu.kext, Whatevergreen.kext, and AppleALC.kext.
4. At the date of this writing (7/31/2019) DO NOT update Clover. Clover has a directory change under the hood and it may cause your system to not boot. There are notes about it in the 10.14.6 thread.
5. Start the update.
6. There will be several restarts. Expect purple lines during each restart past initial up to the log-in screen. At the final stage, your screen may be black for a while - don't panic, give it time, your login screen will display in a few minutes.
7. You should be good-to-go!

10.14.6 Supplemental Update

Backed up via Carbon Copy Cloner then ran the update. The update installed without issues, just like the standard update did.

10/08/2019 Clover 5070, 10.14.6 Supplemental Update & Attempted Catalina Upgrade

The last addressed first: failed with prohibited symbol, still watching for a fix.

Clover 5070

This was a scary update. Why scary? Well, getting to the EFI partition to change things is a little rough, and, not knowing what may break is another. However, this process was made MUCH easier as a result of this excellent "How To" thread. The short of it is, Clover changed some structure, dropped some drivers, and that made things a little trickier.

Here is the short process:

1. Backup your system using your favorite tool, such as Carbon Copy Cloner.
2. Update Clover Configurator, "CC".
3. Using CC, or your favorite updating tool, update your kexts, or, if you prefer, make sure you have located the current kexts and copy them over manually to the proper places. I had to update Lilu, Whatevergreen, and AppleALC.
4. Copy your EFI folder to <your system drive>/EFI-Backups/<your chosen backup folder name> - so you can find this later as you'll need to do some copying.
5. Drag the CLOVER folder in your mounted EFI driver to the trash and empty the trash.
6. Using CC, download and *begin* the install process for the latest Clover.
7. When you get to Installation, click Customize.
8. Have your Finder view set to your EFI-Backups/../Clover folder and begin to match up your drivers to what's in the installer (refer to the thread previously linked) using your Finder view as the reference.
9. After matching everything, run the installation.
10. After installation, now you'll need to copy over the ACPI->Patched files, config.plist, Kexts->Other files, driver64UEFI files (to the drivers/UEFI folder in the new version) that are missing/needed, and your theme information.

Once that is done, you should be good to go for a reboot (after double-checking everything to ensure nothing is missing) and get back into MacOS.

10.14.6 Supplemental Update

I thought I had done this, but, apparently not. After updating Clover & kexts as above, this update proceeded without issue. Safari also updated at the same time. It did take a little while.

10/09/2019 Catalina Install

Installed Catalina today. As my system was up-to-date per yesterday's work, the only thing I had to do was use the Clover facility to rename EC0 to EC and the installation proceeded without issue.

Why: USB power, etc., must be critical to Catalina. I had EC0 in my ACPI segment and it was returning TRUE, so I had to use the rename facility in Clover (set that patch using Clover Configurator). No SSDT_EC.aml needed in this case.

For details, see this post. You will either need to rename EC0 (or H_EC), OR, use SSDT_EC.aml if neither EC0 or H_EC are present in IORegistryExplorer OR EC0 (or H_EC) _STA is set to FALSE (0).

To determine if _STA is set to TRUE, look for 0xfffffff as that is an unsigned INT for "true" (that part may not be clear to some people).

Once I renamed EC0 to EC, the installation took about 45 minutes to complete.

10/22/2019 10.15 Supplemental Update

Installed the 10.15 Supplemental Update today.

1. Checked for Clover/kext updates. Clover, while at 5097 (I'm on 5070), was not compatible with my current macOS, and all the kexts were up to date, so there was nothing to do there.
2. Restarted to install the OS update.
3. Selected the Install macOS Preboot on Preboot. Interestingly, Clover did no auto-select this option, so I had to repeat step 2 and manually select it.
4. After Step 3 reboots, select the Preboot again - NOT the "Data". Installation/update will continue.
5. After Step 4 completes, reboot and proceed with normal startup.

11/1/2019 10.15.1 Update

Updated to 10.15.1 late last week.

Needed to download the linked kexts - Lilu, AppleALC, and WhateverGreen as linked through the post here as Clover Configurator didn't see the updated kexts.

Once backed up, I started the update process. As per the previous update, had to manually select the Install Preboot on Preboot drive to begin the installation process, and after the reboot, did so again.

Update installed without any issues.

12/18/2019 10.15.2 Update

Updated to 10.15.2.

1. Back up your system. I use Carbon Copy Cloner. This is SOP when doing updates.
2. Updated Clover Configurator.
3. Updated Clover to version 5100 (choose "Install anyway" if given the compatibility warning during that update).
4. Update, via Clover Configurator, Lilu, WhateverGreen, and AppleALC kexts.
5. Install the update. System will reboot twice and then you should be good to go. If Clover does not automatically choose the "Installer Preboot from Preboot", you must choose that on both reboots.

Update installed without any issues.

Happy Hacking! :)




Thanks for reading my build guide and happy hacking! :D


Last edited:


Staff member
Sep 21, 2010
RX 580
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
Very good build description. <blush>Thank you for the kind words on MyHero build description.</blush>

Welcome to the HERO Club! :thumbup:


Jul 31, 2012
HD4600 / RX 570
iMac, Mac mini
Mobile Phone
How about calling it the MyHero II ? With Stork's permission of course. If I needed a new rig this is what I'd be building. Unfortunately all of my many builds are running flawlessly. Can't justify it.


Staff member
Sep 21, 2010
RX 580
MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
How about calling it MyHero II ? If I needed a new rig this is what I'd be building. ....
LOL! Maybe MyHero9 for the Z270 version. Naw. I like his name of Heroica...sorta sounds like a Greek goddess. :clap: (...although I think it's LEGO game character name.)


Jul 31, 2012
HD4600 / RX 570
iMac, Mac mini
Mobile Phone
LOL! Maybe MyHero9 for the Z270 version. Naw. I like his name of Heroica...sorta sounds like a Greek goddess. :clap: (...although I think it's LEGO game character name.)
Yeah, I agree, Heroica is just fine. Whatever it's called it's a very good user build description for those making the jump to Kaby Lake and a 200 series Hero board. Nice job JC. :thumbup:
Last edited:
Apr 4, 2017
Vega 64
Mobile Phone
Thank you @Stork , @trs96 , and @arehep . :D

This is my first build and write up.

Trs96 - any relation to a TRS 80 Model I???