[Success] ASUS TUF Gaming Z490-PLUS - i9-10850K - Saphire Radeon RX590 Nitro+

Montery is working fine on my new Hack. I'm actually on a H570 Phantom Gaming 4 from Asrock. And that also has a i219 NIC which is working just fine. Success with your new build. B.t.w. updating your EFI is very easy nowadays with OCAT Tools. Search for the Guide on Tonymacx86.
So, how did you get past the high CPU frequency/high temps with SMBIOS iMacPro1,1 ?
When running SMBIOS iMac20,x then my CPU is idling normally and temps drop about 5 degrees Celsius. but iMacPro1,1 the CPU is idling at Mac turbo frequency which is obviously not a good thing for the CPU. Any help would be greatly appreciated.
That sounds strange. When I did use iMacPro 1,1 there was no difference in CPU temps. Even the CPU idles @ 800MHz and not 1300 MHz which seems to be normal on a Mac but is too much for Intel specs. May be you made a mistake when editing your config.plist? Do you use plist editor or other OCC for that? OCC sometimes changes a value in CPU setting when changing SMBIOS I do remember.
Planet X - Comet Lake Beast - OpenCore - Big Sur 11.1
ASUS TUF Gaming Z490-PLUS - Intel Core i9-10850K - Saphire Radeon RX590 Nitro+ SpecialEdition


ASUS TUF Gaming Z490-PLUS TUF Gaming Z490-PLUS

Intel i9-10850K Comet Lake 10 core 3.6 Processor i9-10850K-Processor

Corsair Vengeance RGB PRO DDR 4 32GB C15 Vengeance RGB PRO 32GB C15

Samsung SM961 256GB PCI Express 3.0

Samsung 970 EVO SSD 512GB PCIe M.2 NVMe 970 EVO SSD 512GB PCIe M.2 NVMe

Addlink S70 NVMe PCIe Gen3x4 M.2 2280 SSD, S70 1 TB S70 NVMe PCIe Gen3x4 M.2 SSD, S70 1 TB

Saphire Radeon RX590 Nitro+ Special Edition 8 GB GDDR5 Radeon RX590 Nitro+ Special Edition

Thermaltake Core V41 Mid-Tower Gaming case Core V41

Sharkoon SATA QuickPort intern multi 2.5/3.5 sata

Be quiet! Pure Power 11 600W Power Supply quiet! Pure Power 11 600W

Cooler Master MasterLiquid ML240R RGB

LG 32UN650-W UHD 4k Monitor 32UN650-W

View attachment 503296 View attachment 503297


  • Jeipiika [Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OC
  • Jergoo's ROG Strix Z490-I guide
  • scope666's ROG Strix Z490-E guide
  • OpenCore, Lilu, WhateverGreen, AppleALC, VirtualSMC from Acidanthera
  • Dortania's OpenCore guide, and the myriad resources therein

The Build
Because of my previous H470 build always presented me a Mass storage icon in the Menubar of macOS I have decided to exchange my motherboard with the Z490 version of the ASUS TUF Gaming series. I could use my previous EFI and OC config.plist files to get my Asus TUF Gaming Z490-PLUS with an i9-10850K to work.
Everything works great. The system is Rock Solid and also does sleep very well. Also the annoying Mass storage icon is gone for good.
Sound and Graphics and Bluetooth and Wi-Fi is working fine. The CPU is scaling too from 800MHz to 5,2GHz.
I use the Intel Power Gadget and iStat Menus for monitoring my system. That also shows me the Fans and a lot of worthy information.
The Acidanthera team has done a great job to prepare the Installation Guide for us and they do maintaining the kext updates in a monthly schedule. Kudos for that.

These are the BIOS settings I have used:

  • Fast Boot
  • CSM
  • Set the secure boot config to Other OS
  • Serial/COM Port (not present)
  • VT-d (left it enabled you can set DisableIoMapper in OC to Yes - but even that isn't needed)
  • Thunderbolt (not in use)
  • Intel Software Guard Extensions (SGX - has no use in macOS)
  • SR-IOV (no use on macOS)
  • Intel (VMX) Virtualisation Technology (VT-x)
  • Intel SpeedStep
  • Intel Shift Technology
  • Above 4G decoding
  • Hyper-Threading
  • Execute Disable Bit
  • EHCI/XHCI Hand-off
  • OS type: UEFI Mode (Other OS under Secure Boot)
  • SATA Mode: AHCI
  • Graphics Configuration > PCIE only
CFG Lock is disabled by default. There is no CFG Lock setting in the BIOS anymore on the 400 series ASUS boards.

Wi-Fi and Bluetooth does work with the Fenvi FV-T919 BCM94360CD BT4.0 card which is natively supported by macOS.
After the installation of the Fenvi FV-T919 BT/Wi-Fi card I have to say it makes my build complete. AirDrop started working immediately and even with Wi-Fi and Bluetooth enabled the PC sleeps and wakes as it should be. Wi-Fi is very fast and reaches the full speed of my internet connection.

OpenCore is my preferred Bootloader. My EFI is attached below. Please use your own ROM and Serials in PlatformInfo. I have removed my personal data.

I have created a USBMap.kext with the help of the Dortania guide. With the help of SSDTime tool I have made a dump of my DSDT from Windows and have used SSDTime tool to build my ACPI SSDT patch files. See below.

I have to use the following files in OpenCore:
View attachment 504668

USBInjectAll.kext is in there but not enabled, as I might have to use it later to do changes to my USBMap.kext.

I use iMacPro 1,1 as SMBIOS as that has no problems with DRM. It's also the best SMBIOS to use when you're only using a dedicated graphics card. It has also the opportunity that the CPU idle frequency is scaled @800MHz, which is the default for the Intel CPU.

Hackintool PCIe:
View attachment 503388

Sleep settings:
View attachment 503293

A first benchmark:
View attachment 503391

What I also had to learn was the fact that Big Sur doesn't like a disk Volume HFS+ with Backup as name. I have had that for years, but now, on Big Sur, my Time Machine backup was failing. I couldn't even unmount the disk as it is in use by the kernel. That did tell me that it will have to do with Time Machine. So I did start Catalina from a backup disk and did erase the Backup Volume. After that I have created an APFS Volume with a new name and added a second Volume with the name Backup to the same disk. Now Time Machine does work fine again and I finally have my last NVMe drive also APFS formatted. Thank you Apple.

Because we have the possibility to have Linux on macOS as well I did install Homebrew and neofetch.
Doesn't it look great?
View attachment 503291

I did update my SMBIOS to iMac 20,2 for a tryout and figured out that it does fix my Geekbench score for my RX 590 after a cold boot. It always has been 20.000 points less after a cold boot than after wake from sleep. I have learned that switching to iMac 20,2, and enable the internal graphics with Multi Monitor enabled in the BIOS, did fix that issue with Geekbench for the Graphics performance. Now I always have a ~ 55.000 Metal score after boot. Before that has been around 37.000. I have also tried to see if enabling IGfx HD630 was the cause, but on iMac Pro 1,1 the issue kept the same. From now on I'm using iMac 20,2 SMBIOS. The CPU idle frequency is 1,3GHz but I also have found on the internet that a real iMac 2020 has 1,3GHz as idle too.

2020-12-30: Just updated the OpenCore EFI to 6.4. This time I have also disabled the Kernel patch F1 for RTC as you can also use a OC Kernel Quirk DisableRtcChecksum and set to Yes. See attachments.

2020-12-31: I will start to enjoy my new build and will update the guide later. Stay Safe and good luck.

2021-01-01: Happy New Year 2021! Stay healthy and much of luck to you!

2021-01-02: Updated SSDT-SBUS-MCHC.aml in EFI/OC/ACPI as sample has been updated too.

2021-01-05: Updated OC to 6.5 and updated WhateverGreen.kext, AppleALC.kext, IntelMausi.kext and NVMeFix.kext too. Attached new EFI below.

2021-01-11: Disabled HPET in SSDT-AWAC-HPET as it seems to be not used by Apple anymore. No more IRQ patches are needed in ACPI too. Attached a new EFI below.

2021-01-14: Updated USBmap.kext with 2 more ports on the backside next to the LAN port. Also updated the attached EFI.

2021-02-05: Updated OpenCore to 6.6 and attached new zipfile Also disabled tcpkeepalive in terminal with sudo pmset -a tcpkeepalive 0 for a better longterm sleep.

2021-02-13: Updated EFI because of switch to iMac 20,2 SMBIOS.

2021-02-14: Did find out that SSDT-RHUB isn't needed for my board. There is no RHUB in IOJones. Uploaded new EFI. Also enabled DisableIOMapper as macOS does not use VT-d yet. Boots a bit faster too now.

2021-03-07: Updated EFI because of update OC to 6.7. Also I did switch back to iMacPro 1,1 SMBIOS.

2021-04-06: Updated OpenCore to 6.8 with all kext and drivers updated too. Also returned to iMac20,2 SMBIOS.

2021-05-08: Updated to OpenCore 6.9 and updated Kexts and drivers too.
I did switch back to iMacPro1,1 SMBIOS again because of it also does support drm. If you use the USBMap.kext from my EFI please edit the plist in it to match your SMBIOS. It's written twice in there. The new EFI is updated in OP again.
Hi @GeraldB

Wanted to thank you for posting all the detailed information and files, your usbmap.kext file and detailed info has helped me sort out my USB 3.0 on my ASUS TUF Gaming Z490-Plus WiFi motherboard which has caused me problems over the weeks, i am sure i will use your post as a reference point in the future.

Thanks again,

Steve :thumbup:
Hey GeraldB ! It's been a while hehe !
So a couple of years later, I'm still using the same config. I've bought a USB bluetooth adapter, and my Hackintosh works like a real life mac and i'm so happy about it, can't thank you enough really.
I was wondering if you updated your BigSur to Ventura ? I've been looking into it, but I'm quite scared to get the update off the ground... lol
I'm already on Ventura indeed. Just use OCAT (search for the guide on this forum) and upgrade to the latest OpenCore version before upgrade to Ventura.
That sounds awesome. I successfully managed to boot in Monterrey yesterday, and faced quite some drama (random freezes after a few minutes -> fixed removing FAKE_PCIID kexts & adding e1000=0 to boot-args). Now I'm fixing a few things like audio (again), Bluetooth (again) and iServices (again) lol, then I'll upgrade to Ventura. Good to hear from you !
That sounds awesome. I successfully managed to boot in Monterrey yesterday, and faced quite some drama (random freezes after a few minutes -> fixed removing FAKE_PCIID kexts & adding e1000=0 to boot-args). Now I'm fixing a few things like audio (again), Bluetooth (again) and iServices (again) lol, then I'll upgrade to Ventura. Good to hear from you !
adding e1000=0 to boot-args shouldn't be needed for a i219-V Network adapter on your board You only need Intel_Mausi_kext from Also Fake_PCIID shouldn't be needed. For Bluetooth I hope you are using a Fenvi card? The integrated Intel should be disabled as it will give troubles with updates.
Yo GeraldB !! LOL I followed your advice and this time, well, unfortunately it broke my system haha ! So basically, you can remove Fake_PCIID for IntelEthernet but you should NOT remove FakePCIID.kext. I've had to get my hands on another mac and edit my config. Bluetooth using my Fenvi T919 and iServices were fixed "magically" when I erased my mac from the recovery assistant, and reinstalled the software from the legit installer from the mac app store. I'm still wondering what's up with the random freezes, but you know what, the machine boots, so I'll be able to fix it.. I guess ^^ Thanks for your help man you're really knowledeable in the field and you definitely are the main person to thank for having a Hackintosh running Ventura. Cheers
Hello GeraldB and itsneydude

I hope you're well
Thanks for posting and sharing all your feedback.
I'm stuck trying to update to monterey or ventura.
I've a fully functional system running under catalina.
But I have to update to monterey or ventura because my plugins are not supported anymore on old macos.
I tried to follow opencore guide but I failed to build a functional EFI.
Do you what should I copy/ paste from my old EFI what are the new kexts or strings I should modify to get the installation to finish.
I'm a noob so please be gentle.

Thanks for your help,