Contribute
Register

[SUCCESS] Asus Strix H370-I Gaming Big Sur Open Core

Joined
Mar 27, 2014
Messages
8
Motherboard
Asus Rog STRIX H370-I Gaming
CPU
i3 9100
Graphics
Intel UHD 630 (MSI Radeon Rx580 Armor 8gb - not installed for now)
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
System definitions:
  • Motherboard: Asus Strix H370-I Gaming
  • CPU: Intel Core i3 9100
  • RAM: 16gb DDR4 Kingston HyperX 3200
  • SSD: Kingston A2000 500gb x2
  • Video: MSI Radeon RX 580 8gb Armor OC

Fully working onboard Wi-Fi, Bluetooth, sound, sleep/wake, double-boot with Windows (on separate ssd's).
EFI folder in attachment.
 

Attachments

  • EFI.zip
    85.9 MB · Views: 246

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
5,688
Motherboard
Gigabyte Z390M Gaming - Clover 5102
CPU
i5-9600K
Graphics
RX 570 1920x1080
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. iOS
I would love to understand what you did to make that happen
Hi there.

Take a look inside the EFI archive that is uploaded and all will be revealed. There are a pair of bluetooth injector kexts and an Intel wifi kext in there.

Support for Intel wireless chipsets is in its infancy but many people are working on it. There is even a thread here about the work being done.

:)
 
Joined
Feb 28, 2019
Messages
34
Motherboard
ASUS ROG Strix H370-I Gaming
CPU
i7-8700
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. iMac
  2. SE
Mobile Phone
  1. iOS
Hi there.

Take a look inside the EFI archive that is uploaded and all will be revealed. There are a pair of bluetooth injector kexts and an Intel wifi kext in there.

Support for Intel wireless chipsets is in its infancy but many people are working on it. There is even a thread here about the work being done.

:)
Wow! It works indeed. Thanks so much, UtterDisbelief
 
Joined
Apr 20, 2012
Messages
20
Motherboard
Asus Rog Strix H370-I Gaming
CPU
Intel i7-9700F
Graphics
AMD Radeon RX 570 8 GB
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi! Really thanks for sharing your experience: I finally managed to install Big Sur using the EFI folder you posted but I still have one issue. When I logged in Big Sur for the first time, USB ports were working but now not anymore, since my second log in. My keyboard and mouse don't have any problems but if I connect a USB drive I can't see it in the finder (I checked all the USB ports). This precludes me from making backups.
 
Joined
Mar 27, 2014
Messages
8
Motherboard
Asus Rog STRIX H370-I Gaming
CPU
i3 9100
Graphics
Intel UHD 630 (MSI Radeon Rx580 Armor 8gb - not installed for now)
Mac
  1. MacBook Pro
Classic Mac
  1. Apple
Hi! Really thanks for sharing your experience: I finally managed to install Big Sur using the EFI folder you posted but I still have one issue. When I logged in Big Sur for the first time, USB ports were working but now not anymore, since my second log in. My keyboard and mouse don't have any problems but if I connect a USB drive I can't see it in the finder (I checked all the USB ports). This precludes me from making backups.
Hi, probably you should do your own port definition according to Open Core guide. But i also saw that not all ports are working for me. Will check if I can do something with it.
 
Top