Contribute
Register

[Success] Asus Sabertooth z87 i7-4970K

Joined
Jul 18, 2017
Messages
1
After 4 days, I did it! You can also find this post here:
http://slapmyself.com/2017/07/22/hackintosh-sierra-installation.html

My Hardware spec

Motherboard ASUS Sabertooth Z87
CPU Intel i7-4790K
HDD Samsung 850 EVO 500GB(new ssd dedicated to osx)
Graphics MSI GTX 970
USB driver SanDisk 64GB USB2.0

BIOS settings is the key to start.
Before installing, please update your BIOS firmware to the latest version, and load the default settings.

My BIOS settings:

Legacy USB Support -> Auto
EHCI Hand-off -> Enabled
Intel xHCI Mode -> "Smart Auto" / "Enabled" both works
OS Type -> Other OS

Above is my bios setting(note the setting values is on the left, in order to show the settings in one screen I used load default and show changes function)

If your USB drive boots to a blinking/static cursor and stuck there, it’s very likely you have wrong BIOS settings.

Also pay extra attention to the “OS Type” setting, it is not enough to just change is to “Other OS”, if it still says enabled. You need to delete a bunch of keys and stuff so it shows up as disabled. Below is a screenshot to explain the “OS Type” setting, if you see the “disabled” text, you are good.



I wasted 95% of my time thinking the USB drive I created was somehow not working and try to create either with another USB drive, or simply just re-run the creation process. However, they are all caused by bad BIOS settings, so please be patient and try different BIOS settings if you have problem booting the USB drive. Especially since creating USB drive take a lot of time(even worse for USB2.0).

The Installation
The following 2 guides are my main references. I’ve tried both, and both works. The first guide is a more automated approach, you should use it as your first try. The second one is a bit more manual, but also seems to be a little bit more reliable. Use the second one if you are more familiar with command line and computer in general.

https://www.tonymacx86.com/threads/how-to-install-os-x-yosemite-using-clover.144426/https://www.tonymacx86.com/threads/unibeast-install-macos-sierra-on-any-supported-intel-based-pc.200564/

If you have any other issue when installing, consult this list of issues(the big list) first:https://www.tonymacx86.com/threads/big-list-of-solutions-for-el-capitan-install-problems.173991/

If you followed the second guide, one small thing to clarify: After the 1st reboot you will use usb drive to boot again, during that boot, you need to select the “boot from Install < os version> from < your hard drive>” option. Not the option you did for your first boot to USB, not the option that directly boot system from the hard drive, but the “install” option from the hard drive. This way, the installer can finish the install.

Problems I encountered during installation and how I fixed them

  1. Blinking/static cursor on the screen when booting the USB drive
    Solution: Use the BIOS setting mentioned before. If you have the same issue, but have a different set of BIOS settings, try tweak different settings.

  2. Keyboard not responding in clover screen
    Solution: same as above
Post installation
Follow the 2 guides to install bootloader to the hard drive of your system. The main thing you need to do afterwards is to find out what is broken and fix those, usually by installing drivers/kexts. Multibeast is the perfect tool to do that, BUT, a rule of thumb: ONLY install things you found broken, multi-beast made it easy to try to be lazy and just select everything, but that is very likely going to break your system. If you did break your system by doing that, there are ways to use recovery partition to fix things, but I personally ended up re-installing the whole system. You can also use clover configurator to install drivers.

Problems I encountered after installation and how I fixed them

  1. Auto reboot at apple logo
    After installation, when I boot from the SSD, the system shows the Apple logo with black background, and proceeded to reboot it self after a few seconds. When verbose mode is enabled, the screen shows a few lines of text with a row of plus sign at the end, and then reboot.
    Solution: Please refer to the “row of plus” section in “the big list” mentioned before.

  2. Graphics driver
    Solution: Since my card is GTX 970, I downloaded Nividia web driver. For older OSX install, you can find the driver by directly searching the os version and card online, or find it here:http://www.macvidcards.com/drivers.html For latest version, please refer to: https://www.tonymacx86.com/forums/graphics.13/ for latest drivers and installation tips.

  3. Audio
    Solution: After installation, sound won’t work for me, then I used Multi beast to install the Realtek driver, for me it’s ALC 1150

  4. Function keys not working
    My functions keys are actually the media keys(volume up/down, illumination up/down, etc). However, I usually like to bind function keys to stuff in Vim. The “preferences > keyboard > use F1, F2….” approach won’t work since that option is not in my keyboard preferences(probably because my keyboard don’t have a designated fn lock key?).
    Solution: Karabiner solved the problem. It has a nice option to use function keys just for function keys. It can also be used to swap ESC and CapsLock ;)

Final words
I also have an SSD installed with windows I use on a day to day basis. After spending the past few days working on this, I’m too tired to fix the clover boot to be able to boot my windows drive, so I ended up setting the windows drive as my default boot drive, and use manual bios selection to switch to OSX when needed.
 
Top