Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Aug 25, 2015
Messages
101
Motherboard
MSI Z490i Unify
CPU
i9 10700k
Graphics
Radeon Vii
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Nevermind, I didnt look close enough at the config. After a little rework i got through the install. Thanks alot for the help and the efi! Now i just got to put a bow on it :thumbup:.
IMG_20211026_001303438.jpg
 
Joined
Aug 23, 2012
Messages
393
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Maybe it is paradox but ONLY if I have the iMac201_USBInjectAll_v0.7.5_z490.kext active the USB-C Audio Adapter works!

Perhaps you can use Hackintool to export a USBPorts.kext while you have it loaded so you can tweak your map, maybe the definition for that particular port is just a little different.
 
Joined
Aug 25, 2015
Messages
101
Motherboard
MSI Z490i Unify
CPU
i9 10700k
Graphics
Radeon Vii
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
anybody have any issues with usb 2's not working? I have 1 internal usb 2 going to my front ports and they are the only ones that recognise my mouse, keyboard, usb headphones and usb 2 drives. Even when using usbinjectall kext none of the usb 3 ports on the back recognize any of these at all??? I went through the mapping process twice just to be sure but still no usb 2 recognition in the back ports.. Any ideas?
 
Joined
Aug 23, 2012
Messages
393
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
anybody have any issues with usb 2's not working? I have 1 internal usb 2 going to my front ports and they are the only ones that recognise my mouse, keyboard, usb headphones and usb 2 drives. Even when using usbinjectall kext none of the usb 3 ports on the back recognize any of these at all??? I went through the mapping process twice just to be sure but still no usb 2 recognition in the back ports.. Any ideas?

Do you have the board mentioned in this thread?

Asus ROG Strix Z490-E Gaming

Your signature says otherwise.
 
Joined
Aug 25, 2015
Messages
101
Motherboard
MSI Z490i Unify
CPU
i9 10700k
Graphics
Radeon Vii
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
No its the asus z490 proart. I tried updating my sig a couple times over the last days but its not saving it for some reason.
 
Joined
Aug 25, 2015
Messages
101
Motherboard
MSI Z490i Unify
CPU
i9 10700k
Graphics
Radeon Vii
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac Pro
Classic Mac
  1. iMac
Mobile Phone
  1. Android
Do you have the board mentioned in this thread?

Asus ROG Strix Z490-E Gaming

Your signature says otherwise.
No its the asus z490 proart. I tried updating my sig a couple times over the last days but its not saving it for some reason.
 
Joined
Aug 23, 2012
Messages
393
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Here's a build of 0.7.5 with all the latest kexts that was released today:

version.png


kexts.png


Bash:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.7.5-RELEASE/Utilities/ocvalidate

craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

Completed validating /Volumes/EFI/EFI/OC/config.plist in 1 ms. No issues found.
 

Attachments

  • EFI 0.7.5.zip
    10.2 MB · Views: 104
Joined
Aug 5, 2014
Messages
292
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Here's a build of 0.7.5 with all the latest kexts that was released today:

View attachment 532925

View attachment 532926

Bash:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.7.5-RELEASE/Utilities/ocvalidate

craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

Completed validating /Volumes/EFI/EFI/OC/config.plist in 1 ms. No issues found.

It works 100%, thank you very much for the effort.

Just I lost the rear USB-C port for the Apple Audio USB-C Adapter which I have also with the rear USB-C port as active if I use the iMac201_USBInjectAll_v0.7.5_z490 Kext. On the other side, with this kext the front ports doesn't work with some USB drivers.

Is there a way to have both USB-C as with the iMac201_USBInjectAll_v0.7.5_z490 AND front ports works as with the USBPorts? How can I do that?
 
Last edited:

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,961
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
@hemon and @ac9001 USB port mapping has gotten a lot harder since Big Sur 11.3. Using any version of USBInjectall.kext and XHCIPortLimit quirk with Hackintool will not recognize all of the ports and or configure them properly. I've got a couple of Z590 boards and had to resort to loading Catalina and then used a combination of CorpNewt's USB Mapping tool and Hackintool. Even then all the ports were not correctly identified by type, stuff like the wireless bluetooth card and the LED Lighting controller were shown as USB3 when they should be classified as internal ports. I had to manually change those myself, it was a chore. It may be slightly easier with your respective Z490 boards and you be able to get away using the USB Mapping Tool

 
Top