Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,836
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hello scope666, in the meantime I congratulate and thank you for the work done.
It is really important and fantastic.

Coincidentally I found that you and I have almost the same hardware configuration. I tried to use your last attached EFI (EFI 0.7.2 1.3) but in boot it doesn't find the OS, it only detects WINDOWS.

The pen is set as indicated in the Dortania guide, the OS I got it through Python that downloads the latest version.

Would you have any suggestions? I'm sure it's nonsense that escapes me.

PS: the only change I made to the Config.plist file is to set the AAPL, ig-platform-id with the value 0300C89B for the device:
PciRoot (0x0) / Pci (0x2,0x0)
For using my dGPU
As written in Dortania's guide.

Thanks
It sounds like your USB drive maybe incorrectly configured, you can check in the bios if it shows as a boot option or by hitting the F8 key at boot. Make sure when creating the pen drive to format it correctly, I use the terminal command "Create Media" which you can google and then copy and paste into the terminal window. Once that part of the drive is done mount the EFI partition (I use EFI-Agent from Headkaze available on GitHub) then add the EFI folder there. Lots of ways to do the same thing so just a suggestion. @scope666 may have more suggestions...
 
Joined
Jun 26, 2019
Messages
34
Motherboard
Dell Inspiron 5370
CPU
i5-8250U
Graphics
UHD 620
Mobile Phone
  1. Android
Hello scope666, in the meantime I congratulate and thank you for the work done.
It is really important and fantastic.

Coincidentally I found that you and I have almost the same hardware configuration. I tried to use your last attached EFI (EFI 0.7.2 1.3) but in boot it doesn't find the OS, it only detects WINDOWS.

The pen is set as indicated in the Dortania guide, the OS I got it through Python that downloads the latest version.

Would you have any suggestions? I'm sure it's nonsense that escapes me.

PS: the only change I made to the Config.plist file is to set the AAPL, ig-platform-id with the value 0300C89B for the device:
PciRoot (0x0) / Pci (0x2,0x0)
For using my dGPU
As written in Dortania's guide.

Thanks

Hi there,
please check your ScanPolicy value (usually is 0) and check MinDate and MinVersion in config.plist/UEFI/APFS. Starting from OpenCore 0.7.2, if you're not running Big Sur you can't detect previous macOS APFS disks. The only way to do it is chaning the MinDate and MinVersion values to the following:

Please note that the following values are extracted from OpenCorePkg/OcApfsLib.h

macOS Version MinDate MinVersion
High Sierra 10.13.6 (17G66) 20180621U 748077008000000ULL
Mojave 10.14.6 (18G103) 20190820U 945275007000000ULL
Catalina 10.15.4 (19E287) 20200306U 1412101001000000ULL
Big Sur 11.4 (20F71) 20210508U 1677120009000000ULL


If you wanna OpenCore detect every APFS partition, without any exception, set both values to -1

P.S. About the graphics patch, since you're using a headless AAPL,ig-platform-id you can drop pretty every property. Just make sure you leave AAPL,ig-platform-id, igfxfw and model properties
 
Joined
Aug 22, 2021
Messages
6
Motherboard
ASUS ROG STRIX Z490-E GAMING
CPU
Intel i9 10900K
Graphics
AMD Radeon RX 6800 XT
Mobile Phone
  1. iOS
It sounds like your USB drive maybe incorrectly configured, you can check in the bios if it shows as a boot option or by hitting the F8 key at boot. Make sure when creating the pen drive to format it correctly, I use the terminal command "Create Media" which you can google and then copy and paste into the terminal window. Once that part of the drive is done mount the EFI partition (I use EFI-Agent from Headkaze available on GitHub) then add the EFI folder there. Lots of ways to do the same thing so just a suggestion. @scope666 may have more suggestions...
I'm sorry, i expressed myself badly. I meant that opencore does not detect BigSur .dmg, the pen starts up without problems and the bios is set correctly.

Making further attempts if i put my EFI folder in the pen, OpeCore detects the Big Sur .dmg file.
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,836
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I'm sorry, i expressed myself badly. I meant that opencore does not detect BigSur .dmg, the pen starts up without problems and the bios is set correctly.

Making further attempts if i put my EFI folder in the pen, OpeCore detects the Big Sur .dmg file.
Okay, thanks for clarifying. So are you okay now? You can see the Big Sur install icon now?
 
Joined
Aug 22, 2021
Messages
6
Motherboard
ASUS ROG STRIX Z490-E GAMING
CPU
Intel i9 10900K
Graphics
AMD Radeon RX 6800 XT
Mobile Phone
  1. iOS
Hi there,
please check your ScanPolicy value (usually is 0) and check MinDate and MinVersion in config.plist/UEFI/APFS. Starting from OpenCore 0.7.2, if you're not running Big Sur you can't detect previous macOS APFS disks. The only way to do it is chaning the MinDate and MinVersion values to the following:

Please note that the following values are extracted from OpenCorePkg/OcApfsLib.h

macOS Version MinDate MinVersion
High Sierra 10.13.6 (17G66) 20180621U 748077008000000ULL
Mojave 10.14.6 (18G103) 20190820U 945275007000000ULL
Catalina 10.15.4 (19E287) 20200306U 1412101001000000ULL
Big Sur 11.4 (20F71) 20210508U 1677120009000000ULL


If you wanna OpenCore detect every APFS partition, without any exception, set both values to -1

P.S. About the graphics patch, since you're using a headless AAPL,ig-platform-id you can drop pretty every property. Just make sure you leave AAPL,ig-platform-id, igfxfw and model properties
Thank you very much, the problem was their MinDate and MinVersion values set to 0. I set them both to -1. Now i have started the installation i hope there are no other problems. I keep you updated. Thanks again.
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
2,836
Motherboard
Asus B550 Rog Strix Gaming i
CPU
Ryzen 9 5900X
Graphics
6800XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi there,
please check your ScanPolicy value (usually is 0) and check MinDate and MinVersion in config.plist/UEFI/APFS. Starting from OpenCore 0.7.2, if you're not running Big Sur you can't detect previous macOS APFS disks. The only way to do it is chaning the MinDate and MinVersion values to the following:

Please note that the following values are extracted from OpenCorePkg/OcApfsLib.h

macOS Version MinDate MinVersion
High Sierra 10.13.6 (17G66) 20180621U 748077008000000ULL
Mojave 10.14.6 (18G103) 20190820U 945275007000000ULL
Catalina 10.15.4 (19E287) 20200306U 1412101001000000ULL
Big Sur 11.4 (20F71) 20210508U 1677120009000000ULL


If you wanna OpenCore detect every APFS partition, without any exception, set both values to -1

P.S. About the graphics patch, since you're using a headless AAPL,ig-platform-id you can drop pretty every property. Just make sure you leave AAPL,ig-platform-id, igfxfw and model properties
You figure if he is using @scope666 EFI folder that's not an issue but thanks for jumping in

EDIT: Well there you go...it was the changing the MinDate and MinVersion values
 
Joined
Aug 23, 2012
Messages
374
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
You figure if he is using @scope666 EFI folder that's not an issue but thanks for jumping in

EDIT: Well there you go...it was the changing the MinDate and MinVersion values

I can change this in the EFI so going forward people don't have this issue during install. :)

EDIT: Attached
 

Attachments

  • EFI 0.7.2 1.4.zip
    9.1 MB · Views: 54
Last edited:
Joined
Aug 22, 2021
Messages
6
Motherboard
ASUS ROG STRIX Z490-E GAMING
CPU
Intel i9 10900K
Graphics
AMD Radeon RX 6800 XT
Mobile Phone
  1. iOS
UPDATE:

OpenCore with values -1 now detects Catalina's .dmg file but not BigSur's. I only have Windows. :lol:

I try to put the dedicated values for BigSur as suggested by dreamwhite:

macOS Version MinDate MinVersion
Big Sur 11.4 (20F71) 20210508U 1677120009000000ULL
 
Joined
Aug 23, 2012
Messages
374
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
UPDATE:

OpenCore with values -1 now detects Catalina's .dmg file but not BigSur's. I only have Windows. :lol:

I try to put the dedicated values for BigSur as suggested by dreamwhite:

macOS Version MinDate MinVersion
Big Sur 11.4 (20F71) 20210508U 1677120009000000ULL

In the guide they're only saying to change it if you're trying to boot older operating systems:

1629656406152.png
 
Joined
Aug 22, 2021
Messages
6
Motherboard
ASUS ROG STRIX Z490-E GAMING
CPU
Intel i9 10900K
Graphics
AMD Radeon RX 6800 XT
Mobile Phone
  1. iOS
In the guide they're only saying to change it if you're trying to boot older operating systems:

View attachment 527597
I had already set them to -1 but still does not see the OS. Could it depend on the version i downloaded of BigSur?

With the command:
python macrecovery.py -b Mac-E43C1C25D4880AD6 -m 00000000000000000 download

should download the latest version.
Or so it says in the guide...

EDIT
But strangely with my EFI folder and my config file (which I created following the guide) the OS is detected by OpenCore
 
Top