Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Aug 5, 2014
Messages
306
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Hey mate, I've got the ROG Maximus XII Hero here, do you think I'd be able to use your EFI?

Done a few Hackintoshes but haven't really played around with DSDTs etc since my Rampage IV Extreme lol.

Just try it?
 
Joined
Aug 23, 2012
Messages
417
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey mate, I've got the ROG Maximus XII Hero here, do you think I'd be able to use your EFI?

Done a few Hackintoshes but haven't really played around with DSDTs etc since my Rampage IV Extreme lol.

I'd think you have a good chance, I came close to buying that instead (I own the Hero VI and Hero IX) but it was missing the DisplayPort output that the Strix has. They should be very similar.
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Thanks guys, I will try it and get back with results.
 
Joined
Jun 21, 2020
Messages
12
Motherboard
Gigabyte GA-Z97-D3H
CPU
i7-4790K
Graphics
RX 580
Hi Hemon,
ASUS Z490-E + i9-10900K can fully work with Mojave ?
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Hey guys, just had a crack using Scopes EFI, getting a hangup at the following running in verbose, anybody able to shed any light? Perhaps a graphics issue? see screenshots.

Bit more information I am running the Asus Hero XII Wifi Motherboard with a i7 10700 and Radeon 5700XT.

I've set BIOS as you had shown in the earlier post, with the exception of Execute Disable Bit? Can't seem to find that anywhere in the BIOS.

Any help would be greatly appreciated.
 

Attachments

  • 20200625_201918.jpg
    20200625_201918.jpg
    3.5 MB · Views: 73
  • 20200625_201805.jpg
    20200625_201805.jpg
    3 MB · Views: 61
Joined
Aug 23, 2012
Messages
417
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys, just had a crack using Scopes EFI, getting a hangup at the following running in verbose, anybody able to shed any light? Perhaps a graphics issue? see screenshots.

Bit more information I am running the Asus Hero XII Wifi Motherboard with a i7 10700 and Radeon 5700XT.

I've set BIOS as you had shown in the earlier post, with the exception of Execute Disable Bit? Can't seem to find that anywhere in the BIOS.

Any help would be greatly appreciated.

Maybe try this EFI instead, that GPU is a bit different from my understanding:


(he mentions 5700XT)
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Maybe try this EFI instead, that GPU is a bit different from my understanding:


(he mentions 5700XT)

No luck there mate, has more issues I'd say, CPU unrecognised and hangs up on please switch to xpc or bootstrap_check_in()
 
Joined
Aug 23, 2012
Messages
417
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Take a look here, they have a lot of specific areas that you can get stuck listed and solutions for them:



Also another repository:

https://github.com/jergoo/Hackintosh-ROG-STRIX-Z490I (very clearly documented)


Also perhaps because of your different cpu, I'd look into Cpuid1Data and Cpuid1Mask

EDIT:
Found this, perhaps my Emulate section needs to come out, might be messing you up:

Emulate: Needed for spoofing unsupported CPUs, thankfully in 10.15.5 Comet Lake S support was added so no need to spoof here. For those running High Sierra or Mojave, you will need the below to spoof to a supported CPU model(due to stability issues, this guide will not go over such CPUID spoofs)
 
Last edited:
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Thank you very much mate, will have a play around today and let you know how I go.
 
Top