Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Aug 23, 2012
Messages
392
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Here's a build of 0.7.2 with all the latest kexts, let me know how it works for you.

kexts.png



Code:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.7.2-RELEASE/Utilities/ocvalidate

craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

Completed validating /Volumes/EFI/EFI/OC/config.plist in 3 ms. No issues found.
 

Attachments

  • EFI 0.7.2.zip
    9.2 MB · Views: 57
Joined
Aug 5, 2014
Messages
290
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Here's a build of 0.7.2 with all the latest kexts, let me know how it works for you.

View attachment 526082


Code:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.7.2-RELEASE/Utilities/ocvalidate

craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

Completed validating /Volumes/EFI/EFI/OC/config.plist in 3 ms. No issues found.

As always, thank you very much for the effort!

Question: Is there a way to make the iPad USB-C Audio Adapter to work? I tried both USB-C ports (front and rear) and the adapter is not recognized at all.
 
Joined
Aug 23, 2012
Messages
392
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
As always, thank you very much for the effort!

Question: Is there a way to make the iPad USB-C Audio Adapter to work? I tried both USB-C ports (front and rear) and the adapter is not recognized at all.

I'm pretty sure in my map I only have the rear USB-C port enabled. I've tested it with a Samsung T5 portable SSD and it works perfectly. Do you have another USB-C device to test the port?
 
Joined
Aug 5, 2014
Messages
290
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
I'm pretty sure in my map I only have the rear USB-C port enabled. I've tested it with a Samsung T5 portable SSD and it works perfectly. Do you have another USB-C device to test the port?

Unfortunately, it doesn't work. I tried it now again.

The front port works with the iPad Pro.
 
Joined
Aug 23, 2012
Messages
392
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Unfortunately, it doesn't work. I tried it now again.

The front port works with the iPad Pro.

Sounds like you're not using my USB map because I had to disable the front USB-C. (port limit + I couldn't get full speed like I could out of the rear port)
 
Joined
Aug 5, 2014
Messages
290
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Sounds like you're not using my USB map because I had to disable the front USB-C. (port limit + I couldn't get full speed like I could out of the rear port)
I don't know, I just use your EFI.

How can I use your USB map?
 
Joined
Aug 23, 2012
Messages
392
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I don't know, I just use your EFI.

How can I use your USB map?

One idea is to install / run Hackintool and see if the USB tab looks like mine:

 
Joined
Aug 5, 2014
Messages
290
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
One idea is to install / run Hackintool and see if the USB tab looks like mine:

This is my screenshot.

What do you think?
 

Attachments

  • Bildschirmfoto 2021-08-06 um 08.45.24.png
    Bildschirmfoto 2021-08-06 um 08.45.24.png
    117 KB · Views: 17
Joined
Aug 23, 2012
Messages
392
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
This is my screenshot.

What do you think?

It looks correct, so I'm baffled how your front USB-C is working, where is it plugged in on the motherboard? In the screenshot I see an iPhone plugged in the "front left" port. With my case that's a normal USB-A port, not C. IIRC my front USB-C has its own very weird looking cable that plugs into a dedicated port on the motherboard.

1628254289544.png


1628254475581.png
 
Last edited:
Joined
Aug 5, 2014
Messages
290
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
It looks correct, so I'm baffled how your front USB-C is working, where is it plugged in on the motherboard? In the screenshot I see an iPhone plugged in the "front left" port. With my case that's a normal USB-A port, not C. IIRC my front USB-C has its own very weird looking cable that plugs into a dedicated port on the motherboard.

View attachment 526415

View attachment 526416
On the front USB-C I had the iPad Pro connected but maybe I'm wrong and I'm not correctly remember it because I also used a normal USB-A to USB-C cable. I then use a USB-A cable for the iPhone (which you see in the screenshot).

Anyway, the Audio USB-C Adapter of the iPad doesn't work with the rear USB-C Port, I received once an error because it needs "too much power" (I don't remember the message correctly…). Is there a way that this port can use more power?
 
Top