Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Mar 3, 2021
Messages
12
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10850K
Graphics
RX 5700 XT
Also fixed all the icloud errors I was having - so that's neat.
 
Joined
Dec 7, 2018
Messages
28
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
By any chance has anyone done 4K HEVC editing in final cut with this build? I'm looking to upgrade my current hackintosh to this motherboard/cpu combo :) Using a Vega 64 in my current build as well.

Thanks!
 
Joined
Mar 3, 2021
Messages
12
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10850K
Graphics
RX 5700 XT
I've got a 5700xt in my build and have edited video lightly with absolutely rock solid stability. I primarily edit/mix audio and man having a machine like this was a game changer.
 
Joined
Dec 7, 2018
Messages
28
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Nice! Yeah I edit video for a living as well as edit audio but honestly a lot of my work isn't super demanding. But my current build I can't seem to get to work well for HEVC editing and don't have time to be constantly tweaking my machine, I've found it super helpful to follow a hackintosh thread that has support going for the build to troubleshoot future problems :D Can't wait for the newer m1x or m2 machines, having some issues with my current motherboard so I'd just like to upgrade in the process.
 
Joined
Mar 3, 2021
Messages
12
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10850K
Graphics
RX 5700 XT
Don’t say m1 too loudly here.. could be the end of the Hackintosh times
(We’ll see though, they made AMD hackintoshing work)
 
Joined
Dec 7, 2018
Messages
28
Motherboard
Gigabyte Z370 Aorus Gaming 5
CPU
i7-8700K
Graphics
Vega 64
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Don’t say m1 too loudly here.. could be the end of the Hackintosh times
(We’ll see though, they made AMD hackintoshing work)
Hah! I don’t know man, I actually dipped my toes into an M1 Mac mini and had a bad experience on a lot of fronts and returned it, my hackintosh ironically was less buggy hah! The display support on the current M1 chips is just really really bad. They’re good chips but the IO needs a ton of improvement haha.
 
Joined
May 27, 2021
Messages
1
Motherboard
Asus ROG STRIX Z490-E Gaming
CPU
i9-10900k
Graphics
Using iGPU, but have a 3090 FE
Don’t upgrade BS to 11.4. Reboots and freez all times. :/
I'm having the same issue. I rolled back to 11.3 which works great.

I also have an Asus Strix ROG z490-E with a 10900k and am using your EFI version 0.6.9-1.1

One issue I am having is getting the HDMI port to work. The DP works great. I have a 3090 and have tried with and without the "-wegnoegpu" boot flag but it seems to make no difference. Both HDMI and DP are plugged into my iGPU on the MB.

Reading back it looks like you re-enabled iGPU support in this EFI version. And I double checked and FakePCIID.kext & FakePCIID_Intel_HDMI_Audio.kext are enabled and CommandProFix.kext is disabled. I'm not sure what Hemon meant by "For HDMI I just used the "old" DeviceProperties entry." but maybe that's something I need to change? Any suggestions for getting the HDMI to work on 11.3 would be great.
 
Joined
Aug 23, 2012
Messages
373
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm having the same issue. I rolled back to 11.3 which works great.

I also have an Asus Strix ROG z490-E with a 10900k and am using your EFI version 0.6.9-1.1

One issue I am having is getting the HDMI port to work. The DP works great. I have a 3090 and have tried with and without the "-wegnoegpu" boot flag but it seems to make no difference. Both HDMI and DP are plugged into my iGPU on the MB.

Reading back it looks like you re-enabled iGPU support in this EFI version. And I double checked and FakePCIID.kext & FakePCIID_Intel_HDMI_Audio.kext are enabled and CommandProFix.kext is disabled. I'm not sure what Hemon meant by "For HDMI I just used the "old" DeviceProperties entry." but maybe that's something I need to change? Any suggestions for getting the HDMI to work on 11.3 would be great.

Yeah, Hemon meant reverting back to the way I originally had the iGPU defined, which the 1.1 EFI already has. I deleted the other version to avoid any confusion. -wegnoegpu shouldn't be needed as by default I'm blocking the top PCIE slot video card (probably where you have your 3090, and where I have my 2080 Ti)
 
Joined
Mar 3, 2021
Messages
12
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10850K
Graphics
RX 5700 XT
Is anyone familiar with enabling thunderbolt hot plugging? I've got an asus thunderboltex 3-tr that will work if all my TB devices are powered up before boot.. but no hot plugging.
 
Joined
May 19, 2020
Messages
29
Motherboard
Asus ROG Strix Z490-E Gaming
CPU
Intel i9-10850k
Graphics
AMD Radeon Pro W5500, AMD Radeon Pro WX4100, iGPU
Mac
  1. iMac
  2. MacBook Air
Mobile Phone
  1. iOS
Don’t upgrade BS to 11.4. Reboots and freez all times. :/
I had the same. It seems to be related to the Intel i225-V ethernet card.

I fixed it by disabling the patch:
Screenshot 2021-05-29 at 08.44.15.png


You will have to add the FakePCIID_Intel_I225-V.kext to get the ethernet card to work.
 
Top