Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Jul 20, 2015
Messages
12
Motherboard
ASUS ROG Strix Z490-G GAMING
CPU
Intel Core i5-10500
Graphics
GIGABYTE RADEON RX 5700 XT
The way I usually do it, copy my EFI to a spare USB key, putting in your unique settings like keys, etc. Test booting from it. This way if there's an issue, your copy of the EFI on the hard drive is unaffected.
Sorry to say, I had no success with your new EFI. It seems that my Asus Z490-G motherboard is a bit different. It was only Xiaoviejang's EFI that worked. When I tried your new EFI, I could see that yours and Xiaoviejang's config are very different. I have not any clue what is different, but yours look more like from the Open core guide and Xiaoviejang's very specific and different from the Open core guide, but latter worked flawlessly for my motherboard. What can I say.

Hopefully, Xiaoviejang, if you read this post, please make an updated EFI of your previous upload to the new Open Core, hopefully working with Big Sur. I have good faith in it to work :thumbup:
 
Joined
Aug 23, 2012
Messages
410
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hopefully, Xiaoviejang, if you read this post, please make an updated EFI of your previous upload to the new Open Core, hopefully working with Big Sur. I have good faith in it to work :thumbup:

He HAS a version of 0.6.3, I even linked it in the first post of this thread.
 
Joined
Nov 16, 2020
Messages
24
Motherboard
Asus Z490-E Gaming
CPU
i9-10850K
Graphics
RX 5700 XT
I'm using AirportItlwm kext too anyway .. could you please share us you loaded kext currently man?

I've just trying big sur.. and the bluetooth is not working. Wifi working when booting but when toggle on/off its gone
I've got airportitlwm running but the option for wifi under Network does not appear. I'm not sure what is wrong. Bluetooth works, just not wifi. Does Airportitlwm also handle bluetooth? Because I also have the bluetooth firmware kext as well.
 
Last edited:
Joined
May 24, 2018
Messages
110
Motherboard
Asus Z97-Pro Gamer
CPU
i7-4770k
Graphics
intel graphic HD
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I've got airportitlwm running but the option for wifi under Network does not appear. I'm not sure what is wrong. Bluetooth works, just not wifi.
Please use heliport
Does Airportitlwm also handle bluetooth? Because I also have the bluetooth firmware kext as well.
No, I recommend using intelFirmwarekext even if Bluetooth support by default.
 
Joined
Nov 16, 2020
Messages
24
Motherboard
Asus Z490-E Gaming
CPU
i9-10850K
Graphics
RX 5700 XT
Please use heliport

No, I recommend using intelFirmwarekext even if Bluetooth support by default.
I can't get itlwm to load, even when I set it to. Heliport always said itlwm wasn't running. So I switched to airportitlwm
 
Joined
May 24, 2018
Messages
110
Motherboard
Asus Z97-Pro Gamer
CPU
i7-4770k
Graphics
intel graphic HD
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I can't get itlwm to load, even when I set it to. Heliport always said itlwm wasn't running. So I switched to airportitlwm
both of them wrap intel wifi 6, so they must give the same result. AirportItlwm has another implement for handoff...etc, thing you need to check: does your motherboard disable the wifi to save power or issue related to cool boot via hackintool.
Take the picture related to the peripheral part in hackintool and post it here. So we can check.
 
Joined
Nov 16, 2020
Messages
24
Motherboard
Asus Z490-E Gaming
CPU
i9-10850K
Graphics
RX 5700 XT
both of them wrap intel wifi 6, so they must give same result. AirportItlwm has another implement for handoff...etc, thing you need to check is did your motherboard disable the wifi to save power or issue related to cool boot via hackintool.
Take the picture related to peripheral part in hackintool and post here. So we can check.
My bluetooth works, it's just the wifi that doesn't. I didn't use Hackintool for any of my configuration, but I did download it to look at the status of my devices.
 

Attachments

  • Screen Shot 2020-11-17 at 7.48.26 AM.png
    Screen Shot 2020-11-17 at 7.48.26 AM.png
    118.8 KB · Views: 38
  • Screen Shot 2020-11-17 at 8.04.18 AM.png
    Screen Shot 2020-11-17 at 8.04.18 AM.png
    25.3 KB · Views: 37
Joined
May 24, 2018
Messages
110
Motherboard
Asus Z97-Pro Gamer
CPU
i7-4770k
Graphics
intel graphic HD
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
your wifi device missing. please look at the first table. it shows the ethernet and the wifi device should be there if itlwm/airportitlwm loaded in the Extensions tab of hackintool.

Please check the Extensions tab if itlwm/airportitlwm loaded in there. You have another method to check using terminal but using hackintool is faster and familiar.
 
Joined
Aug 23, 2012
Messages
410
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
your wifi device missing. please look at the first table. it shows the ethernet and the wifi device should be there if itlwm/airportitlwm loaded in the Extensions tab of hackintool.

He's right, should look something like this except with the built-in WiFi instead of Broadcom:

1605630450130.png
 
Top