Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Aug 23, 2012
Messages
420
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm on Big Sur, it boots without problems …

Ok, that's strange. I'll have to try again sometime with the new bootarg. For me it froze as it was completing the boot with that in place. I also have triple monitors and a lot of hardware, so it could be something specific to my setup.
 
Joined
Aug 5, 2014
Messages
307
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Joined
Aug 23, 2012
Messages
420
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Actually, I use these boot arguments: -v -wegnoegpu debug=0x100 keepsyms=1 e1000=0 igfxonln=1

Ah, so maybe a conflict with my AMD card or something...
 
Joined
Jul 30, 2021
Messages
33
Motherboard
Z390 aorus pro
CPU
I7 9700
Graphics
Rx 5700
OK, here's the latest 0.8.1 build. The big change this month is reset NVRAM and toggle SIP have been changed to drivers. Press the spacebar at the boot menu to expand and see those options. Also I incorporated MacDivanz's ethernet fix above.

View attachment 549514
View attachment 549515

Code:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.8.1-RELEASE/Utilities/ocvalidate
craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

NOTE: This version of ocvalidate is only compatible with OpenCore version 0.8.1!

Completed validating /Volumes/EFI/EFI/OC/config.plist in 6 ms. No issues found.

UPDATE: On my system still running Big Sur, I have to use the old bootarg (under NVRAM) dk.e1000=0 or I lock up. If you're running Monterey you should be good to go as-is.
Hi Scope666
I am using i7 10700k on Z490 E gaming and am planning to upgrade to i9 10900k. Do I need to change smbios from 20,1 to 20,2?
 
Joined
Jun 10, 2022
Messages
2
Motherboard
Asus ROG Strix Z490-E
CPU
Core I9-10900
Graphics
None
Thanks Scope666.
For me All things Work like a charm except rear USB C port which works on v0.8.0.
Onboard wifi now works too using itlwm or Airportitlwm kext.
Thanks again
Best Regards
 
Joined
Aug 23, 2012
Messages
420
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks Scope666.
For me All things Work like a charm except rear USB C port which works on v0.8.0.
Onboard wifi now works too using itlwm or Airportitlwm kext.
Thanks again
Best Regards

That is very strange as I didn't touch the USB map.
 
Top