Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Aug 23, 2012
Messages
419
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi, Does your BT card show up under BT in system report as chipset BCM94360CD? I just bought a combo with adapter 2nd hand: supposed to be with orig. imac with BCM94360CD chipset, shown in a photo but there is a heatsink on it I don't want to risk removing and it comes up as BCM20702B0 in system report. BT connects to speakers but ipad is impossible with this system or the intel setup under Monterey or even Catalina with the card. Thx!

Sorry it took so long for my reply, here's my full report if it helps:


Code:
Apple Bluetooth Software Version:    8.0.5d7
  Hardware, Features, and Settings:
  Name:    Craig’s iMac
  Address:    AX-XX-XX-XX-XX-XX
  Bluetooth Low Energy Supported:    Yes
  Handoff Supported:    Yes
  Instant Hot Spot Supported:    Yes
  Manufacturer:    Broadcom
  Transport:    USB
  Chipset:    20702B0
  Firmware Version:    v150 c9317
  Bluetooth Power:    On
  Discoverable:    Off
  Connectable:    Yes
  Auto Seek Pointing:    On
  Remote wake:    On
  Vendor ID:    0x05AC
  Product ID:    0x828D
  Bluetooth Core Spec:    4.0 (0x6)
  HCI Revision:    0x2465
  LMP Version:    4.0 (0x6)
  LMP Subversion:    0x4196
  Device Type (Major):    Computer
  Device Type (Complete):    Mac Desktop
  Composite Class Of Device:    0x380104
  Device Class (Major):    0x01
  Device Class (Minor):    0x01
  Service Class:    0x1C0
  Auto Seek Keyboard:    On
  Devices (Paired, Configured, etc.):
  Craig’s AirPods:
  Address:    XX-XX-XX-XX-XX-XX
  Major Type:    Miscellaneous
  Minor Type:    Unknown
  Services:   
  Paired:    Yes
  Configured:    Yes
  Connected:    No
  Bluetooth Core Spec:    1.0b
  Vendor ID:    0x004C
  Product ID:    0x200F
  Class of Device:    0x00 0x00 0x0000
  Services:
  Bluetooth File Transfer:
  Folder other devices can browse:    ~/Public
  When receiving items:    Accept all without warning
  State:    Disabled
  Bluetooth File Exchange:
  Folder for accepted items:    ~/Downloads
  When other items are accepted:    Save to location
  When receiving items:    Accept all without warning
  State:    Disabled
  Bluetooth Internet Sharing:
  State:    Disabled
  Incoming Serial Ports:
  Bluetooth-Incoming-Port:
  RFCOMM Channel:    3
  Requires Authentication:    No
 
Joined
Aug 23, 2012
Messages
419
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Many thanks, I got it sorted meanwhile but can't work out how to delete posts here!

No reason to delete, you never know if it might benefit someone else. :)

BTW, since it's so late in the month, I'll probably just wait until the next version of OpenCore is released, and I'll post a new build then.
 
Joined
Feb 2, 2022
Messages
18
Motherboard
Asus RogStrix Z490-E
CPU
i9 10850K
Graphics
Nvidia RTX 3080
Hi all after the update 12.3.1 the OS not work anymore, with crash randomly. So i have update the last update of OC 0.7.9 but without success. Anyone had the same problem? and know how to fix that? Thank you.
 

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,354
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi all after the update 12.3.1 the OS not work anymore, with crash randomly. So i have update the last update of OC 0.7.9 but without success. Anyone had the same problem? and know how to fix that? Thank you.
It’s the onboard Intel I225V Ethernet controller issue, to fix it either roll back to 12.2 or see this post for add in Ethernet cards that work OOTB. If you disable the controller in the bios you should be able to boot and not have the crashes.

 
Joined
Aug 23, 2012
Messages
419
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Sorry for missing last month, but here's the brand new OC 0.8.0 as of today. As usual let me know how it goes for you.

Version.png


Kexts.png


Bash:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.8.0-RELEASE/Utilities/ocvalidate
craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

Completed validating /Volumes/EFI/EFI/OC/config.plist in 0 ms. No issues found.

PS Because of the recent Intel I225V Ethernet issue posted above, I'm probably going to stay on Big Sur until it's resolved. (Hopefully)

EDIT: Added to 1st post.
 
Last edited:
Joined
Feb 2, 2022
Messages
18
Motherboard
Asus RogStrix Z490-E
CPU
i9 10850K
Graphics
Nvidia RTX 3080
Ok hi guys, i have found one solution for the issue of Ethernet that works fine, you just only need change in the boot-args "dk.e1000=0" in "e1000=0" and is fix, no more crash. For the 0.8.0 EFI thank you so much Scope666, i must test it.
 
Last edited:
Joined
Aug 23, 2012
Messages
419
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
OK, here's the latest 0.8.1 build. The big change this month is reset NVRAM and toggle SIP have been changed to drivers. Press the spacebar at the boot menu to expand and see those options. Also I incorporated MacDivanz's ethernet fix above.

version.png

kexts.png


Code:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.8.1-RELEASE/Utilities/ocvalidate
craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

NOTE: This version of ocvalidate is only compatible with OpenCore version 0.8.1!

Completed validating /Volumes/EFI/EFI/OC/config.plist in 6 ms. No issues found.

UPDATE: On my system still running Big Sur, I have to use the old bootarg (under NVRAM) dk.e1000=0 or I lock up. If you're running Monterey you should be good to go as-is.

UPDATE2: Added to first post.
 
Last edited:
Joined
Aug 5, 2014
Messages
306
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
OK, here's the latest 0.8.1 build. The big change this month is reset NVRAM and toggle SIP have been changed to drivers. Press the spacebar at the boot menu to expand and see those options. Also I incorporated MacDivanz's ethernet fix above.

View attachment 549514
View attachment 549515

Code:
craig@Craigs-iMac ocvalidate % pwd
/Users/craig/Downloads/OpenCore-0.8.1-RELEASE/Utilities/ocvalidate
craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

NOTE: This version of ocvalidate is only compatible with OpenCore version 0.8.1!

Completed validating /Volumes/EFI/EFI/OC/config.plist in 6 ms. No issues found.

UPDATE: On my system still running Big Sur, I have to use the old bootarg (under NVRAM) dk.e1000=0 or I lock up. If you're running Monterey you should be good to go as-is.

It works 100% - thank you very much for the effort!
 
Joined
Aug 23, 2012
Messages
419
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It works 100% - thank you very much for the effort!

Are you on Big Sur or Monterey? Trying to figure out if I'm alone with this boot argument thing.
 
Top