Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Mar 14, 2018
Messages
10
Motherboard
Asus Ro Strix Z490 Gaming E
CPU
I9-10850k
Graphics
rx6600
Mac
  1. iMac

Leesureone

Moderator
Joined
Feb 21, 2010
Messages
3,347
Motherboard
Asus Z690 Rog Strix G Gaming
CPU
i9-12900K
Graphics
RX 6900 XT
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Probably you have come across this but the "unsupported" ones do work, certainly the xt and 6600. I am running the last one
That was posted in October, since then with the second release of Monterey support was added for the 6600XT and 6600 cards. The 6700 and 6500 series still are not supported.
 
Joined
Mar 14, 2018
Messages
10
Motherboard
Asus Ro Strix Z490 Gaming E
CPU
I9-10850k
Graphics
rx6600
Mac
  1. iMac
Not wanting to bother you guys with covered issues but I couldn't yet find a solution with my setup (almost the same as scope's) to get 15 ubs ports running.

Does anyone have a successful config with front USB-C port and 3 reds, 2 blues and the 4xUSB 2.0s + internal USB 2.0 all working?

Not working but needed: the front / (also rear) USB-C and the single rear red port. I have a Kraken x63 on the internal USB so will keep that. BT has recognised but not connected, using the various kexts mentioned. Would be good to get that running but will try an Archer card tomorrow.



I tried Scope's EFI with only following changes with no success in this respect (nothing shows on said ports). Many thanks for making the mysterious torturous onboard audio problem disappear though!



Changes:

removed disable dGPU in device properties

boot args now: dk.e1000=0 igfxonln=1 agdpmod=pikera

removed debugging

UUID etc


I removed the inject all kext and injected everything as otherwise was originally, with propertree.


If I need to start from scratch, if anyone could point me to the easiest current method for Monterey I would be grateful. Not sure whether to change config line XCHI port limit in the process or not for example. The SSDT.rehub edit is getting way over my head - too many uncertains - prefer to get a working EFI ;)


asus rog strix z490 gaming e
AMD radeon rx6600 8GB
i9 10850k
Kraken x63
Monterey 12.2.1
OC 7.8
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,974
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Not wanting to bother you guys with covered issues but I couldn't yet find a solution with my setup (almost the same as scope's) to get 15 ubs ports running.

Does anyone have a successful config with front USB-C port and 3 reds, 2 blues and the 4xUSB 2.0s + internal USB 2.0 all working?

Not working but needed: the front / (also rear) USB-C and the single rear red port. I have a Kraken x63 on the internal USB so will keep that. BT has recognised but not connected, using the various kexts mentioned. Would be good to get that running but will try an Archer card tomorrow.



I tried Scope's EFI with only following changes with no success in this respect (nothing shows on said ports). Many thanks for making the mysterious torturous onboard audio problem disappear though!



Changes:

removed disable dGPU in device properties

boot args now: dk.e1000=0 igfxonln=1 agdpmod=pikera

removed debugging

UUID etc


I removed the inject all kext and injected everything as otherwise was originally, with propertree.


If I need to start from scratch, if anyone could point me to the easiest current method for Monterey I would be grateful. Not sure whether to change config line XCHI port limit in the process or not for example. The SSDT.rehub edit is getting way over my head - too many uncertains - prefer to get a working EFI ;)


asus rog strix z490 gaming e
AMD radeon rx6600 8GB
i9 10850k
Kraken x63
Monterey 12.2.1
OC 7.8
 
Joined
Mar 14, 2018
Messages
10
Motherboard
Asus Ro Strix Z490 Gaming E
CPU
I9-10850k
Graphics
rx6600
Mac
  1. iMac
Thanks a lot but I've pretty much been through all of this and it seems that the process has developed since 2019. Questions: In Dortania it recommends SSDT.rehub, but Scope here doesn't use that. Portlimit doesn't work anymore, apparently.... I don't know which method to follow. I will run through your ref again and see if I have missed sth.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,974
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks a lot but I've pretty much been through all of this and it seems that the process has developed since 2019. Questions: In Dortania it recommends SSDT.rehub, but Scope here doesn't use that. Portlimit doesn't work anymore, apparently.... I don't know which method to follow.
yes, the port limit patch is broken in Big Sur onwards, best to do this in Catalina

some have used this before in windows:
 
Joined
Mar 14, 2018
Messages
10
Motherboard
Asus Ro Strix Z490 Gaming E
CPU
I9-10850k
Graphics
rx6600
Mac
  1. iMac
yes, the port limit patch is broken in Big Sur onwards, best to do this in Catalina

some have used this before in windows:
So if the process works in Catalina, then the resulting USBport.kext should work in Monterey right? Do I need rhub and / or ec-usbx in the ACPI folder in order to produce the kext or only post-process, or - with rhub, do I need it at all?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,974
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
So if the process works in Catalina, then the resulting USBport.kext should work in Monterey right? Do I need rhub and / or ec-usbx in the ACPI folder in order to produce the kext or only post-process, or - with rhub, do I need it at all?
yes, if you create your kext correctly in Catalina, it will work in Big Sur and Monterey

yes, you need ec-usbx unless you have the properties in your kext

may also need rhub.aml, you will have to test
 
Joined
Mar 14, 2018
Messages
10
Motherboard
Asus Ro Strix Z490 Gaming E
CPU
I9-10850k
Graphics
rx6600
Mac
  1. iMac
yes, if you create your kext correctly in Catalina, it will work in Big Sur and Monterey

yes, you need ec-usbx unless you have the properties in your kext

may also need rhub.aml, you will have to test
I got it sorted. I can confirm the method works with 2 boots and enabling portlimit b4 1st reboot and disabling before second boot to get remaining ports (usb3 or usb2):
. Now just need to sort BT
 
Joined
Mar 14, 2018
Messages
10
Motherboard
Asus Ro Strix Z490 Gaming E
CPU
I9-10850k
Graphics
rx6600
Mac
  1. iMac
Can you guys turn on verbose logging so we can see where it's getting stuck? It's under the NVRAM section of config.plist on your boot USB: (add the -v flag)

Code:
<key>7C436110-AB2A-4BBB-A880-FE41995C9F82</key>
            <dict>
                <key>SystemAudioVolume</key>
                <data>Rg==</data>
                <key>boot-args</key>
                <string>alcid=1 -v</string>
                <key>csr-active-config</key>
                <data>5wMAAA==</data>
                <key>prev-lang:kbd</key>
                <string>en-US:0</string>
            </dict>

I would also check the BIOS settings and make sure all the "standard" Hackintosh settings are set correctly. Things like fast boot off, XHCI hand off enabled, etc. Any of the guides on here for a Z390 should have the settings.


You guys should start here to make sure you're creating the OpenCore boot USB correctly:


Comet Lake specific guide:



EDIT: Found the BIOS settings also in that guide (recently added)


Disable:

  • Fast Boot
  • VT-d (can be enabled if you set DisableIoMapper to YES)
  • CSM
  • Thunderbolt(For initial install, as Thunderbolt can cause issues if not setup correctly)
  • Intel SGX
  • Intel Platform Trust
  • CFG Lock (MSR 0xE2 write protection)(Apparently this is already off on our Asus boards)
Enable:

  • VT-x
  • Above 4G decoding
  • Hyper-Threading
  • Execute Disable Bit
  • EHCI/XHCI Hand-off
  • OS type: Windows 8.1/10 UEFI Mode
  • DVMT Pre-Allocated(iGPU Memory): 64MB
Hi, Does your BT card show up under BT in system report as chipset BCM94360CD? I just bought a combo with adapter 2nd hand: supposed to be with orig. imac with BCM94360CD chipset, shown in a photo but there is a heatsink on it I don't want to risk removing and it comes up as BCM20702B0 in system report. BT connects to speakers but ipad is impossible with this system or the intel setup under Monterey or even Catalina with the card. Thx!
 
Top