Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Aug 5, 2014
Messages
311
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Here's a build of 0.7.6 with all the latest kexts, let me know how it works for you.

View attachment 536682

View attachment 536683


Code:
craig@Craigs-iMac ocvalidate % pwd

/Users/craig/Downloads/OpenCore-0.7.6-RELEASE/Utilities/ocvalidate

craig@Craigs-iMac ocvalidate % ./ocvalidate /Volumes/EFI/EFI/OC/config.plist

Completed validating /Volumes/EFI/EFI/OC/config.plist in 0 ms. No issues found.

It works for now, thanks!
 
Joined
Aug 23, 2012
Messages
431
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Here you go!

Thank you very much for the effort.

Anyway, I cannot use the WLAN of the MOBO since it is on macOS very unstable, it drops too much. Bluetooth works good!

Here you go, let me know if it works for you. I'm guessing its the one that says IOUSBHostDevice, if it doesn't work then maybe it's sharing with the AURA controller.
 

Attachments

  • USBPorts.kext.zip
    2.7 KB · Views: 40
Joined
Aug 5, 2014
Messages
311
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Here you go, let me know if it works for you. I'm guessing its the one that says IOUSBHostDevice, if it doesn't work then maybe it's sharing with the AURA controller.
It works, thanks!

The last problem that I have is that the read audio suddenly doesn't work anymore since it identifies the front audio port as connected (I see it on the menu bar) also if it is actually NOT connected. I never had such a problem and I changed nothing. Do you know what it's happened here?

Next time that I will change my system I will just bought a Mac Mini, I don't have patience anymore…
 
Joined
Apr 26, 2011
Messages
30
Motherboard
Asus Strix Z490-E Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Hi scope666. Thank you very much for your hard work and for sharing your knowledge with us. I just made a build similar to yours last week. Before i had an older system running Catalina and Clover for many year and everything was great but i had to upgrade to a better system. I used your OC (0.7.4, and then upgraded to 0.7.6)..but i am running into a bit of issues...One major problem i have is the onboard ethernet...it`s very unstable..chrome tabs freeze very often...i tried an wifi card and there is no freezing but i need to use the ethernet for work. Is it working ok for you? Do i need to check something...Actually in the older system i had a Sonnet Presto Pro Gigabyte which i used for many years and was natively supported by MacOS..but i had the surprise that is not working anymore in Monterey although the driver is still present in Monterey and i see the vendor id inside..Maybe something related to OC? I quite new at opencore. Do you have any suggestions what i can try or how to fix it? I saw it uses AppleBCM5701Ethernet.kext from inside IONetworkingFamily.kext. I checked this on my older Catalina hdd on the same new system..but in my new Monterey with your OC it does not even show up inside Hackintool or System Report..weird. I would really appreciate any help on how to fix either the onboard lan or this presto card...Ah and one for question..That kext CommanderProFix is something i need for this motherboard or it`s a kext specifically for your system? Thank you again.
 
Joined
Apr 26, 2011
Messages
30
Motherboard
Asus Strix Z490-E Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Something i just realized now about this ethernet driver..it says something while booting about it.
Any idea what it means?
 

Attachments

  • PXL_20211213_071632520~3.jpg
    PXL_20211213_071632520~3.jpg
    290.8 KB · Views: 50
Joined
Aug 23, 2012
Messages
431
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 3080 Ti (Win) / RX 560 (Mac)
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Something i just realized now about this ethernet driver..it says something while booting about it.
Any idea what it means?

It looks to me the driver can't read the MAC address from the NIC. I can't speak to Monterey because I'm still on Big Sur. I don't jump to new versions quickly because I use this machine for work, and also Pro Tools, which takes awhile to certify new Operating Systems.

Some notes specific to Monterey here: https://dortania.github.io/OpenCore-Install-Guide/extras/monterey.html#amd-patches
 
Joined
Apr 26, 2011
Messages
30
Motherboard
Asus Strix Z490-E Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Just tried this morning BigSur and the network card does not work here as well..so something changed since BigSur..The bluetooth dongle works in BigSur..and i succeeded in making it work in Monterey thanks to your link!
Thank you.

PS: Only issue that i still need to fix in Monterey the unstable onboard ethernet...
 
Joined
Aug 5, 2014
Messages
311
Motherboard
ASUS Z490-E
CPU
i9-10900K
Graphics
UHD 630
Can anyone tell me how to disable front audio, please?
 
Joined
Apr 26, 2011
Messages
30
Motherboard
Asus Strix Z490-E Gaming
CPU
i9-9900K
Graphics
RX 580
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
Just a short update..for anyone that has a network card using BCM5701Ethernet.kext that worked on Catalina and earlier..i found this CatalinaBCM5701Ethernet.kext on GitHub and put it in my OC kexts folder and not my Presto card (with BCM57762 Gigabit chipset) is back and running properly :D
 
Joined
May 6, 2021
Messages
3
Motherboard
Asus Z490-e
CPU
Intel Core i9-10850k
Graphics
EVGA Nvidia GTX 1070
is it safe to update from big sur to monterey with this? i just got my machine running today on the latest version of big sur
 
Top