Contribute
Register

[Success] - Asus ROG Strix Z490-E Gaming + i9 10900K + OpenCore

Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Thanks guys, I will try it and get back with results.
 
Joined
Jun 21, 2020
Messages
12
Motherboard
Gigabyte GA-Z97-D3H
CPU
i7-4790K
Graphics
RX 580
Hi Hemon,
ASUS Z490-E + i9-10900K can fully work with Mojave ?
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Hey guys, just had a crack using Scopes EFI, getting a hangup at the following running in verbose, anybody able to shed any light? Perhaps a graphics issue? see screenshots.

Bit more information I am running the Asus Hero XII Wifi Motherboard with a i7 10700 and Radeon 5700XT.

I've set BIOS as you had shown in the earlier post, with the exception of Execute Disable Bit? Can't seem to find that anywhere in the BIOS.

Any help would be greatly appreciated.
 

Attachments

Joined
Aug 23, 2012
Messages
178
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 2080 Ti (Win) / RX 560 (Mac)
Mac
MacBook Pro
Mobile Phone
iOS
Hey guys, just had a crack using Scopes EFI, getting a hangup at the following running in verbose, anybody able to shed any light? Perhaps a graphics issue? see screenshots.

Bit more information I am running the Asus Hero XII Wifi Motherboard with a i7 10700 and Radeon 5700XT.

I've set BIOS as you had shown in the earlier post, with the exception of Execute Disable Bit? Can't seem to find that anywhere in the BIOS.

Any help would be greatly appreciated.
Maybe try this EFI instead, that GPU is a bit different from my understanding:


(he mentions 5700XT)
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Maybe try this EFI instead, that GPU is a bit different from my understanding:


(he mentions 5700XT)
No luck there mate, has more issues I'd say, CPU unrecognised and hangs up on please switch to xpc or bootstrap_check_in()
 
Joined
Aug 23, 2012
Messages
178
Motherboard
Asus ROG Strix Z490-E
CPU
i9-10900K
Graphics
RTX 2080 Ti (Win) / RX 560 (Mac)
Mac
MacBook Pro
Mobile Phone
iOS
Take a look here, they have a lot of specific areas that you can get stuck listed and solutions for them:



Also some other repositories:

https://github.com/jergoo/Hackintosh-ROG-STRIX-Z490I (very clearly documented)

https://github.com/SchmockLord/Hackintosh-Intel-i9-10900k-Gigabyte-Z490-Vision-D (Gigabyte but very similar)


Also perhaps because of your different cpu, I'd look into Cpuid1Data and Cpuid1Mask

EDIT:
Found this, perhaps my Emulate section needs to come out, might be messing you up:

Emulate: Needed for spoofing unsupported CPUs, thankfully in 10.15.5 Comet Lake S support was added so no need to spoof here. For those running High Sierra or Mojave, you will need the below to spoof to a supported CPU model(due to stability issues, this guide will not go over such CPUID spoofs)
 
Last edited:
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Thank you very much mate, will have a play around today and let you know how I go.
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Take a look here, they have a lot of specific areas that you can get stuck listed and solutions for them:



Also some other repositories:

https://github.com/jergoo/Hackintosh-ROG-STRIX-Z490I (very clearly documented)

https://github.com/SchmockLord/Hackintosh-Intel-i9-10900k-Gigabyte-Z490-Vision-D (Gigabyte but very similar)


Also perhaps because of your different cpu, I'd look into Cpuid1Data and Cpuid1Mask

EDIT:
Found this, perhaps my Emulate section needs to come out, might be messing you up:

Emulate: Needed for spoofing unsupported CPUs, thankfully in 10.15.5 Comet Lake S support was added so no need to spoof here. For those running High Sierra or Mojave, you will need the below to spoof to a supported CPU model(due to stability issues, this guide will not go over such CPUID spoofs)
With the Emulate, are you referring to just removing the data you had input under CPUID1Data and Mask? Or is there something else I need to do? I seem to get the furthest out of all of the EFI's available from other builds but still getting the Unsupported CPU and Unsupported PCH error after 'DSMOS has arrived'.
 
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Going through open core troubleshoot, my install boot seems to be failing at GPU driver initialisation. With your config.plist, should I be changing something for my different GPU? Apologies for all the questions... Could use any help I can get it seems.

EDIT:

OK, I seem to get past that issue now by using the pikera arg, but now I just get hit with a wall of text

(com.apple.xpc.launchd.domain.pid.KeyRecoveryAssi.614) <Error>: Failed to bootstrap path: path = /System/Library/*/*/* etc.

Finally after a couple minutes I get

apfs_module_stop:1730: unload: com.apple.filesystems.apfs (remaining mem allocated: 0)
ConsideRebuildofPrelinkedKernel com.apple.nke.webcontentfilter triggered rebuild
Forcing CS-RUNTIME for entitlement : com.apple.private.security.kext-management.

before just freezes, doesn't black screen just wont go any further.
 
Last edited:
Top