Contribute
Register

[Success] ASUS PRIME Z390-P | i5-8600K | UHD 630 | Mojave 10.14.2 - 10.14.6

Joined
Dec 26, 2015
Messages
287
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
  1. Android
Why did you tell me to change keyboard?

Borrow from someone...so that you can press f1. By the way once again the problem is related to memory. Windows can recover it but hackintosh can't. In which slots did you put the rams in your mobo?
 
Joined
Mar 19, 2015
Messages
27
Motherboard
Asus Prime Z390-P
CPU
i5-9600K
Graphics
Vega 56
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi @poles , finally I've managed to get a 99% working hackintosh. I've I wanted to know if you was able to enable native NVRAM on our motherboard
 
Joined
Dec 26, 2015
Messages
287
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
  1. Android
Did you install EmuVariableUefi-64.efi on EFI/CLOVER/drivers64UEFI yet? If not then intall it and clear NVRAM and Kext Cache using Mac Optimizer 2.4 (google it) or use nvram -c (At clover boot screen select shell icon, type in the terminal).
Finally reboot.

How to check nvram:

NVRAM Testing: You can test if your NVRAM is working by running the following Terminal command and rebooting: sudo nvram TestVar=HelloWorld; once you reboot, run sudo nvram -p | grep 'TestVar'; if you see a result, your NVRAM is working; if not, your NVRAM is broken and needs to be fixed, or otherwise iMessage won't work; after testing, you can delete the TestVar variable by running sudo nvram -d TestVar
 
Joined
Oct 28, 2019
Messages
44
Motherboard
ASUS Prime Z390-P
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello,
I made an update to Catalina and my Network will not work again.

I already deleted all file in "/Library/Preferences/SystemConfiguration/"
I also copied the *.kext files from "EFI/CLOVER/kext/Other" to "/Library/Extensions" via hacking tool.
I set the two RTVariables before.

But still after a shutdown and new start the Hackintosh gets no IP-Adress.
After a replug of the network cable it works...

Could anyone give me a tip to resolve my Network problem with Catalina, please.

Thank you very much for your support.

Regards
kaminkehrer
 
Joined
Dec 26, 2015
Messages
287
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
  1. Android
In Catalina Apple has changed the write permission of system partition. By default its read only. You need to first enable write permission then install kext in Library/Extensions. Lastly don't forget to clear kext cache after kext installation. For more info check this post, specially "I can't install kexts to /Library/Extensions/ or any script into Installation partition ?"
 
Joined
Oct 28, 2019
Messages
44
Motherboard
ASUS Prime Z390-P
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
Hello poles,

I have done that but still no Network :(.

I followed all what you have liked round about Christmas in this thread and made rw and copied kext via Hackintool.
But Ethernet will not work.

I'm very pleased to get any help.

Regards
kaminkehrer
 
Joined
Oct 29, 2012
Messages
11
Motherboard
ASUS PRIME Z390-P
CPU
i3 8350K
Graphics
RX 580
just in case:
[SUCCESS] Catalina 10.15.3 | ASUS PRIME Z390-P | I3 8350K | 16 GB RAM | NVMe 1TB (OEM 961 probably) | RX 580
BIOS ver. 2401 (downgraded by ASUS Windows app, 2407 in my case can't boot from NVMe for some reasons)
EFI folder attached [serials changed]
 

Attachments

  • EFI.zip
    22.9 MB · Views: 88
  • Screenshot 2020-02-13 at 13.31.54.png
    Screenshot 2020-02-13 at 13.31.54.png
    218.5 KB · Views: 82
Joined
Dec 26, 2015
Messages
287
Motherboard
GA-Z97X-UD3H
CPU
i5-4690
Graphics
GTX 1050 Ti
Mobile Phone
  1. Android
just in case:
[SUCCESS] Catalina 10.15.3 | ASUS PRIME Z390-P | I3 8350K | 16 GB RAM | NVMe 1TB (OEM 961 probably) | RX 580
BIOS ver. 2401 (downgraded by ASUS Windows app, 2407 in my case can't boot from NVMe for some reasons)
EFI folder attached [serials changed]

How did you fixed the problem?
 
Joined
Sep 25, 2012
Messages
533
Motherboard
Asus ROG STRIX Z390-F
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
[SUCCESS] Catalina 10.15.3 | ASUS PRIME Z390-P | I3 8350K | 16 GB RAM | NVMe 1TB (OEM 961 probably) | RX 580
BIOS ver. 2401 (downgraded by ASUS Windows app, 2407 in my case can't boot from NVMe for some reasons)
EFI folder attached [serials changed]
Did you try this before downgrading BIOS?
 
Top