Contribute
Register

[SUCCESS] ASUS Prime Z390-A + i7 9700K + RX VEGA 64 (LC Edition)

Joined
Oct 25, 2018
Messages
13
Motherboard
Asus Prime Z390-A
CPU
i7-9700k
Graphics
Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
UPDATE TO THE BUILD:
Added a FENVI FV-T919 Airport and Bluetooth card. This thing worked OOTB without any sort of installation or mods to my build. Would highly recommend it so far!

As for my TB-3 GC-TITAN RIDGE card, not as great of news. It seems likes both TB3 ports are working and recognized by Windows and OS X, but the audio from my UAD Apollo is dropping samples or something as the audio sounds like it clips everyone and again.

The card also isn't passing the display port video onto my Apple Thunderbolt Display. :( So sadly after messing with it for about 4hours or so total, I took it out for now and put the Asus card back in. Not sure if this is an issue with my MOBO being ASUS and not Gigabyte, or if this is a bad card, or if the Titan Ridge chipset is too new and doesn't play well with my mobo bios yet etc.

I may sell the GC-TITAN RIDGE card, or I may just wait and see if others have the same issues. For now it's back to the old ASUS TB3-EX card Lol.
 
Joined
Nov 5, 2013
Messages
1
CPU
4670K
Graphics
650GT
Mac
Classic Mac
Mobile Phone
Hello Jakeofspades

Thanks so much for your wonderful post. I'm trying to install High Sierra on my system:
Intel 8700K
ASUS Prime-A
T-force Nighthawk 32gb 16x2 3200 mhz
Zotac GTX 980 (upgrade soon to be Inno GTX 3d 1080ti)
Thermaltake 750W
ASUS [PCE-AC68] Dual-band Wireless-AC1900 PCI-E Adapter
UAD DUO MkI​

Actually I have the same idea like you for using this Hackintosh for music and video production (hackintosh with Thunderbolt) The reason I don't go for 9700K right now because of the higher price of 9700K and its availability, and the little boost performance I would get from the chip as of this BIOS version. So that's why I'm still using 8700K on Z390 MB with an idea of upgrading to 9900K in the near future when its price drops.

I will by ASUS ThuderboltEX 3 soon for connecting to my UAD Twin mk1 with TB2.

Is it possible for you to post your config.plist? I just would like to try your setting just in case that it might work for my system with minimal tweak? Also once you can make ASUS TBex3 works, please let me know. I would be very excited to using my UAD on my hackintosh soon.

Would you have any suggestion for me according to settings you have been through with yours? I'd be thankful for your recommendation.

I haven't finished installing High Sierra yet. The process would always take very long, at least 30 mins, and then stop at 2 mins before it would complete the installing. Is there any advice for that? I already disable Nvidia dr on bootflag

Thank you.

cl2018
 
Joined
Jan 3, 2011
Messages
371
Motherboard
Asus TUF Sabertooth X99
CPU
Intel Core i7 5950k @ 4.4Ghz
Graphics
Radeon RX Vega 64
Mac
MacBook Pro
Mobile Phone
iOS
so with Rx Vega 64 8GB you do not need any drivers or any special kext patches?

I have Sierra. I have GTX 780 Ti and GTX 1080 Ti.
I heard no (zero) support or drivers for Mojave.
Last year I remember waiting and waiting and waiting for drivers until they were FINALLY released.

So having Nvidia means waiting 6+ months and maybe never having support.
With mojave for example, all AMD users are already enjoying the latest OS.

Therefore I have decided to switch to AMD.
I just want to know if it 'just works' or there is a clover kext or a fix or a BIOS setting or a driver that I need to use.

Thanks!
 

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
2,600
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
In an effort to get my iGPU working, I've enabled it in BIOS with PCIE being the primary display. I have installed the lilu & whatevergreen kexts but this does not appear to work ... I was reading on another recent build that there's a way to set this iGPU up as a 'headless' gpu and that it actually helps performance quite a bit, so I'm sure there's something simple I'm missing here that can be fairly easily remedied.
@Jakeofspades,

Really nice looking build, for information on setting the IGPU as headless see this guide :-

https://www.tonymacx86.com/threads/an-idiots-guide-to-lilu-and-its-plug-ins.260063/

There is a dedicated section on setting up a headless PlatformID in the WhatEverGreen part of the guide.

I have the Sapphire Vega 64 LC GPU, by default when the card is put under load the GPU temp rises but the Fan/Pump speed decreases ... the solution for me was to inject a custom SoftPowerPlayTable, see this guide for more info on how to monitor the vega GPU and how to fix the issue (if your card suffers from it) :-

https://www.tonymacx86.com/threads/guide-injection-of-amd-vega-power-and-fan-control-properties.267519/

Cheers
Jay
 
Last edited:
Joined
May 14, 2014
Messages
27
Mac
iMac, MacBook Pro
Mobile Phone
iOS
I got a Asus Prime Z390-A, a Intel 9900K and the Vega 56.
The only thing that does not work is USB 3.
Does your USB 3 work?
Did you have any issues getting this up and running? I am considering buying the 9900k and a Vega 64 to put in my ASUS Maximus X Hero Z370 but wasn't sure how compatible it would all be.
 
Joined
May 14, 2014
Messages
27
Mac
iMac, MacBook Pro
Mobile Phone
iOS
No issues with my Vega 56 or the CPU. Runs out of the box, but i'm having troube getting USB 3 to work.
Gotcha. USB 3 has always been an issue for me whenever I've built Hackintoshs, I wonder if there will ever be a 100% fix.
 
Top