Contribute
Register

[Success]: ASUS P7P55D-E LX Mountain Lion 10.8.2 [Guide]

Did you find this guide to be helpful?


  • Total voters
    60
Status
Not open for further replies.

lexone

Moderator
Joined
Apr 13, 2012
Messages
497
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 780
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Hi, any suggestions for getting this dsdt file working with a P7P55D PRO on 10.8.2?

Which DSDT? Are you using a DSDT? What's not working?

The DSDT that's attached to this thread is one that I created and patched for my mobo (P7P55D-E LX) and will not work on your mobo. You need to download the correct one for your mobo and BIOS version from here. Once you've downloaded your DSDT, rename the file to DSDT.aml and place it on the desktop then install it with MutliBeast by selecting UserDSDT.
 
Joined
Oct 1, 2012
Messages
21
Motherboard
Asus P7P55D-E LX
CPU
i7 870 2.93 ghz
Graphics
Radeon HD5870
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Yes! I think I just got this mfer to work! Just a couple (5) hours and it totally worked. That VoodooHDA.kext and AppleHDADisabler.kext both worked perfectly. The only thing that happened was for some reason after I installed that I ended up having to install a .kext for my ethernet which stopped working (not sure wtf that was about).

I also didn't use your .aml, I just used the standard ASUS-P7P55D-E LX .aml and that seemed to work really well. (Note: first time through I used your .aml and got some kind of crazy hanging load up screen and was forced to reinstall – which I ended up doing twice 'cause I didn't reformat the drive before I reinstalled the first time. Not sure why that happened. The error was something like "header read size 200 incorrect image" and then it just hung and I was forced to hard stop the computer.)

I even just got Bluetooth working and did my comparison: I paid 4 times less for this rig (and monitor) than I would've paid for a MacPro of roughly equivalent settings. :thumbup:

Functional build as of this instant:
ASUS P7P55D-E LX
Inte Core i7 2.94 GHz (Quad)
Radeon HD 5870 1024 MB VRAM
8 GB Corsair DDR3 RAM
Dell U2711 (running native resolution 2560x1440)

So far, so good. :D
 

lexone

Moderator
Joined
Apr 13, 2012
Messages
497
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 780
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
Yes! I think I just got this mfer to work! Just a couple (5) hours and it totally worked. That VoodooHDA.kext and AppleHDADisabler.kext both worked perfectly. The only thing that happened was for some reason after I installed that I ended up having to install a .kext for my ethernet which stopped working (not sure wtf that was about).

I also didn't use your .aml, I just used the standard ASUS-P7P55D-E LX .aml and that seemed to work really well. (Note: first time through I used your .aml and got some kind of crazy hanging load up screen and was forced to reinstall – which I ended up doing twice 'cause I didn't reformat the drive before I reinstalled the first time. Not sure why that happened. The error was something like "header read size 200 incorrect image" and then it just hung and I was forced to hard stop the computer.)

I even just got Bluetooth working and did my comparison: I paid 4 times less for this rig (and monitor) than I would've paid for a MacPro of roughly equivalent settings. :thumbup:

Functional build as of this instant:
ASUS P7P55D-E LX
Inte Core i7 2.94 GHz (Quad)
Radeon HD 5870 1024 MB VRAM
8 GB Corsair DDR3 RAM
Dell U2711 (running native resolution 2560x1440)

So far, so good. :D

Awesome! :headbang: glad to know I was able to help you out. Which VoodooHDA.kext did you install? My custome v2.7.2 or v2.7.4 that came with the AppleHDADisabler? I didnt have to use the disabler at all and my v.2.7.2 was edited to fix the volume slider so it actually works and to provide onboard Microphone support. Weird that my DSDT didn't work for you...but i didnt download it from TonyMac's site because that one gave me issues so I created and patched my own straight from my board. Glad to know ur setup works so please +1 and provide positive feedback.
Enjoy your system...:thumbup:
 
Joined
Oct 1, 2012
Messages
21
Motherboard
Asus P7P55D-E LX
CPU
i7 870 2.93 ghz
Graphics
Radeon HD5870
Mac
  1. iMac
  2. MacBook Pro
  3. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Awesome! :headbang: glad to know I was able to help you out. Which VoodooHDA.kext did you install? My custome v2.7.2 or v2.7.4 that came with the AppleHDADisabler? I didnt have to use the disabler at all and my v.2.7.2 was edited to fix the volume slider so it actually works and to provide onboard Microphone support. Weird that my DSDT didn't work for you...but i didnt download it from TonyMac's site because that one gave me issues so I created and patched my own straight from my board. Glad to know ur setup works so please +1 and provide positive feedback.
Enjoy your system...:thumbup:

I think you did help, btw, because I wasn't getting anywhere just asking. But you put me on the right path.

It is weird that your DSDT didn't work for me. But my install ended up being pretty vanilla, actually. With the exception of the Disabler and a couple of things in Multibeast, I didn't have to do much to get this thing working. :)
 

lexone

Moderator
Joined
Apr 13, 2012
Messages
497
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 780
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
I think you did help, btw, because I wasn't getting anywhere just asking. But you put me on the right path.

It is weird that your DSDT didn't work for me. But my install ended up being pretty vanilla, actually. With the exception of the Disabler and a couple of things in Multibeast, I didn't have to do much to get this thing working. :)

Glad to know i was able to help...enjoy!


:thumbup:...:clap:...:thumbup:
 
Joined
Jun 25, 2011
Messages
8
Motherboard
Gigabyte GA-z68XP-UD4
CPU
i7 2600k
Graphics
ATI Radeon 6950 2GB
Mac
Classic Mac
Mobile Phone
Which DSDT? Are you using a DSDT? What's not working?

The DSDT that's attached to this thread is one that I created and patched for my mobo (P7P55D-E LX) and will not work on your mobo. You need to download the correct one for your mobo and BIOS version from here. Once you've downloaded your DSDT, rename the file to DSDT.aml and place it on the desktop then install it with MutliBeast by selecting UserDSDT.

I was wondering if using your DSDT as a base and tweaking it for my own mobo would work, but it sounds like I should start from scratch and edit that one. I have tried the DSDT from the resources section here, but it does not work for me in 10.8.2. How do I create my own DSDT for my mobo? So far my install is working with exotic kexts for my 4890 card, but I am booting from my unibeast drive. Every time I try to install a boot loader, it hangs on the grey apple screen with the spinning wheel. TYIA
 

lexone

Moderator
Joined
Apr 13, 2012
Messages
497
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 780
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
I was wondering if using your DSDT as a base and tweaking it for my own mobo would work, but it sounds like I should start from scratch and edit that one. I have tried the DSDT from the resources section here, but it does not work for me in 10.8.2. How do I create my own DSDT for my mobo? So far my install is working with exotic kexts for my 4890 card, but I am booting from my unibeast drive. Every time I try to install a boot loader, it hangs on the grey apple screen with the spinning wheel. TYIA

Yea my DSDT will not work for your board since they use different BIOS versions.

Follow this guide: (GUIDE) Creating Your Own DSDT for Most Boards While these instructions are done via Mac, it's pretty much the same for Windows.

I may be able to help you fix your issue tho with being stuck at the grey apple screen. Do you get a spinning dial at all to show it is booting? Boot into your MacHD via UniBeast drive using the verbose (-v) parameter (select your MacHD and type -v then hit enter to boot into that drive). Let me know where it gets stuck. If you can please take a picture of the screen with a camera or your phone and attach so I can see where it gets stuck. If you are experiencing what I am thinking, I may have already uploaded the files you need in my guide to fix your problem so i will try my best to explain what you need to do to resolve the issue. I too was having that problem where I would get stuck at a grey apple boot screen with no spinning dial and I fixed it :thumbup:
 
Joined
Jan 31, 2012
Messages
46
Motherboard
Asus p7p55de-lx
CPU
core i5 760
Graphics
Asus HD6850
Mac
Classic Mac
Mobile Phone
  1. iOS
I got my first kernel panic couple of days ago and dont remember what it was saying exactly also didn't care for first time kernel panic, just restarded and booted fine..

but just couple of minutes ago I got my 2nd kernel panic while starting up at grey screen. it was something like at the top faulting cpu error 0x3

and at the bottom it was saying like that

dependency: com.apple.iokit.IOPCIFamily
dependency: VoodooHda.kext

restarted and booted fine...

I also checked your first post again and saw your bios screens. ACPI 2.0 support is enabled on my bios which is disabled in yours and s3 settings might be different than yours, can't remember now and dont know these settings can cause random kernel panics at startup. I was also getting random kernel panics on lion at startup but after restarting it was booting fine, maybe I should tweak my bios settings and try your AppleACPIPlatform.kext. Also I didn't delete applehda.kext.

yea its time to tweaking and hachintoshing :)
 

lexone

Moderator
Joined
Apr 13, 2012
Messages
497
Motherboard
GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 780
Mac
  1. iMac
  2. Mac Pro
Mobile Phone
  1. iOS
I got my first kernel panic couple of days ago and dont remember what it was saying exactly also didn't care for first time kernel panic, just restarded and booted fine..

but just couple of minutes ago I got my 2nd kernel panic while starting up at grey screen. it was something like at the top faulting cpu error 0x3

and at the bottom it was saying like that

dependency: com.apple.iokit.IOPCIFamily
dependency: VoodooHda.kext

restarted and booted fine...

I also checked your first post again and saw your bios screens. ACPI 2.0 support is enabled on my bios which is disabled in yours and s3 settings might be different than yours, can't remember now and dont know these settings can cause random kernel panics at startup. I was also getting random kernel panics on lion at startup but after restarting it was booting fine, maybe I should tweak my bios settings and try your AppleACPIPlatform.kext. Also I didn't delete applehda.kext.

yea its time to tweaking and hachintoshing :)

The only BIOS settings that need to be changed are the ones stated in this guide, any others are at your own risk.

As for the KP's....remember VoodooHDA.kext is known to be problematic although I haven't had any issues with my version since installing it but a random KP here & there is OK. If it happens again, please take a pic of it with a camera or phone and upload for me to see.

I would definitely recommend installing the AppleACPIPlatform.kext from my guide as this helped me to boot my system without any KP's.

Give it a shot. Let me know if there is anything else I can do to help you out as I haven't had any KP's yet on my system.
:thumbup::headbang:
 
Joined
Jan 31, 2012
Messages
46
Motherboard
Asus p7p55de-lx
CPU
core i5 760
Graphics
Asus HD6850
Mac
Classic Mac
Mobile Phone
  1. iOS
I tweaked some bios settings and disabling hda controller on bios caused no audio on os x. tried applehdadisabler.kext and fix permissions/caches but it didnt help either. then I re-enabled hdacontroller on bios and now works OK. the other settings I changed; Suspend mode was auto, changed to S3 only like yours, Repost Video on S3 Resume was No changed to YES.

during all these period restarted more than 5 times and no kernel panics at all. my os x works fine nothing changed but if I get another kernel panic, next time I'll take a picture of it and try your AppleACPIPlatform.kext thanks four your effort :thumbup:

btw have you tried multibeast 5.1 update? it contains patched applehda.kext and various fixes.
 
Status
Not open for further replies.
Top