Contribute
Register

[SUCCESS] Asus H370-I ITX, 8600k, RX560, 970 EVO Mojave Journey

Joined
Dec 3, 2018
Messages
94
Motherboard
ASUS H370-I Gaming ITX
CPU
i5-8600K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
I've done some port patching with some success to a certain degree. I like the idea of kext free patching as described here But I could not get it to work. Hopefully someone could help me on that. So in the mean time I followed this guide, with great success.

Ive attached the files I've used. The ports I've decided on was the internal BT port (HS14), front ports and all rear ports except for the middle two (3 & 4).
Screenshot 2018-12-31 at 12.00.58.png
 

Attachments

Joined
Dec 3, 2018
Messages
94
Motherboard
ASUS H370-I Gaming ITX
CPU
i5-8600K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
Next I wanted to see if I could parallels as sometimes its easier to try software in a VM, especially anything Microsoft. To get working the BIOS settings are as follows:

Advanced -> CPU Configuration -> Intel (VMX) Virtualisation Technology = Enabled.
Advanced -> System Agent (SA) Configuration -> VT-d = Enabled.

In Clover Configuration in "Boot" make sure that "dart=0" is checked. For some reason is its unchecked and from a cold boot I lose bluetooth and get "busy timeout BCM20702A0" message.
 
Joined
Dec 3, 2018
Messages
94
Motherboard
ASUS H370-I Gaming ITX
CPU
i5-8600K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
Just installed the debug reporting tool. If anybody has a spare moment go over my dump and see if everything is ok or if I need to do anything else that would be most appreciated, Cheers.
 

Attachments

Joined
Dec 29, 2018
Messages
5
Motherboard
ASRock Z370M-ITX/ac P3.20 - Clover UEFI
CPU
i5-9600K
Graphics
Intel UHD 630, Zotac GTX 1080ti mini
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hi @djashjones, do you have working USB Type C port on the back panel? Did you fix the 15 port limit?
I have the same motherboard, here is my SSDT UIAC (with a description of each port).
 

Attachments

Joined
Dec 3, 2018
Messages
94
Motherboard
ASUS H370-I Gaming ITX
CPU
i5-8600K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
Hi, On your setup I would enable SS04 and disable HS11 as the LED controller is not needed. You can tweak the RGB in the bios if you really wanted to.

The reason I disabled the type c port is that the only type c devices I have is an external hard drive which came with both types of cables. I also have a couple of type C adapters both types as my MBP has thundbolt ports.

Also another reason is that the 2 red ports are gen 2 (the same as the type C) and Im planning to get a powered external hub that can output 5Gbps per port on my desk as the case is on the floor.
 
Joined
Dec 3, 2018
Messages
94
Motherboard
ASUS H370-I Gaming ITX
CPU
i5-8600K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
Noticed late last night by accident that jpg preview did not work. I fixed it by following this guide, found here. Thanks to Averett for his solution.
 
Joined
Jan 5, 2019
Messages
6
Motherboard
ROG Strix H370-i Gaming
CPU
i5-8400
Mac
Mac mini
Mobile Phone
Android
Finally managed to get Mojave installed thanks to everyone here. I'm still struggling with audio. I've got no output devices listed. I used your post EFI and tried to follow some of the guides I've found but I have had no luck. I've really new to OSx.... Do you have any suggestions?
 
Joined
Dec 3, 2018
Messages
94
Motherboard
ASUS H370-I Gaming ITX
CPU
i5-8600K
Graphics
RX 560
Mac
MacBook Pro
Mobile Phone
iOS
What audio options did you with Multibeast and have you got Clover Configurator installed?
 
Top