Contribute
Register

[Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

Joined
Dec 13, 2010
Messages
338
Motherboard
Z390 PHANTOM GAMIG-ITX/ac
CPU
i5-9600K
Graphics
UHD 630
Mac
  1. iMac
  2. Mac mini
Mobile Phone
  1. Android
  2. iOS
My tests, according to the SSDT-TbtOnPch_PINI.aml version of post #922 (Mango1122) with the first one appears in system properties the Thunderbolt but I lose the hot plug and i can not eject.

With the second one SSDT-TbtOnPch_PINI_D8.aml, it disappears from the system properties but the hot plug returns.

With the original post # (rj510) SSDT-Z390-ASRock-ITX-AR-TB3-V8.aml I have ACPI errors in the log but it has hot plug and disconnect well.

It would be great to do both at the same time, but I prefer it to work than be shown.

It shows very differently how the two work because of such a simple change...;)
 
Joined
May 17, 2012
Messages
51
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
I don't know what I did exactly, but using @mango1122 and @baja-king files that you both posted, I have it working somehow.
 

Attachments

  • Screen Shot 2020-05-05 at 3.57.25 PM.png
    Screen Shot 2020-05-05 at 3.57.25 PM.png
    149.4 KB · Views: 56
Last edited:
Joined
May 23, 2019
Messages
242
Motherboard
ASRock Z390 Phantom
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
@candurin @baja-king . Here's my EFI (OC 0.5.8) - IGPU only. Add section Generic under the PlatformInfo with your board details.
 

Attachments

  • EFI May 2020 - 0.5.8.zip
    56.8 MB · Views: 98
Joined
May 17, 2012
Messages
51
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Thanks @mango1122. I was able to clean up my kexts and EFI a bit. I was not able to use the "D8" version. The "DC" version does work and it populates the thunderbolt information in System report.
 

Attachments

  • Screen Shot 2020-05-05 at 9.20.34 PM.png
    Screen Shot 2020-05-05 at 9.20.34 PM.png
    420 KB · Views: 39
Last edited:
Joined
May 23, 2019
Messages
242
Motherboard
ASRock Z390 Phantom
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Guys can anyone check the logs with hackintool and filter for Thunderbolt and paste the result ?
Is there any error you see with - my logs don't have any error > but im curious if anyone is seeing an error related to DROM ?

Code:
2020-05-06 16:31:08.810690+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::probe(IOService*, int*)> AppleThunderboltGenericHAL::probe
2020-05-06 16:31:08.810692+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::probe(IOService*, int*)> 1810691us AppleThunderboltGenericHAL::probe
2020-05-06 16:31:08.810709+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::start(IOService*)> AppleThunderboltGenericHAL::start
2020-05-06 16:31:08.810711+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::start(IOService*)> 1810710us AppleThunderboltGenericHAL::start
2020-05-06 16:31:08.811129+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHI::start(IOService*)> Thunderbolt runtime power conservation disabled.
2020-05-06 16:31:08.811131+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHI::start(IOService*)> Thunderbolt runtime power conservation disabled.
2020-05-06 16:31:08.811520+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHIType3::publishPCILinkData()> Thunderbolt 255 PCI - LS=0x7023 LC=0x0040 SS=0x0140 SC=0x0008 PMCSR=0x0000 RT=0xffffffff NLRT=0xffffffff LWRT=0xffffffff PRRT=0xffffffff TRT=0x0000 TNLRT=0x0000 TLWRT=0x0000 TPRRT=0x0000 TLUP=0x0001
2020-05-06 16:31:08.811526+0800  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHIType3::publishPCILinkData()> Thunderbolt 255 PCI - LS=0x7023 LC=0x0040 SS=0x0140 SC=0x0008 PMCSR=0x0000 RT=0xffffffff NLRT=0xffffffff LWRT=0xffffffff PRRT=0xffffffff TRT=0x0000 TNLRT=0x0000 TLWRT=0x0000 TPRRT=0x0000 TLUP=0x0001
2020-05-06 16:31:13.465169+0800  localhost kernel[0]: (AppleUserHIDDrivers) [AppleUserHIDEventDriver.cpp:93][0x100000639] CalDigit Thunderbolt 3 Audio usagePage: 12 usage: 1 vid: 8584 pid: 25907
 
Joined
May 23, 2019
Messages
242
Motherboard
ASRock Z390 Phantom
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
QQ => Did the formula change? Just curious - based on what @dgsga had posted, DC seemed to be the correct value. I guess not for us but would love to know why.



Awesome. Thanks! I'll try this today. Big thing for me is to see if TB3 gets restored after sleep & wake.

DC is the correct value but for my board the root port is at D8. See pic.
 

Attachments

  • Screenshot 2020-05-05 at 5.45.48 PM.png
    Screenshot 2020-05-05 at 5.45.48 PM.png
    168.2 KB · Views: 39
Joined
May 17, 2012
Messages
51
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Guys can anyone check the logs with hackintool and filter for Thunderbolt and paste the result ?
Is there any error you see with - my logs don't have any error > but im curious if anyone is seeing an error related to DROM ?

Here's mine:
Code:
Timestamp                       (process)[PID]    
2020-05-06 10:13:58.796680-0400  localhost kernel[0]: (kernel) IOElectrify: Thunderbolt force-power: ON.
2020-05-06 10:13:58.858478-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::probe(IOService*, int*)> AppleThunderboltGenericHAL::probe
2020-05-06 10:13:58.858480-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::probe(IOService*, int*)> 1858480us AppleThunderboltGenericHAL::probe
2020-05-06 10:13:58.858496-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::start(IOService*)> AppleThunderboltGenericHAL::start
2020-05-06 10:13:58.858497-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltGenericHAL::start(IOService*)> 1858497us AppleThunderboltGenericHAL::start
2020-05-06 10:13:58.858639-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHI::start(IOService*)> Thunderbolt runtime power conservation disabled.
2020-05-06 10:13:58.858641-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHI::start(IOService*)> Thunderbolt runtime power conservation disabled.
2020-05-06 10:13:58.858736-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHIType3::publishPCILinkData()> Thunderbolt 255 PCI - LS=0x7023 LC=0x0000 SS=0x0148 SC=0x0008 PMCSR=0x0000 RT=0xffffffff NLRT=0xffffffff LWRT=0xffffffff PRRT=0xffffffff TRT=0x0000 TNLRT=0x0000 TLWRT=0x0000 TPRRT=0x0000 TLUP=0x0001
2020-05-06 10:13:58.858742-0400  localhost kernel[0]: (AppleThunderboltNHI) <AppleThunderboltNHI`AppleThunderboltNHIType3::publishPCILinkData()> Thunderbolt 255 PCI - LS=0x7023 LC=0x0000 SS=0x0148 SC=0x0008 PMCSR=0x0000 RT=0xffffffff NLRT=0xffffffff LWRT=0xffffffff PRRT=0xffffffff TRT=0x0000 TNLRT=0x0000 TLWRT=0x0000 TPRRT=0x0000 TLUP=0x0001
 
Joined
May 23, 2019
Messages
242
Motherboard
ASRock Z390 Phantom
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Great so no thunderbolt DROM errors - I have tested with the SSDT method and everything seems to work perfectly. I've connected a TS3 dock and my primary display monitor to the dock. I see sleep/wake working good. I'll let it run for a while and report if I encounter issues.
 

Attachments

  • Screenshot 2020-05-05 at 5.41.44 PM.png
    Screenshot 2020-05-05 at 5.41.44 PM.png
    101.9 KB · Views: 20
Joined
May 17, 2012
Messages
51
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
I even cleaned up my PCI entries in System Report :)
 

Attachments

  • Screen Shot 2020-05-06 at 10.42.58 AM.png
    Screen Shot 2020-05-06 at 10.42.58 AM.png
    429.4 KB · Views: 30
Joined
May 17, 2012
Messages
51
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Great so no thunderbolt DROM errors - I have tested with the SSDT method and everything seems to work perfectly. I've connected a TS3 dock and my primary display monitor to the dock. I see sleep/wake working good. I'll let it run for a while and report if I encounter issues.

I have a dock on my MacBook, but I ordered a CalDigit dock for this build. I'll report back when it gets connected. I am too lazy to go undo all my cabling for my other dock :)
 
Top