Contribute
Register

[Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

Joined
Feb 25, 2014
Messages
106
Motherboard
Asus ROG Strix Z690-I
CPU
12700K
Graphics
RX 6900 XT
Can someone give me some quick advice on how to create CPUFriend/CPUFriend Data Provider? I've looked everywhere and can't seem to find a guide outside of the somewhat confusing readme on acidanthera's github. My goal is to use a MacPro7,1 SMBios with the stock frequencies for the 9900K (no OC) from iMac19,1.
 
Joined
Jan 3, 2017
Messages
11
Motherboard
ASRock Z390 Phantom Gaming-ITX/AC
CPU
i7-8700K
Graphics
Vega 56 Air Boost
Hi
I don't know if this thread is still active?
I have finish building an SFF rig with this ASRock Z390 Phantom Gaming-ITX/AC, i7 8700k, Vega 56, Broadcom BCM94352Z DW1560 and 64GB of RAM.

I have installed Mojave, and I'm struggling with USB ports and Bluetooth for more than a week. USB3 does not work (2 rear SS05-SS06 and front SS07 or SS08) and Bluetooth. Bluetooth pairs with speakers/mouse but no keyboard, and Airdrop does not detect iPhone (iPhone detect PC). Of course, no Thunderbolt.

I have tried everything that I could understand, and now I'm stuck.

Thanks.
 
Joined
Feb 25, 2014
Messages
106
Motherboard
Asus ROG Strix Z690-I
CPU
12700K
Graphics
RX 6900 XT
Joined
Feb 25, 2014
Messages
106
Motherboard
Asus ROG Strix Z690-I
CPU
12700K
Graphics
RX 6900 XT
Hi
I don't know if this thread is still active?
I have finish building an SFF rig with this ASRock Z390 Phantom Gaming-ITX/AC, i7 8700k, Vega 56, Broadcom BCM94352Z DW1560 and 64GB of RAM.

I have installed Mojave, and I'm struggling with USB ports and Bluetooth for more than a week. USB3 does not work (2 rear SS05-SS06 and front SS07 or SS08) and Bluetooth. Bluetooth pairs with speakers/mouse but no keyboard, and Airdrop does not detect iPhone (iPhone detect PC). Of course, no Thunderbolt.

I have tried everything that I could understand, and now I'm stuck.

Thanks.
Post a zip of your EFI (serials removed), and I’m sure someone can help. I’ve only ever used legit Apple WiFi cards. So I didn’t have to deal with the headache. But I’m sure someone here can help you. I’ll gladly take a look. And, yes, thread is still active.
 
Joined
Jan 3, 2017
Messages
11
Motherboard
ASRock Z390 Phantom Gaming-ITX/AC
CPU
i7-8700K
Graphics
Vega 56 Air Boost
Thank you onmybikedrunk here is my EFI...
 

Attachments

  • EFI.zip
    22.2 MB · Views: 76
Joined
Feb 25, 2014
Messages
106
Motherboard
Asus ROG Strix Z690-I
CPU
12700K
Graphics
RX 6900 XT
Thank you onmybikedrunk here is my EFI...
So I took a look... Now let me preface by saying that unfortunately I didn't keep much of my own personal hack's EFI data from Mojave... A bit of this had to come from some quick and dirty research. Give this EFI a try... I did update your SMBIOS to iMac19,1 with the use of both your iGPU (headless) and dGPU - so keep that in mind... If you're already signed into iServices then you can boot from the new SMBIOS and it'll ask you for your iCloud password again - everything should continue working. If not, make sure you clear out everything listed here. I also removed USBInjectALL and replaced it with a custom kext for our motherboard. It is specific to iMac19,1 and it also probably doesn't have the ports active the way you want them but we can figure out the exact ports later and I'll edit for you. I also installed TB3 SSDT so that should also be usable as TB3/USB3 but no hot-plug yet.

Also, the community has now fixed NVRAM via an SSDT to replicated it being native to Z390 boards, you need to update your EFI so it's fully supported. For now, I just left it as is with EMUvariable driver in place. If you want to fix your board so it supports native NVRAM, follow the instructions here. I realize both of those guides are for OpenCore but you can relate the info just as easily to a Clover install.

NOW, it is extremely hard to come up with a fresh EFI on the fly without sitting in front of the computer/hardware so use the posted EFI with caution - I would format a USB thumb drive and boot from the EFI of that or use a separate vanilla install so your original stays intact in case you want to go right back to it... DON'T DO ANYTHING WITHOUT A BACKUP! ALWAYS!

Honestly your original EFI was a bit of a mess. There was a ton of unnecessary stuff in there. Going forward I'd love to help, but let's take it to Discord or another method so we don't hijack the thread entirely. My username is the same on Discord.
 

Attachments

  • EFI 2.zip
    22.1 MB · Views: 97
Last edited:
Joined
Apr 28, 2012
Messages
44
Motherboard
z390 phantom gaming itx
CPU
9900ks
Graphics
5700 xt
Last edited:
Joined
Jan 3, 2017
Messages
11
Motherboard
ASRock Z390 Phantom Gaming-ITX/AC
CPU
i7-8700K
Graphics
Vega 56 Air Boost
You can add the boardid to the script, i just haven't tried it since power management seems to be working fine for me and don't want to mess something up, it's a matter of adding the imac19,1 or macprowhatever defenition to the script.
Do you mean changing SMBIOS to 19.1 ??
 
Top