Contribute
Register

[Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

Joined
Dec 10, 2018
Messages
18
Motherboard
Asrock z390 Phantom-Gaming itx/ac
CPU
i7-9700K
Graphics
RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. iOS
Hi! Here are some of the updates what I've done for my install.

I successfully install macOS Catalina 10.15.7 using an EFI provide on this post. (With OpenCore)

Indeed even, if I followed all the steps, i couldn't boot my USB stick with this EFI. (With Clover)

Once the installation done, I wanted to put my head in the EFI provide by rj510, because Thunderbolt/ USB-c is not working.

I tried to compare both of them but I think I'm still a little bit noob for those things. Haha!

I've done some changes on it. I actually can boot on it. But, when I launch my drive with Catalina, I just have the Apple logo, the white progressing bar and some weird violet things on the screen. Then a black screen.

I'll put my head in the Dortania's Guide. But, if someone have an idea for the clover EFI, I'm in !

Thank you for your help !

MacOS 10.15.7
Asrock z390 phantom gaming itx
i7 9700k / 32gb 3000Mhz Corsair vengeance
RX 570 4go
Samsung SSD 970 PRO Nvme (Apfs)
 

Attachments

  • EFI OC WORK.zip
    4.1 MB · Views: 43
  • EFI CLOVER NOT WORK.zip
    17 MB · Views: 29
Joined
May 16, 2012
Messages
85
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
ASRock has officially released the new Thunderbolt firmware for Asrock Z490 Phantom Gaming its/ac and it can be updated in Windows. I don't know if I can modify the officially released firmware so that it can update the modified Thunderbolt firmware in Windows.
This z490 uses titan ridge, no? Whereas our mobos are alpine ridge. How is this applicable?
 
Last edited:
Joined
May 3, 2022
Messages
15
Motherboard
GIGABYTE Z390-DESIGNARE
CPU
I9-9900KS
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
Yeah the SSDT is not loading - Can you try this ? Rename to SSDT-TbtOnPch.aml and paste the logs again.
P.S - For anyone else reading this > add SSDT-DTGP.aml
Rename _E2C to XE2C using Clover or OC

Edit - The address on the first line of MMBA method may be wrong. Should be "D8" instead of "DC" - Updated file attached as SSDT-TbtOnPch_PINI_D8.aml. For some users the Root port is at DC as seen in the IOReg while for some it is at D8 (my board). Choose what works for you.
Hi,mango1122,Sorry to bother you, I used your method, but my Thunderbolt3 is still not hotplug, I have to plug it in before booting to work properly, unplugged it and plugged it in again, and I couldn't find the Thunderbolt3 device,is there any way to fix it?
Thanks!
 

Attachments

  • 111.png
    111.png
    170 KB · Views: 27
  • 222.png
    222.png
    399.5 KB · Views: 24
  • 333.png
    333.png
    48.8 KB · Views: 29
  • uTools_1653062597914.png
    uTools_1653062597914.png
    222.2 KB · Views: 30
  • IMG_6735.jpg
    IMG_6735.jpg
    762.3 KB · Views: 28
Last edited:
Top