Contribute
Register

[Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

ASRock has officially released the new Thunderbolt firmware for Asrock Z490 Phantom Gaming its/ac and it can be updated in Windows. I don't know if I can modify the officially released firmware so that it can update the modified Thunderbolt firmware in Windows.
This z490 uses titan ridge, no? Whereas our mobos are alpine ridge. How is this applicable?
 
Last edited:
Yeah the SSDT is not loading - Can you try this ? Rename to SSDT-TbtOnPch.aml and paste the logs again.
P.S - For anyone else reading this > add SSDT-DTGP.aml
Rename _E2C to XE2C using Clover or OC

Edit - The address on the first line of MMBA method may be wrong. Should be "D8" instead of "DC" - Updated file attached as SSDT-TbtOnPch_PINI_D8.aml. For some users the Root port is at DC as seen in the IOReg while for some it is at D8 (my board). Choose what works for you.
Hi,mango1122,Sorry to bother you, I used your method, but my Thunderbolt3 is still not hotplug, I have to plug it in before booting to work properly, unplugged it and plugged it in again, and I couldn't find the Thunderbolt3 device,is there any way to fix it?
Thanks!
 

Attachments

  • 111.png
    111.png
    170 KB · Views: 85
  • 222.png
    222.png
    399.5 KB · Views: 70
  • 333.png
    333.png
    48.8 KB · Views: 73
  • uTools_1653062597914.png
    uTools_1653062597914.png
    222.2 KB · Views: 76
  • IMG_6735.jpg
    IMG_6735.jpg
    762.3 KB · Views: 77
Last edited:
Just to keep this threat alive. I have successfully updated to Ventura (13.0) using OpenCore 0.8.5. Took just 5 minutes using OpenCore Configurator, which I also used to update all the kexts.
 
Just to keep this threat alive. I have successfully updated to Ventura (13.0) using OpenCore 0.8.5. Took just 5 minutes using OpenCore Configurator, which I also used to update all the kexts.
Thanks for this info - very useful and reassuring for the future. Still on Catalina here (rock solid) but looking forward to updating when the time is right.
 
@candurin you're still running a 9600K right?
 
@candurin you're still running a 9600K right?
Correct. Haven’t changed anything in my build.

Having said that, I’m itching to update to a newer gen processor, Z690 ITX and RX 6800 XT. I’m just not in any rush to do so.
 
Last edited by a moderator:
Updated to Ventura 13.1, OC 0.8.7.

Quick and painless update. I just use the latest OpenCore Configurator (OCC). Only two kexts needed updates, which OCC did for me.
 
Updated to Ventura 13.1, OC 0.8.7.

Quick and painless update. I just use the latest OpenCore Configurator (OCC). Only two kexts needed updates, which OCC did for me.
Thanks for the update. gonna try this

Do you know how to enable video output from GPU? I'm using MSI Radeon RX 6600 Mech 2X 8GB
 
To be honest, I don’t. It’s set up in my config and I haven’t done anything with that in awhile outside whatever needs to be done during OC updates.
 
Hi there can you help me with updating? I have a similar build but I used Clover for Catalina system.
 
Back
Top