Contribute
Register

[Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

Joined
Sep 23, 2019
Messages
55
Motherboard
Asrock Z390 Phantom Gaming ITX
CPU
i9-9900K
Graphics
RX 580
OK. So with the update to 10.15.5 I do not any drivers are loaded under System Report > Thunderbolt. However, all my devices connected to my TB3 dock are working perfectly. Seems odd. Perhaps the SSDT needs to be updated for the most recent Catalina update?
So you managed to solve your rig freezing? If so, how?
 
Joined
May 16, 2012
Messages
86
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
So you managed to solve your rig freezing? If so, how?

I wish I had a highly technical and thorough response for you. I simply rebooted a few times and it corrected itself. The issue with TB drivers not populating remains.
 
Joined
Sep 23, 2019
Messages
55
Motherboard
Asrock Z390 Phantom Gaming ITX
CPU
i9-9900K
Graphics
RX 580
I wish I had a highly technical and thorough response for you. I simply rebooted a few times and it corrected itself. The issue with TB drivers not populating remains.
Ahh, was just being curious! The more info out there the better... BTW if your TB works fine, what is the issue about the drivers?
 
Joined
May 16, 2012
Messages
86
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
It was just the fact that on 10.15.4 I had full Thunderbolt information populating in System Report. With 10.15.5, this is no longer the case. More of an observation, really.
 
Joined
Dec 29, 2010
Messages
223
Motherboard
GA-Z97N-Gaming 5
CPU
Core i7 4790K
Graphics
Nvidia GTX 760
Mac
Classic Mac
Mobile Phone
I have Thunderbolt information populating in 10.15.5. Have you tried doing a cold boot (unplug the power for 2 minutes)?

That being said, I get a panic caused by an AMD GPU driver crash upon wake with these SSDTs, so I'm not using them for now.
 
Joined
Dec 6, 2010
Messages
68
Motherboard
AsRock Z490 ITX/TB3
CPU
i7 107000K
Graphics
UHD 630
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
@sffjawsh I can’t respond to your PM as I don’t have 75 posts. Please post your BIOS TB settings, SSDT-TbtOnPCH, config.plist and Tbt firmware version, and I’ll take a look. Your Z370 itx/ac should be working...
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,208
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
@sffjawsh I can’t respond to your PM as I don’t have 75 posts. Please post your BIOS TB settings, SSDT-TbtOnPCH, config.plist and Tbt firmware version, and I’ll take a look. Your Z370 itx/ac should be working...
No help in PMs as per the Forum Rules.
 
Joined
Oct 2, 2019
Messages
3
Motherboard
ASRock Z390
CPU
i9 9990K
Graphics
Internal
Anybody have any idea what’s not working with my initial install?
I have tried a mixture of combinations, all kinda based around the EFI on this board. BIOS settings matching this with built in graphics.

My install gets stuck always with a full bar on the Apple logo.
I got Z390 Asrock ITX with I9 9900K

BIOS is 4.0 currently
 

Attachments

  • 521238F1-8000-4EE9-B90E-96A35AD35908.jpeg
    521238F1-8000-4EE9-B90E-96A35AD35908.jpeg
    3.8 MB · Views: 71
Last edited by a moderator:
Joined
May 16, 2012
Messages
86
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Just following up. Everything seems back to normal with TB3 working and populating system report properly.
 
Joined
Dec 29, 2010
Messages
223
Motherboard
GA-Z97N-Gaming 5
CPU
Core i7 4790K
Graphics
Nvidia GTX 760
Mac
Classic Mac
Mobile Phone
@candurin, does wake from sleep work alright for you with the TB3 SSDTs?
 
Top