Contribute
Register

[Success] ASRock Z390 Phantom Gaming-ITX + TB3 + iGPU + Mojave + SFF Build

Joined
Jun 8, 2019
Messages
99
Motherboard
Z490 Vision D
CPU
i9-10900K
Graphics
Sapphire RX Vega64
Mac
  1. MacBook Pro
It would be good to find out if this SSDT-only approach works on the Z390 itx/ac as it might then work on the new Z490 Phantom Gaming-ITX/TB3...

@dgsga FWIW => The new Z490 board might have JHL7340 Thunderbolt 3 i.e. Titan Ridge controller. Will have to wait for the reviews but they're advertising it as 40gbps which is what they did with the X570 TB3 board (AMD) The X570 one has JHL7340.
 
Joined
Dec 16, 2019
Messages
8
Motherboard
Gigabyte Z390 I Auros pro Wifi
CPU
i7-9700K
Graphics
RX 580
Hello,
I have a question for you guys here! I am new to the ASRock z390 and OC. I use to have a Gigabyte Z390 I aorus, the motherboard burned out and got the Asrock as replacement. I finally got this board working thanks to this thread and I can say is pretty stable in my opinion. I am using OC because the board was sold to me upgraded to version 4.30. Now, I found that I am having issue when it comes to dual monitor/sidecard and photoshop. please view the image sample below:
Screen Shot 2020-05-11 at 5.15.10 PM.png

The only way that I can get photoshop to work with dual monitor is if I uncheck the graphic processor option under the performance tab. The only problem is that if I leave this option unchecked I can use certain tools that helps me facilitate my workflow. On top I have been experiencing random Kernel Panic causing the computer to restart by it self... Anyways my question for any of you in this thread...have anyone experiencing anything like this and how to fix?
 
Joined
May 23, 2019
Messages
243
Motherboard
ASRock Z390 Phantom
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Even I'm back to the native firmware. For me though, TB just dies after sleep & wake (TB link status changes to 0xe00002eb from 0x07/0x01). This is with all the combinations of iGPU vs iGPU & DGPU. I switched back so I could use my 5700 XT w/o kernel panics. I'll have to give up sleep :( but even if I put the device to sleep, I can restart gracefully.

I'll give the SSDT only approach a try again in a few weeks. I'll post my experience over in the Designare thread. Maybe @CaseySJ and others will have some insights.

I suppose that's a good thing to do. BTW on the SSDT method are you injecting any DROM properties ? Im trying to inject both the DROM and UUID to see if that stabilises the system after sleep. Will post an update soon.
 

Attachments

  • Screenshot 2020-05-18 at 7.47.09 PM.png
    Screenshot 2020-05-18 at 7.47.09 PM.png
    188.9 KB · Views: 29
  • Screenshot 2020-05-18 at 7.49.09 PM.png
    Screenshot 2020-05-18 at 7.49.09 PM.png
    406.3 KB · Views: 32
Joined
May 17, 2012
Messages
52
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
@mango1122 just another perspective. I just tested my setup over the course of the last 5 days. I let let my computer sleep multiple times and overnight, including a 48 hour sleep from which I woke the computer this morning. All devices and the TB3 dock are working perfectly and all information is populated in system report.

I don’t even know what DROM is :)
 
Joined
May 23, 2019
Messages
243
Motherboard
ASRock Z390 Phantom
CPU
i9-9900K
Graphics
UHD 630
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
@mango1122 just another perspective. I just tested my setup over the course of the last 5 days. I let let my computer sleep multiple times and overnight, including a 48 hour sleep from which I woke the computer this morning. All devices and the TB3 dock are working perfectly and all information is populated in system report.

I don’t even know what DROM is :)
Thats pretty awesome - did you do anything special ? I remember you reporting that the devices disappear from the System report after a while ?
 
Joined
Aug 12, 2017
Messages
222
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i7-8700K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. 512K
  2. Centris
  3. iBook
  4. iMac
  5. LC
  6. Lisa
  7. Performa
  8. Plus
  9. Power Mac
  10. PowerBook
  11. Quadra
  12. SE
  13. SE/30
Mobile Phone
  1. Android
  2. iOS
  3. Other
@mango1122 just another perspective. I just tested my setup over the course of the last 5 days. I let let my computer sleep multiple times and overnight, including a 48 hour sleep from which I woke the computer this morning. All devices and the TB3 dock are working perfectly and all information is populated in system report.

I don’t even know what DROM is :)
Hi just wonder if you are using Clover or OpenCore. I am on OpenCore 9.5.8 and have no problems with sleep now. No fans and deep sleep even for 2 days. But USB-C drives connected to Thunderbolt lose connection on sleep but mount again when I wake. Thunderbolt drives are disconnected and I have to restart to mount them. And if I unmount a USB-C drive in Thunderbolt it will not mount until restart.
 
Joined
May 17, 2012
Messages
52
Motherboard
ASRock Z390 Phantom Gaming-ITX
CPU
i5-9600K
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
@asleb I am using Clover.

@mango1122 The only hiccup I ever have is when I boot from cold, sometimes the TB3 port (and therefore dock) isn't recognized. Its not recognized in BIOS, Windows nor OS X. Simply discharging the motherboard (pressing power button while computer has no power) fixes it immediately. I don't blame this on SSDT or anything Hackintosh related, this is an ASRock/hardware issue, I believe.
 
Joined
Oct 23, 2010
Messages
21
Motherboard
ASRock Z390 Phantom-Gaming ITX
CPU
i7-9700K
Graphics
RX 570
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. iMac
  2. Performa
  3. Power Mac
  4. PowerBook
Mobile Phone
  1. iOS
@mango1122 The only hiccup I ever have is when I boot from cold, sometimes the TB3 port (and therefore dock) isn't recognized. Its not recognized in BIOS, Windows nor OS X. Simply discharging the motherboard (pressing power button while computer has no power) fixes it immediately. I don't blame this on SSDT or anything Hackintosh related, this is an ASRock/hardware issue, I believe.

I don’t even know what DROM is :)
Candurin, would you be so nice and post your EFI Folder so I can compare yours to mine? Thank You.
 
Top