Contribute
Register

[Success] AMD RX6000 Series working in macOS

Gigamaxx

Moderator
Joined
May 15, 2016
Messages
6,570
Motherboard
GIGABYTE X470 Arous Gaming 7 WiFi
CPU
Ryzen R9 3900X
Graphics
RX 480
Mac
  1. iMac
So far no luck on my end on 11.4. My 6900XT is not recognized.
I switched off WEG and moved to MacPro7,1 but no dice.
Did you remove any SSDTs for the previous graphics card? Disable IGPU?
Device Properties section?
Is it all vanilla? No prior graphics settings or fixes? NVRam reset.
 
Joined
Mar 28, 2019
Messages
131
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980XE
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Did you remove any SSDTs for the previous graphics card? Disable IGPU?
Device Properties section?
Is it all vanilla? No prior graphics settings or fixes? NVRam reset.
Yeah, I'm only running minimal SSDT's, no GPU-related ones.
No Device Properties for that part either and my CPU does not have an iGPU.
NVRAM reset was also done, but unfortunately did not help.
I'll try and experiment some more, maybe I'll happen across something else eventually.
 
Joined
Jan 17, 2020
Messages
41
Motherboard
Aorus Pro Wifi i x570
CPU
3950x
Graphics
6900xt
Yeah, I'm only running minimal SSDT's, no GPU-related ones.
No Device Properties for that part either and my CPU does not have an iGPU.
NVRAM reset was also done, but unfortunately did not help.
I'll try and experiment some more, maybe I'll happen across something else eventually.
I see you were running a RX580, have you added boot flag agdpmod=pikera you will need that now I think.
 
Joined
Jan 28, 2012
Messages
65
Motherboard
Asus Rampage VI Extreme Omega
CPU
Core i9 10980XE
Graphics
Radeon 6800 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
@Andy1983 Yes, it's set to normal. I even tried to set it to a value below 1 in the corresponding .plist file, but 1 is the lowest value possible.
 
Joined
Mar 28, 2019
Messages
131
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980XE
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
I see you were running a RX580, have you added boot flag agdpmod=pikera you will need that now I think.
I've tried booting with WEG (with and without the agdpmod argument) and completely without WEG, but none of these combinations led to success. I can see it has the correct device ID in system info, but for some reason it's not actually detected as a 6900XT.
 
Joined
Mar 6, 2021
Messages
3
Motherboard
Gigabyte Aorus Z390 Pro
CPU
Intel Core i9 9900KF
Graphics
Radeon RX580
I've tried booting with WEG (with and without the agdpmod argument) and completely without WEG, but none of these combinations led to success. I can see it has the correct device ID in system info, but for some reason it's not actually detected as a 6900XT.

Reference AMD card?
 
Joined
Mar 31, 2021
Messages
8
Motherboard
MSI X470 Gaming Plus Max
CPU
AMD 3900X
Graphics
AMD RX 560 2GB / RX 6800
Is there an way to disable SAM for macOS (which wont work?) but keep it enabled for Windows?
I'm also having issue with Resizeable bar. MacOs cannot boot when it's enabled.
It's a pain to toggle when I want to boot Windows to play some games.
I hope it can get fixed.
 
Joined
Mar 20, 2021
Messages
17
Motherboard
GIGABYTE Z490 VISION D
CPU
i9-10900K
Graphics
RX 6900 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Updated to 11.4.1 beta yesterday, installed a new card today. Everything is working fine (including my Sound Blaster Audigy RX which is using a custom kext) except 1. USB 3.0 ports on the front panel 2. Bluetooth dongle (it may be not supported by Big Sur, will try to change it via https://www.tp-link.com/in/home-networking/adapter/ub400/

P.S. I have outdated CPU & MB which have PCI-E 3.0 slots only so my benchmarks may not be so good ;)
 

Attachments

  • About This Mac.png
    About This Mac.png
    143 KB · Views: 129
  • Blackmagic RAW Speed Test.png
    Blackmagic RAW Speed Test.png
    616.2 KB · Views: 130
  • FurMark.png
    FurMark.png
    39.7 KB · Views: 129
Joined
Oct 24, 2013
Messages
1,091
Motherboard
Asus ROG Z690 Formula
CPU
i7-12700K
Graphics
RX 6900 XT
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
Mobile Phone
  1. iOS
I wonder if the usb-c port on the 6000 series needs port mapping and proper power properties similar to how we have to do it for the onboard USB ports?
 
Joined
Mar 6, 2013
Messages
271
Motherboard
Gigabyte X299X Designare 10G
CPU
i9-10980XE
Graphics
AMD 6900XT
Mobile Phone
  1. Android
I wonder if the usb-c port on the 6000 series needs port mapping and proper power properties similar to how we have to do it for the onboard USB ports?
It looks like the new drivers disable the USB ports. It shows up with an AppleAMDUSBXHCIPCI entry, but with no ports:
1619213521090.png


And whereas in earlier Big Sur versions you could plug in a USB stick or other device into the USB-C port and it'd work, and sleep was broken even with the GPU disabled unless the controller was disabled, neither is true now.
 
Top