Contribute
Register

[Success] Alienware Aurora R6 with 10.12.6

Joined
Jan 4, 2011
Messages
384
Motherboard
Dell Alienware Aurora R7
CPU
i7-8700k
Graphics
AMD Radeon RX Vega64
Mac
Mac mini
Mobile Phone
Android, iOS
I just purchased an Aurora R7 and I am trying to get High Sierra on the spare 512GB SSD I had from my last build.

I was able to figure out how to disable secure boot finally. I disabled VT-D in BIOS. But rest of BIOS it weird and limited on functions. I see some have got it working or partially working.

Could anyone share their BIOS settings they used?
 
Joined
Aug 13, 2017
Messages
123
Motherboard
Dell Inspiron 7559
CPU
i7-6700HQ
Graphics
HD 530 (3840 x 2160)
Mobile Phone
iOS
Yeah, the Bios settings on the Alienware seems to be really limited. That's the world of vendor made computers, I guess.

How were you able to get the Nvidia drivers working?

One interesting thing was that the default ethernet driver worked, but after following the installation instructions on Multibeast and selecting the 2.2.0 Intel driver, I could not get the ethernet to work.
I was reading through all these posts again today, and wondered if you'd figured out your ethernet issue? Is everything working on yours now?

I just did another Sierra install on an R6 (10.12.6), and wanted to get the Intel 630 video working with acceleration.

Anyone know how to get the 630 working on this Aurora R6 (or if it's possible)? The BIOS has very few options, and none that adjust that video memory setting.
 
Last edited:
Joined
Jul 14, 2018
Messages
7
Motherboard
MSI MPG Z390I GAMING EDGE AC Mini-ITX
CPU
i7-8770K
Graphics
GTX 1080Ti
Mac
MacBook Pro
Mobile Phone
iOS
I also have a recent R7, and can't get past the black screen with the white apple logo. How did you manage to actually install the OS?

I tried my best to modify the UEFI settings as close to the installation guide as I could. But some of the options it asks you to change were not present. Perhaps they're named differently in the Alienware world.

Any guidance you can provide would be great.
Am currently stuck on the Apple logo. Could you please tell me how to get past it?

Been trying for a few nights now :(
 
Joined
Jul 14, 2018
Messages
7
Motherboard
MSI MPG Z390I GAMING EDGE AC Mini-ITX
CPU
i7-8770K
Graphics
GTX 1080Ti
Mac
MacBook Pro
Mobile Phone
iOS
Attached is the config.plist. I also added a bit more info to my original post.
Attached is the config.plist. I also added a bit more info to my original post.
I am constantly stuck at the Apple logo screen.

I've tried using your config.plist file in attempt to solve that but the issue still persists.

I have an Aurora R6, and the BIOS settings are quite limited. How did you get your installation to work?

Will very much appreciate any help on this.

Thank you :)
 
Joined
Feb 1, 2016
Messages
5
Motherboard
?
CPU
Intel i7
Graphics
Intel HD
Mac
Classic Mac
Mobile Phone
Hey man can you maybe share your EFI Folder? would be nice because I have also a Aurora R6 with i7 7700k and gtx1080
 
Joined
Jul 17, 2017
Messages
21
Motherboard
Alienware / Intel Z270
CPU
Intel i7-7700K
Graphics
GeForce GTX 1080, HD630, 1440p
Mac
MacBook Air, MacBook Pro, Mac mini
Mobile Phone
Android, iOS
Here's my EFI on 10.13.6. I've Nvidia web drivers installed.

Working: Everything (including Intel 630 video acceleration)
Untested: Audio (I've a USB soundbar which works OOB)
 

Attachments

Joined
Oct 14, 2018
Messages
1
Motherboard
Dell Aurora R7
CPU
i7-8700
Graphics
GTX 1080
Mac
MacBook Pro
Mobile Phone
Android
Hello Guys,

I'm new here but just wanted to share that I successfully installed High Sierra 10.13.6 included Security update 2019 on my Dell Aurora R7, I7 8700, GTX1080. This is thanks to all the post and feedback in this forum.

HS is installed on a separate M4 SSD and dual boot working fine with Windows. I just had to struggle with the RAID ON to AHCI bios settings and Windows HDD driver...led to a clean reinstall of Windows :)

Everything working except Wifi (Killer not supported).


I'm not an expert but would be happy to help if someone is having issues with the same config !

Thanks,
 
Joined
Apr 17, 2019
Messages
129
Motherboard
Q77 Board
CPU
I7 3770
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
Android
I own a R5 would this be the same setup or different? I have the i7 6700 with a gt 1080 founders edition thanks in advance.
 
Top