Contribute
Register

[SUCCESS] Alienware Alpha R1 60 second guide

Joined
May 22, 2018
Messages
1
Motherboard
Alienware alpha
CPU
I5 Delided
Graphics
2.0
I have an Alienware Steam I purchased NEW from GameStop for $379 (heck of a deal for an i7 Quad Core) in December 2016. I tried the Hackintosh at first it didn't work but, I tried the El Capitan install. After that, I loaded the Sierra OS version 10.12.4, it worked/installed flawless. The only thing is that when I have my external USB plugged in it seems to lock up sometimes but if I leave it out it's rock solid. I have the i7 Alienware Steam Machine. I had to send it into Dell/Alienware for the "Yellow Flash of Death" and Dell/Alienware replaced the mainboard and it's been fine ever since. I also had about 2 months left on the warranty and told Dell/Alienware that it was purchased before Christmas and I should have at least 1 year of support. I faxed the copy of my receipt and they added the 1 year warranty giving me support until 12/2017. My version of Sierra is running on an external 64GB SSD I purchased from MicroCenter years ago. Its their rebranded Sandisk SSD G2 Series Solid State Drive With SandForce 1222 Controller. I F12 in UEFI mode and select the 64GB SSD, Clover loads and boot right into my Hackintosh. There was an issue with a game I have on Steam, "The Witness" does not play, the graphics seems to not be working but that might be an issue with the game since they just released it for OSX April 3rd?? I am thinking of making a YouTube video showing my steps to get it Sierra installed but that is yet to be determined? My bluetooth headphones, mouse and Steam controller work without mods so I use my Beats bluetooth headphones for audio because I have mine connected to a 25" HP monitor not TV. I was thinking of getting a Logitech 980-000910 Bluetooth Audio Adapter for Bluetooth Streaming or an Avantree aptX LOW LATENCY Bluetooth Transmitter and Receiver 2-in-1 for my studio monitors to use Logic Pro X for music production. I only wish that they had made this unit able to support multiple drives or had enough space to install dual hard drives...let the mods begin! Thanks tonymacx86, you guys rock!! Also thanks to the guys that are the testers and posters with information helping others set their systems up.
I think you got scammed if you had to pay them extra.. as the death light is just a bios battery issue..
 
Last edited by a moderator:
Joined
Mar 3, 2019
Messages
3
Motherboard
Alienware Alpha R1
CPU
i3
Graphics
GeForce 860m
Mobile Phone
Android
Success! So I thought I'd give back the community with a quick guide.

I picked up a used Alienware Alpha R1 for peanuts on eBay. It's the i3 model and had 16GB RAM.

First things first
  • Check it boots OK with Windows.
  • Check BIOS version and Update to latest - this was already on A05.
Setup BIOS
  • Reboot - get into BIOS with F12
  • Restore to defaults.
  • Set VT to disabled. Go to Advanced -> Processor Config -> Intel Virtualization Technology [Disabled]
  • Save and exit.
Boot and Install
  • Followed instructions with UniBeast for Sierra.
  • Worked like a charm and as described. Zero issues. No flags or other alterations to Unibeast. Just total stock UEFI boot.
  • In testing I tried an external USB, that crashed during OS X install. So use the internal drive.
Post Install
Ethernet worked before I ran Cover Configurator, so DL'ed MulitiBeast direct to box.

And we are done. That's it.

No Wifi or BT working. But I'm not bothered.

And it's fast. Feels way faster than my old 2011 MacBook Pro 13" i7. Even though Geek bench scores are not that different, it feels much snappier. Certainly the GPU makes a big difference. If i dropped an i7 in the Alpha it would be destroying the old MBP.

I don't think I'll ever buy actual Apple hardware again!

Hi I know it's been 2 years but I'm trying this and if hangs on apple logo almost loading the installer but there is a pinwheel in the corner . I'm using a searra thumb drive made with unibeast and searra from the app store. It keeps hanging. Should I use no flags don't select a eufi or legacy just boot vanilla?
 

Top