Contribute
Register

[Success] Affordable Mac mini 2018 - Asus Prime H370-Plus + i3-8100 +16GB RAM + UHD 630 | Mojave 10.14.2

Status
Not open for further replies.
Joined
Apr 10, 2017
Messages
17
Motherboard
Asus Prime H370M-PLUS
CPU
i5-8400
Graphics
HD 630
Mobile Phone
  1. Android
Sorry for late reply. You always release version unless you are debugging use debug version.

Hey friend, I need you a lot, I was able to install the Mojave all right but except for the audio and graphics. I followed your steps with the graphics that I should use the framebuffer but it does not work for me when restarting, it remains in blackscreen, I do not know why I was using vga but then I used the vga-hdmi adapter, it did not work either. Well, I don't know what to do, help me out. I only need the audio and the graphics, and with that I would be happy.
I hope you can help me.
By the way have you tried updating to Catalina now? Because now I am using High Sierra now because I have gtx 1050ti there it takes the graphics with nvidia driver well. But with Mojave no, now I plan to update Catalina in case it works with the framebuffer, but I had problems, marks the prohibited icon
 
Joined
Dec 25, 2015
Messages
309
Motherboard
Gigabyte Z690 UD AX
CPU
i5-12400F
Graphics
Readon RX 6600
Mobile Phone
  1. Android
Hey friend, I need you a lot, I was able to install the Mojave all right but except for the audio and graphics. I followed your steps with the graphics that I should use the framebuffer but it does not work for me when restarting, it remains in blackscreen, I do not know why I was using vga but then I used the vga-hdmi adapter, it did not work either. Well, I don't know what to do, help me out. I only need the audio and the graphics, and with that I would be happy.
I hope you can help me.
By the way have you tried updating to Catalina now? Because now I am using High Sierra now because I have gtx 1050ti there it takes the graphics with nvidia driver well. But with Mojave no, now I plan to update Catalina in case it works with the framebuffer, but I had problems, marks the prohibited icon

First of all, have you detached you Nvidia 1050ti graphics card from your motherboard while try to boot Mojave?
Second, share your config.plst file here, I will try to help.
 
Joined
Apr 10, 2017
Messages
17
Motherboard
Asus Prime H370M-PLUS
CPU
i5-8400
Graphics
HD 630
Mobile Phone
  1. Android
Ok perfect so far I have already been able to install the nvidia webdriver in Mojave I already have results even in About Mac, it shows me that I have the gtx 1050ti 4GB, but when using, the acceleration is not going well, well I understand that from mojave not much driver compatibility. Okay that's what I did what I could achieve.


Leaving aside what I said.
Now what the question asked me, yes, it was separate, I took out the card and if Mojave starts. Currently I have connected, it also takes me but with 7 MB sometimes 5 MB

There I go, I'll share my plist or the EFI folder, I am use config_h370m_plus_for_me.plist. Yours if it boots but without mouse and keyboard. The goal is to have Mojave with Intel HD 630 not Nvidia, I hope your help and success on my pc
 

Attachments

  • Screen Shot 2020-06-02 at 4.54.24 PM.png
    Screen Shot 2020-06-02 at 4.54.24 PM.png
    72.2 KB · Views: 47
  • Screen Shot 2020-06-10 at 2.47.07 PM.png
    Screen Shot 2020-06-10 at 2.47.07 PM.png
    77.9 KB · Views: 42
  • EFI-HELP.zip
    18.1 MB · Views: 44
Joined
Dec 25, 2015
Messages
309
Motherboard
Gigabyte Z690 UD AX
CPU
i5-12400F
Graphics
Readon RX 6600
Mobile Phone
  1. Android
@LennonBoxo98
Navigate to Graphics section using Clover Configurator and tick "Inject Intel" option and put 0x3E9B0007 in ig-platform-id. Let me know the result.
Note this only for iGPU and hoping your GTX 1050 Ti is detached from motherboard.

8400-igpu-test1.png
 
Last edited:
Joined
Apr 10, 2017
Messages
17
Motherboard
Asus Prime H370M-PLUS
CPU
i5-8400
Graphics
HD 630
Mobile Phone
  1. Android
I can't handle those settings either, it's worth trying the open core
Will you help me configure the new config with the OC?
 
Joined
Dec 25, 2015
Messages
309
Motherboard
Gigabyte Z690 UD AX
CPU
i5-12400F
Graphics
Readon RX 6600
Mobile Phone
  1. Android
I haven't tried opencore yet so I'm not sure I can help. But whatever bootloader you try its about setting correct ig-platform-id for your CPU. I can send you with edited plist if you want for clover.
 
Joined
Apr 10, 2017
Messages
17
Motherboard
Asus Prime H370M-PLUS
CPU
i5-8400
Graphics
HD 630
Mobile Phone
  1. Android
Yes please, already 3 weeks trying to fix the graphics :(.
Thanks
 
Joined
Dec 25, 2015
Messages
309
Motherboard
Gigabyte Z690 UD AX
CPU
i5-12400F
Graphics
Readon RX 6600
Mobile Phone
  1. Android
First of all, Why are you using VirtualSMC.kext and FakeSMC.kext together in EFI/CLOVER/kexts/Others. Either you one of these. If you use VirtualSMC.kext then remove FakeSMC.kext & its other plugins and If you use FakeSMC then remove VirtualSMC.

Please take a backup from that folder then delete and use all the kexts I have a uploaded on that folder. I have updated other kext file also.

Then boot with config_try1.plist, config_try2.plist, config_try3.plist one by one.
 

Attachments

  • EFI-UPDATED.zip
    19.2 MB · Views: 44
Joined
Apr 10, 2017
Messages
17
Motherboard
Asus Prime H370M-PLUS
CPU
i5-8400
Graphics
HD 630
Mobile Phone
  1. Android
Thanks for your time it hurts that it did not work for me, I migrated to OpenCore and it works perfectly it works all restarted off sleep etc and I was even able to update to Big Sur. All good
 
Status
Not open for further replies.
Top