Contribute
Register

[Success] 8700K, Gigabyte Z370-HD3P, UHD Graphics 630, macOS High Sierra, Mojave

Joined
Nov 9, 2014
Messages
3
Motherboard
Gigabyte Z370XP SLI
CPU
i7 8700k
Graphics
Powercolor Red Devil RX580 8gb
Mac
iMac
Hi,

I am setting up an identical system with Gigabyte z370xp SLI. Currently it worked (sound, network, wifi-bluetooth...) But still I got some ACPI errors during startup

Code:
2018-07-05 05:03:52.224653+0700 0x82       Default     0x0                  0      0    kernel: Started cpu 2 (lapic id 00000002)
2018-07-05 05:03:52.225325+0700 0x83       Default     0x0                  0      0    kernel: Started cpu 4 (lapic id 00000004)
2018-07-05 05:03:52.226003+0700 0x84       Default     0x0                  0      0    kernel: Started cpu 6 (lapic id 00000006)
2018-07-05 05:03:52.226684+0700 0x85       Default     0x0                  0      0    kernel: Started cpu 8 (lapic id 00000008)
2018-07-05 05:03:52.227358+0700 0x86       Default     0x0                  0      0    kernel: Started cpu 10 (lapic id 0000000a)
2018-07-05 05:03:52.228025+0700 0x87       Default     0x0                  0      0    kernel: Started cpu 1 (lapic id 00000001)
2018-07-05 05:03:52.228692+0700 0x88       Default     0x0                  0      0    kernel: Started cpu 3 (lapic id 00000003)
2018-07-05 05:03:52.229534+0700 0x89       Default     0x0                  0      0    kernel: Started cpu 5 (lapic id 00000005)
2018-07-05 05:03:52.230208+0700 0x8a       Default     0x0                  0      0    kernel: Started cpu 7 (lapic id 00000007)
2018-07-05 05:03:52.230877+0700 0x8b       Default     0x0                  0      0    kernel: Started cpu 9 (lapic id 00000009)
2018-07-05 05:03:52.231549+0700 0x8c       Default     0x0                  0      0    kernel: Started cpu 11 (lapic id 0000000b)
2018-07-05 05:03:52.232166+0700 0xb6       Default     0x0                  0      0    kernel: (AppleAPIC) IOAPIC: Version 0x20 Vectors 64:111
2018-07-05 05:03:52.235305+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.235306+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.235557+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [_SB_.PCI0.RP05.PXSX]
2018-07-05 05:03:52.235558+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [_SB_.PCI0.RP05.PXSX]
2018-07-05 05:03:52.235996+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  Namespace lookup failure, AE_NOT_FOUND
2018-07-05 05:03:52.235997+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  Namespace lookup failure, AE_NOT_FOUND
2018-07-05 05:03:52.236810+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/dswload2-274)
2018-07-05 05:03:52.236810+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/dswload2-274)
2018-07-05 05:03:52.237339+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.237339+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.237368+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Local Variables are initialized for method [PXSX]
2018-07-05 05:03:52.237369+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Local Variables are initialized for method [PXSX]
2018-07-05 05:03:52.238480+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.238480+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.238509+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Arguments are initialized for method [PXSX]
2018-07-05 05:03:52.238509+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Arguments are initialized for method [PXSX]
2018-07-05 05:03:52.239495+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.239496+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.239524+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Exception: AE_NOT_FOUND,
2018-07-05 05:03:52.239525+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Exception: AE_NOT_FOUND,
2018-07-05 05:03:52.240150+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) During name lookup/catalog
2018-07-05 05:03:52.240150+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) During name lookup/catalog
2018-07-05 05:03:52.240692+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psobject-310)
2018-07-05 05:03:52.240693+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psobject-310)
2018-07-05 05:03:52.241222+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.241222+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.241473+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) Method parse/execution failed
2018-07-05 05:03:52.241473+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) Method parse/execution failed
2018-07-05 05:03:52.242099+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [\_SB.PCI0.RP04.PXSX] (Node ffffff804db26300)
2018-07-05 05:03:52.242100+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [\_SB.PCI0.RP04.PXSX] (Node ffffff804db26300)
2018-07-05 05:03:52.243039+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) , AE_NOT_FOUND
2018-07-05 05:03:52.243040+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) , AE_NOT_FOUND
2018-07-05 05:03:52.243333+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psparse-632)
2018-07-05 05:03:52.243333+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psparse-632)
2018-07-05 05:03:52.244341+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.244342+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.244593+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [_SB_.PCI0.RP09.PXSX]
2018-07-05 05:03:52.244594+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [_SB_.PCI0.RP09.PXSX]
2018-07-05 05:03:52.245032+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  Namespace lookup failure, AE_NOT_FOUND
2018-07-05 05:03:52.245032+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  Namespace lookup failure, AE_NOT_FOUND
2018-07-05 05:03:52.245845+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/dswload2-274)
2018-07-05 05:03:52.245846+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/dswload2-274)
2018-07-05 05:03:52.246374+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.246375+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.246403+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Local Variables are initialized for method [PXSX]
2018-07-05 05:03:52.246404+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Local Variables are initialized for method [PXSX]
2018-07-05 05:03:52.247515+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.247515+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.247544+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Arguments are initialized for method [PXSX]
2018-07-05 05:03:52.247544+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) No Arguments are initialized for method [PXSX]
2018-07-05 05:03:52.248530+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.248530+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)
2018-07-05 05:03:52.248559+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Exception: AE_NOT_FOUND,
2018-07-05 05:03:52.248560+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Exception: AE_NOT_FOUND,
2018-07-05 05:03:52.249185+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) During name lookup/catalog
2018-07-05 05:03:52.249185+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) During name lookup/catalog
2018-07-05 05:03:52.249727+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psobject-310)
2018-07-05 05:03:52.249728+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psobject-310)
2018-07-05 05:03:52.250256+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.250256+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI Error:
2018-07-05 05:03:52.250507+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) Method parse/execution failed
2018-07-05 05:03:52.250508+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) Method parse/execution failed
2018-07-05 05:03:52.251134+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [\_SB.PCI0.RP08.PXSX] (Node ffffff804db28b70)
2018-07-05 05:03:52.251134+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) [\_SB.PCI0.RP08.PXSX] (Node ffffff804db28b70)
2018-07-05 05:03:52.252071+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) , AE_NOT_FOUND
2018-07-05 05:03:52.252072+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) , AE_NOT_FOUND
2018-07-05 05:03:52.252364+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psparse-632)
2018-07-05 05:03:52.252365+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform)  (20160930/psparse-632)
2018-07-05 05:03:52.255163+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI:
2018-07-05 05:03:52.255163+0700 0x71       Default     0x0                  0      0    kernel: (AppleACPIPlatform) ACPI:
I just wonder if "Optional Patching DSDT And SSDTs" part can help to fix my above issues?

Thanks for reading, thanks a lot for replying :thumbup:
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,314
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
Joined
Jun 10, 2011
Messages
313
Motherboard
Gigabyte Z370 Aorus Ultra Gaming 2.0
CPU
i7 8700K
Graphics
Sapphire Pulse RX580 8Gb
Mac
MacBook Pro
Mobile Phone
iOS

aol

Joined
Apr 14, 2011
Messages
512
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX 570 + GTX 1060
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I have this build working on the UHD 630. My issue is I added in a nVidia 1060 6GB and while the system shows that it's using the nVidia drivers, the drivers don't load and the ATM shows "nvidia chip model 7MB", which is a fairly common problem but I can't figure it out. I don't think it's the nvram issue, I'm using the latest clover with aptiomemoryfix (no emuvariables) and as I said, the Sys Prefs show the radio button checked next to nvidia web driver, so it seems to be remembering the setting, the system just isn't loading the drivers.

A little background. This is a HS 10.13.6 system that was on a Z170 board (v4 in my sig) and I basically just rebuilt to v5 in my sig with this hd3p board, stuck the same drives on it, rebuilt clover in the EFI, and here I am. So, this was a vanilla HS 10.13.6 system using a clover built for the z170 board, but I've rebuilt clover in the EFI for this board, starting with unibeast, then selectively adding in stuff from the old config.plist. Reran the audio drivers, toleda's ALC audio script. Everything is working except the nvidia drivers don't load cleanly.

BIOS has pcie/nvidia graphics primary (igpu enabled), otherwise basically followed this guide. nvidia web is true. Reinstalled the web drivers. I'm not injecting any graphics, no ig-platformid. iMac 17,1 SMBIOS with lilu/shiki/nvidiagraphicsfixup/intelgraphicsfixup, coredisplayfixup, codeccommander, intelmausiethernet kexts. I do have the rename gfx0/igpu, pegp/gfx and HECI/IMEI acpi patches. Other than that, mostly the base config from unibeast plus a few settings I believed I needed from the old system, and reran audio script. In my experience, audio and graphics can sort of work together/fail together. No acpi/patched yet, still trying to get base system running on the nvidia drivers.

Thanks for reading, I can attach config and screenshot of kexts/drivers64efi if desired. I'll keep researching. Other than that, pretty fast system to get up and running.
 

aol

Joined
Apr 14, 2011
Messages
512
Motherboard
GA-Z370-HD3P
CPU
i7-8700K
Graphics
RX 570 + GTX 1060
Mac
MacBook Pro, Mac Pro
Mobile Phone
iOS
I have this build working on the UHD 630. My issue is I added in a nVidia 1060 6GB and while the system shows that it's using the nVidia drivers, the drivers don't load and the ATM shows "nvidia chip model 7MB", which is a fairly common problem but I can't figure it out.
Resolved.

Dopey me. I have no idea why it took so long for me to realize I had a rogue "nv_disable=1" in my boot args, a hold-over from the default config that unibeast created. Fixed. On this board you need to NOT have "nv_disable=1", you need Nvidia Web true, and you need the web drivers installed. You don't need emulated vram with latest clover, and I'm using aptiomemoryfix. I do have lilu/shiki/nvidiagraphicsfixup/intelgraphicsfixup, coredisplayfixup, mainly to support my iMac17,1 SMBIOS dual screen and as a start at getting hardware video encoding using the UHD 630, a problem for another day.
 
Joined
Jun 6, 2017
Messages
18
Motherboard
Z370 HD3 P
CPU
i7 8700
Graphics
1060 3Go
...

As of now I'm running BIOS version F3. Using BIOS versions F5 and up (latest as of now is F7) the system does not boot; that is, after selecting High Sierra in Clover boot manager the system just reboots w/o notice.

It seems some of you run newer BIOS versions - anyone any idea what may cause the observed behaviour?
Hi @Loki.Mephisto did you find a way to boot with recent bios updates like F6 ?

I can't boot in mac OS after F4 bios
 
Joined
Apr 6, 2018
Messages
11
Motherboard
Gigabyte Z370
CPU
i7-8700
Graphics
GeForce 1050 Ti
Classic Mac
iBook, Power Mac
Nope - still at F4.

No big deal for now since everything works; albeit a bit annoying/puzzling
 
Top