Contribute
Register

[Success] 8700K, Gigabyte Z370-HD3P, UHD Graphics 630, macOS High Sierra, Mojave

Joined
Sep 18, 2013
Messages
46
Motherboard
Motherboard Gigabyte GA-Z87X-OC
CPU
i7-4770
Graphics
GTX 970 + HD 4600
Mac
MacBook Air, Mac Pro
Mobile Phone
Android
I have attached EFI.zip and refs.txt for reference.
Hi, do you think your EFI files will work also for the GA-Z370-HD3 (of course changing the audio to the ALC892)?
Thx
 
Joined
Jan 21, 2016
Messages
40
Motherboard
Z390 Aorus Ultra
CPU
i9-9900K
Graphics
Vega 56
@cam01 don't copy EFI files, follow the steps for installation I think it will work.
 
Joined
Jul 26, 2013
Messages
5
Motherboard
Z370 HD3P
CPU
i7-8700k
Graphics
Intel 630
Mac
iMac, MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android
Hi and thanks for the step by step guide.
I have a perfectly identical configuation:
z370 hd3p but my Bios is F6
i7-8700K
M.2 960 EVO 250GB
2x Crucial Ballistix Sport LT (8GB)

When I want Patching DSDT And SSDTs I have 2 problems:

1) After running:

cd /Users/Your account name/Desktop/origin
iasl -da -dl -fe refs.txt *.aml

I can not find any DSDT.dsl file but only DSDT.aml
In the same way for the other files I find only *.aml files.

2) The files are not named the same way as the guide and I do not know how to operate.
DSDT.aml
SSDT-0-SataTabl.aml
SSDT-1-GSWApp.aml
SSDT-2-SaSsdt.aml
SSDT-3-Ther_Rvp.aml
SSDT-4-xh_rvp10.aml
SSDT-5-CpuSsdt.aml
SSDT-6-HdaDsp.aml
SSDT-6-TbtTypeC.aml
SSDT-7-sensrhub.aml
SSDT-8-PtidDevc.aml
SSDT-9-TbtTypeC.aml
SSDT-x5_0-Cpu0Ist.aml
SSDT-x5_1-ApIst.aml
SSDT-x5_2-Cpu0Cst.aml
SSDT-x5_3-ApCst.aml
SSDT-x5_4-Cpu0Hwp.aml
SSDT-x5_5-ApHwp.aml
SSDT-x5_6-HwpLvt.aml​
I ask for help not to make mistakes.

I thank those who will help me and I attach the original folder extracted from the EFI partition.
 

Attachments

Joined
Jan 13, 2012
Messages
3
Motherboard
Gigabyte Z370-HD3P
CPU
8700K
Graphics
GeForce GTX 670
Hi!
I can't go through the "Generate SSDT" step, because "-bash: syntax error"
What could it be?
 

Attachments

Joined
Jan 21, 2016
Messages
40
Motherboard
Z390 Aorus Ultra
CPU
i9-9900K
Graphics
Vega 56
@alwi Don't copy '(An i7-8700k @ stock speeds)'

Try below command
Code:
sudo sh ssdtPRGen.sh -p 'i7-8700k'
 
Joined
Jan 21, 2016
Messages
40
Motherboard
Z390 Aorus Ultra
CPU
i9-9900K
Graphics
Vega 56
@rainbowflare

There is a problem in SSDT-6-TbtTypeC.aml, other knowledgeable people can help you.

You can try disassembling without that file, use below commands to do so:

Code:
mv BK-SSDT-6-TbtTypeC.aml
iasl -da -dl DSDT.aml SSDT*.aml
 
Joined
Jul 26, 2013
Messages
5
Motherboard
Z370 HD3P
CPU
i7-8700k
Graphics
Intel 630
Mac
iMac, MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android
@rainbowflare

There is a problem in SSDT-6-TbtTypeC.aml, other knowledgeable people can help you.

You can try disassembling without that file, use below commands to do so:

Code:
mv BK-SSDT-6-TbtTypeC.aml
iasl -da -dl DSDT.aml SSDT*.aml
I have re-extracted for the second time DSDT and SSDT files and SSDT-6-TbtTypeC.aml is no longer present.
I've done:

Code:
 iasl -by -dl -fe refs.txt * .aml
without errors.

I have applied all the paches and followed the guide and I have not received any errors.

Obviously, in Acpi> SortedOrder I entered the file names
DSDT.aml
SSDT.aml
SSDT-0-SataTabl.aml
SSDT-1-GSWApp.aml
SSDT-2-SaSsdt.aml
SSDT-3-Ther_Rvp.aml
SSDT-4-xh_rvp10.aml
SSDT-5-CpuSsdt.aml
SSDT-6-HdaDsp.aml
SSDT-7-sensrhub.aml
SSDT-8-PtidDevc.aml
SSDT-9-TbtTypeC.aml

but when I restart the PC it does not restart. I inserted the USB key to go back to OS X.
For the F6 BIOS it does not work.

Thanks anyway for the interest.
 
Joined
Jan 21, 2016
Messages
40
Motherboard
Z390 Aorus Ultra
CPU
i9-9900K
Graphics
Vega 56
@rainbowflare make sure you have followed the steps for installation, take backup patched directory and delete directory files and check if it works.
 
Joined
Feb 22, 2011
Messages
1
Motherboard
Gigabyte Z370 HD3P R
CPU
Core i5 8400
Graphics
ATI
Mac
MacBook Air
I got the same SSDT's as @rainbowflare . Also, when I tried to enable the DSDT/SSDT patching thats the point where my machine stopped booting.

I'd already built my installer disk from another person's build instructions and everything seems to work but I had the following issues:
  • DVI pretty much doesn't work if it is plugged in on boot.
  • VGA works, but not at native resolution. I have to scale it down. When attempting to run at native resolution the screen image runs well past the left and bottom edges of the monitor.
When the DSDT/SSDT broke boot-up I ran it in -v to see what was up. Attached is an image of the last line before boot quit.

I attempted to first remove the SSDT-* files, then SSDT.aml and got the same last message every time. The message above however I think was different after the last run.

Thanks for all the help so far guys!
 

Attachments

Top