Contribute
Register

[SUCCESS] 5ghz i7-8700k - Gigabyte Z370XP SLI - GTX 1070 BLACK EDITION - High Sierra - Thunderbolt

Status
Not open for further replies.
Joined
Mar 11, 2018
Messages
1
Motherboard
z740
CPU
intel i7 8700
Graphics
nvidia 1070ti
Hi, what steps/thread did you use to get your Nvidia graphic card working? I'm using a very similar hardware configuration and failing with the nvidia web installer.

Thanks.
 
Joined
Jul 6, 2017
Messages
8
Motherboard
Dell Inspiron 7577 15 Gaming
CPU
Core i7 7700HQ
Graphics
HD Intel Graphics 630
Hi there,
This is very attractive for my 1st build. Is there anything more to be aware of re the build?
Will most processor cooling units work?
Thanks, looks like a smashing build. Hopefully will work with ProTools Avid Thunderbolt 2 interface/and or UAD
 
Joined
Sep 16, 2017
Messages
4
Motherboard
GIGABYTE Z370XP SLI
CPU
i7 8700K
Graphics
MSI 980ti
Mac
  1. iMac
Could you share your EFI folder?
 
Joined
Sep 16, 2017
Messages
4
Motherboard
GIGABYTE Z370XP SLI
CPU
i7 8700K
Graphics
MSI 980ti
Mac
  1. iMac
I have the same MB and CPU, but with RX580, different RAM and Kraken X62.

For the first problem just edit the "UnknownCPUKind" entry in the AppleSystemInfo.strings file. It's located at /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/ (select then the folder related to your system language, Italian.lproj in my case). I wanted to keep original naming, so this is my edit:
Code:
UnknownCPUKind = "Intel Core i7";
Coffee Lake are natively supported but they're not listed. When macOS will be updated with official support for Coffee Lake CPUs this edit won't be necessary.

In order to display the correct frequency you must make a custom SSDT for the CPU Power Management. Now it displays the stock one.

Could you guide me how to create EFI folder.!
sorry. i read many thread but i cant understand clearly that how to config configlist.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,521
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Could you guide me how to create EFI folder.!
sorry. i read many thread but i cant understand clearly that how to config configlist.
As per rules, please update your hardware profile to allow others to help you easier
https://www.tonymacx86.com/account/

EFI folder gets created while formatting the drive (although it is hidden, you will need EFI mounter to mount the partition to be able to see it)
 

Stork

Admin
Staff member
Joined
Sep 21, 2010
Messages
13,208
Motherboard
Gigabyte Z690 Aero G
CPU
i5-12600K
Graphics
RX 6800 XT
Mac
  1. MacBook Pro
  2. Mac mini
  3. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
Could you guide me how to create EFI folder.!
sorry. i read many thread but i cant understand clearly that how to config configlist.

As per rules, please update your hardware profile to allow others to help you easier
https://www.tonymacx86.com/account/

EFI folder gets created while formatting the drive (although it is hidden, you will need EFI mounter to mount the partition to be able to see it)
The EFI partition gets populated when you install macOS and the run MultiBeast for your build configuration.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
28,521
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
The EFI partition gets populated when you install macOS and the run MultiBeast for your build configuration.
indeed :)
 
Joined
Jul 6, 2017
Messages
8
Motherboard
Dell Inspiron 7577 15 Gaming
CPU
Core i7 7700HQ
Graphics
HD Intel Graphics 630
Hi there
Why would you use the Alpine Ridge card when TB is supported on the MOBO?
Alpine Ridge card seems to be gold dust...
Thanks
 
Joined
Sep 16, 2017
Messages
4
Motherboard
GIGABYTE Z370XP SLI
CPU
i7 8700K
Graphics
MSI 980ti
Mac
  1. iMac
The EFI partition gets populated when you install macOS and the run MultiBeast for your build configuration.
hi, thanks you.
but i have a litle problem
I had boot to install MAC High Sirea. install successfull.

but if i use Mutil beast to post installation. it cant boot. ( attemping system restart..)
I tried use Clover EFI ==== > ( attemping system restart..)
I tried copy EFI folder from USB install to EFI Folder of drive ===>( attemping system restart..)

if after install finish. i dont add kext, dont edit EFI folder. I can boot from USB and it work.

please advise,
 
Joined
Oct 23, 2011
Messages
232
Motherboard
Asus ROG Strix Z390-I
CPU
i9-9900K OC 5GHz
Graphics
RX 5700 XT
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Be sure that you have installed latest BIOS on your motherboard and to have enabled "FixOwnership" on Clover. I use "Clover Configurator" app to edit my Clover confituration. You should boot in verbose mode in order to check what's wrong in your Clover configuration.

EFI partition is hidden until you mount it; you can do it by just going to "Mount EFI" in Clover Configurator and select "Mount partition" from the disk where you installed macOS. You can eject the external USB drive before mounting the EFI partition to avoid editing the wrong file.
Then select File> Open from the menu bar and open "config.plist" file on EFI/EFI/CLOVER/
Once you have edited what you need go to File> Save and try to boot.


You should also be sure that you have installed all kexts you need, especially FakeSMC. You also need to install USBInjectAll.kext and the kext to fix USB Injection on 100/200/300 series motherboard because macOS only support up to 25 USB ports while the Z370XP SLI has more than 25 USB ports. Then you must choose which USB ports you want to use, generate an SSDT for the USB and then remove the latest 2 kexts related to the USB mentioned above.
 
Last edited:
Status
Not open for further replies.
Top