Contribute
Register

[Success] 5770 + HD4000 experience

Status
Not open for further replies.
Joined
Aug 16, 2011
Messages
163
Motherboard
GA-Z77X-UD5H
CPU
Intel Core i5 3570k
Graphics
Gigabyte 7970
Mac
  1. MacBook Pro
Classic Mac
  1. iBook
  2. Power Mac
Mobile Phone
  1. iOS
Various things happened, and I upgraded to 10.8.3 and brought my second monitor up at about the same time.

Normally I edit my ATI5000Controller.kext to have my framebuffer layout in the Hoolock address, which I did as usual. However, something about 10.8.3 would cause my system to hang when booting.

Plus I wanted to use my second monitor, and I've had a longstanding problem getting multimonitor to work with my 5770 since I purchased a POS Korean 2560x1440 IPS monitor. Adding another monitor on DP causes both to be garbled, but I think the problem is mostly the Korean monitor. The electronics are bad, the darn thing arcs when you plug in the DVI cable, and I doubt it conforms to spec, so I still feel relatively good about my kext edits.

Long story short, I got HD4000 and the 5770 both working; the high-res display is on the 5770 and the old 1920 is on the integrated. Here's what I did:

  • edit my kext as usual, except I put the device ID in that plist... I forget which one. I don't think this mattered.
  • Set GraphicsEnabler to NO!
  • Inject device info for the HD4000 by pasting the code from that other post into my boot.plist. It was the one with a 6 that ends in 9.
  • Set VRAM to 64MB in BIOS (EFI)
  • Set AtiConfig to Hoolock, so it uses that framebuffer
  • Drag the little white bar over to the desired primary display in the pref pane.
And that was it. I was surprised it worked with GraphicsEnabler set to NO, but that was the secret. The system WOULD NOT boot with GE set to Yes. It would hang after "macx-swapon success." But even with GE off I have full 3D everything. Sleep/wake works, and so on. And the secondary display is on integrated, so that should help performance, too.

I'm not sure why GE=Yes would make the system hang, but I'm glad it isn't necessary to have full working graphics with my setup.
 
Joined
Nov 29, 2011
Messages
19
Motherboard
Asus P8Z77-M
CPU
Intel Quad Core i5 3750k
Graphics
ASUS DCII HD 7950
Mac
Classic Mac
Mobile Phone
can show me, how did you edit your 5000controller.kext?
 
Status
Not open for further replies.
Top