Contribute
Register

[Success 12.2] ASUS X99 A II | 6950X | Vega Frontier Edition

Status
Not open for further replies.
Joined
Dec 12, 2012
Messages
95
Motherboard
X99 A II
CPU
i7-6950x
Graphics
RX Vega 64 Founders Edition
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Successfully managed a fresh install of Monterey 12.2 on my Hack. This build is entirely based on @CaseySJ build. Modified it to fit my rig and sharing with the community.

Screen Shot 2022-01-29 at 10.53.49 PM.png


Open Core 0.7.7
MB: Asus X99 A II
CPU: i7 6950X
GPU: Radeon Vega Fronteer Edition
Drive: Gen 3 256GM Apple SSD from Mac Pro
BT/Wifi: OSXWIFI
TB3: GB Alpine Ridge rev2

What works....Everything!
BT, Audio, iCloud/Messages/Handoff, Sleep.
USB: All 15 ports
Boot times: 17sec (53s cold start)
Decided to go with the Apple SSD (which used to be Windows on my Big Sur Setup) with all the decreased loading time reports for Samsung drives. Feel like my boot time has been decreased drastically from Big Sur.

What doesn't work:
Startup Disk - I could not get Open Core to remember my startup disk selection. Not a big deal, since Ive always used the picker for dual boot.
Thunderbolt – It powers a Thunderbolt Display but the inputs don't work. Not even in Windows/Bios. (Believe I broke the TB card years ago experimenting on my GB mobo. Ill be getting the Titan Ridge rev 2 tomorrow and will update if it works.)

Note:
In my case I kept the agdpmod=pikera boot argument, otherwise the Dell UP2715K splits into two monitors.


Benchmarks:

Screen Shot 2022-01-29 at 10.27.40 PM.pngScreen Shot 2022-01-29 at 9.42.55 PM.png
Screen Shot 2022-01-29 at 9.19.45 PM.pngScreen Shot 2022-01-29 at 9.25.44 PM.png
Screen Shot 2022-01-29 at 9.35.04 PM.pngScreen Shot 2022-01-29 at 9.37.43 PM.png

Screen Shot 2022-01-29 at 9.45.05 PM.pngScreen Shot 2022-01-29 at 9.46.42 PM.png
 

Attachments

  • EFI.zip
    8.5 MB · Views: 165

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
...
What doesn't work:
Startup Disk - I could not get Open Core to remember my startup disk selection. Not a big deal, since Ive always used the picker for dual boot.
...
Have you tried either of the following?
  • Option 1: System Preferences --> Startup Disk --> select the startup disk
  • Option 2: OpenCore Boot Picker: press and CTRL key while selecting the macOS boot disk
 
Joined
Nov 27, 2010
Messages
94
Motherboard
ASUS X99-A II
CPU
E5 2690v3
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
@drevan what wifi/BT card that you are using?
 
Joined
Dec 12, 2012
Messages
95
Motherboard
X99 A II
CPU
i7-6950x
Graphics
RX Vega 64 Founders Edition
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Have you tried either of the following?
  • Option 1: System Preferences --> Startup Disk --> select the startup disk
  • Option 2: OpenCore Boot Picker: press and CTRL key while selecting the macOS boot disk
Yes, Option 1 is was I was trying to achieve, but didn't wanted to spend time for something I might not even use.
Option 2 is what I did to set the hack as default.
@drevan what wifi/BT card that you are using?
OSXWIFI: BT 4.0 & 802.11 a/b/g/n/ac
 
Joined
Nov 27, 2010
Messages
94
Motherboard
ASUS X99-A II
CPU
E5 2690v3
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Yes, Option 1 is was I was trying to achieve, but didn't wanted to spend time for something I might not even use.
Option 2 is what I did to set the hack as default.

OSXWIFI: BT 4.0 & 802.11 a/b/g/n/ac
I am using BCM94360CD on X99 II. Can you pair and connect to any BT headset or iPhone? In Monterey, I can only pair BT keyboard and mouse only. But in Big Sur. I do not have this issue.
 
Joined
Dec 12, 2012
Messages
95
Motherboard
X99 A II
CPU
i7-6950x
Graphics
RX Vega 64 Founders Edition
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Just tested connecting my headphones, also Airplay Receiver works.
Is that what you were looking for?

Update
I tried pair the phone, it did but disconnects right away.

Update#2
Paired to my '14 MB Air (Big sur) and same thing it diconnects right away
Same for '16 MBP (Catalina).

Not sure if thats the normal behaviour, I've never done that before.

Screen Shot 2022-01-30 at 9.35.36 AM.png
Screen Shot 2022-01-30 at 9.35.27 AM.png
 
Last edited:
Status
Not open for further replies.
Top