Contribute
Register

[SUCCESS] 10.12.6 Asus Z270 Prime A + i7 7000 + GTX1070 + Samsung 960 EVO NVMe + Thunderbolt EX3

Joined
Sep 17, 2017
Messages
64
Motherboard
Gigabyte Z270X- Gaming 5
CPU
i7-i7700
Graphics
RX Vega 64
Mac
iMac
I managed to get bluetooth working, here is how:
After installing Alpine Ridge TB3 I've connected USB sd-card reader/usb expansion dongle to it (TB3). Connected BT usb adapter to 1 of the available slots. Rebooted (multiple times) still working
 
Joined
Nov 22, 2011
Messages
12
Motherboard
ASUS z279 Prime A
CPU
i7-7700K
Graphics
Geforce GTX 1050 TI
Mac
MacBook Pro
Mobile Phone
iOS
I have the same mobo but I am using a 1050 ti graphics card and I cannot get it working correctly. I followed your instructions to a T and still nothing. The hack has sierra on it and is running but the nvidia web drivers are never selected and the graphics are real glitchy.
 
Joined
May 11, 2011
Messages
776
Motherboard
Gigabyte Z170N-WIFI
CPU
Intel Core i7-6700 3.4GHz
Graphics
Integrated HD
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I have the same mobo but I am using a 1050 ti graphics card and I cannot get it working correctly. I followed your instructions to a T and still nothing. The hack has sierra on it and is running but the nvidia web drivers are never selected and the graphics are real glitchy.
Sorry to hear that, but you have to make sure that the correct versions of Lilu.kext and Nvidiagraphicsfixup.kext are installed in /S/L/E - latest versions if possible, and that your SMBIOS and SSUID and System ID settings are included (these are a MUST), with SIPS disabled. Also, there is a different version of the Nvidia GEForce combo drivers depending on the version of Sierra that you are running. If you still have problems you may have to remove IntelGraphicFixup.kext from the setup (preferably from the /EFI folder).
 
Joined
May 11, 2011
Messages
776
Motherboard
Gigabyte Z170N-WIFI
CPU
Intel Core i7-6700 3.4GHz
Graphics
Integrated HD
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Hey Middleman,
have you tried to upgrade the bios to the latest version? 1203 I think
I haven't upgraded to the latest BIOS. That said my system is working fine at the moment so I don't need to use it as yet. Maybe later...
 
Joined
May 11, 2011
Messages
776
Motherboard
Gigabyte Z170N-WIFI
CPU
Intel Core i7-6700 3.4GHz
Graphics
Integrated HD
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
I created this thread to know your opinion on my build plan. Could you take a look and let me know what you think?
https://www.tonymacx86.com/threads/planning-my-first-build.246352/
Thank you!
I had a look at your post, you have selected a very good system with the Asus Prime Z270, it should work okay provided you know what you're doing (as Hackintoshes are complex creatures). With the Gigabyte mobos, whilst I used to use them a fair bit for my Hackintoshes, but the reliability issues they have nowadays coming direct from the production are of a major concern. My systems dealer told me that out of 10 systems he sold with Gigabyte boards, about half would fail. This was why I went with the Asus Prime mobo instead. Aside from solid reliability and great performance, it is the only one giving me proper Thunderbolt functionality (minus the TB signal recognition after booting compared with a standard Mac setup).
 
Joined
May 11, 2011
Messages
776
Motherboard
Gigabyte Z170N-WIFI
CPU
Intel Core i7-6700 3.4GHz
Graphics
Integrated HD
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Joined
Sep 21, 2015
Messages
20
Motherboard
Asus Z170-A
CPU
i7-6700K
Graphics
HD 530 & RX 560
Mobile Phone
Android
Hello @Middleman,my second hackintosh is based on the same motherboard as yours.Do you have any PCI devices showing on About this Mac->System Report? and something else are your sata devices recognised as Generic AHCI or Intel 200 series?
Thanks for your reply!


P.S.: SMBIOS 18,3/High Sierra 10.13.2 SU
 
Last edited:
Joined
May 11, 2011
Messages
776
Motherboard
Gigabyte Z170N-WIFI
CPU
Intel Core i7-6700 3.4GHz
Graphics
Integrated HD
Mac
iMac, MacBook, MacBook Air, MacBook Pro, Mac mini, Mac Pro
Classic Mac
Power Mac, PowerBook
Mobile Phone
iOS
Hello @Middleman,my second hackintosh is based on the same motherboard as yours.Do you have any PCI devices showing on About this Mac->System Report? and something else are your sata devices recognised as Generic AHCI or Intel 200 series?
Thanks for your reply!


P.S.: SMBIOS 18,3/High Sierra 10.13.2 SU
For the PCI devices, only a PCI XHCI Express card running at 2.5GT/s. And for the SATA they are recognised as Generic AHCI and the Samsung NVMe is recognised as Apple SSD Controller under NVMeExpress. The Samsung NVMe is running at 8GT/s.
 
Top