Contribute
Register

[SUCCESS] 10.11.6; ASUS Z170 Pro Gaming, i5-6500, 760GTX

Joined
Jan 11, 2014
Messages
117
Motherboard
ASUS Z170 Pro Gaming
CPU
Intel i5-6500
Graphics
ASUS GTX970 Strix
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hi Everyone,

For too long have I lurked around the tonymacx86 website not posting any of my experiences, but now that I have my new Skylake system up and running I feel the time has come. :)

Some general forewords:
- I prefer to use Clover and not MultiBeast/UniBeast for both the installation drive as well as the running OSX
- I have tried choosing hardware that is most compatible with OSX
- Everything works 100% unless specifically stated :)
- I always try to modify (etc BIOS) and edit as little as possible to make sure my runs as good as possible
- This guide is for OSX 10.11.4 - this install will NOT work on 10.11.3 or lower...

Some thanks are in order: Stork for the ASUS support, tonymacx86 for the Clover guide

So, to start:

Pre-work:
a/ Download Clover
b/ Download the attachments to this post
- 2 config.plist files - one for installing and one for final working version
- kexts.zip - all the kexts you will need for this build
- 2 SSDT files - one for the USB config, the other for the Realtek sound

0. My system

Motherboard: ASUS Z170 Pro Gaming
Processor: Intel Core i5-6500
Memory: Crucial 3000MHz 2x8Gb
GPU: PNY GTX760 2Gb OC
Monitor: ASUS V247, DVI-port

Keyboard: Apple Wired Keyboard - fully works at boot
Mouse: Logitech M510 - fully works in BIOS and Clover


1. BIOS settings


First load all optimal settings!

Advanced Items
- System Agent (SA) Configuration > VT-d > Disable
- USB Configuration > Legacy USB Support > Auto
- USB Configuration > XHCI Hand Off > Enabled
- System > Serial > Disable serial port

Boot Menu
- Fast Boot > Disabled
- Secure Boot > OS Type > Other OS


2. Create Clover install USB

I personally recommend any USB 3 speed drive, at least 16Gb!

To install, use the attached files (and make sure to use config_install.plist). Please note I have crossed out my serial number and MLB, as iMessage works just fine for me using them.

You should be able to reach the install screen with the new USB drive - if you have "Unrecognized CPU" error, just drop NullCPUPowerManagement.kext in with the other kexts. You can create a CPU-specific SSDT after you have OSX running.


3. Post-install

After you have successfully booted from the USB into your install, install Clover onto the hard drive you have OSX on. Use again the attached files, but this time use the config_postinstall.plist, renamed to config.plist.
This config.plist has the system identified as an iMac17,1 - this is a Skylake iMac. For me, with this system definition, turbo works, the CPU also idles as much lower speeds than with any other definition, as well as runs much cooler! :)

For working audio, boot at least once from your new drive (not the USB), mount your EFI partition, and then run the script from here:
audio_cloverALC-110.command.zip.
After reboot, audio works fine for me.

To have iMessage working, create your own serial number and MLB with Clover Configurator.

Please note I did not have to meddle with nvda_drv=1 since my GTX 760 is supported out of the box in OSX.

Please let me know I can help any further!

EDIT on May 18, 2016: Uploaded kexts for a fully working 10.11.5 install!
EDIT on September 2, 2016: Updated for 10.11.6
 

Attachments

  • config_install.plist
    5.5 KB · Views: 2,340
  • config_postinstall.plist
    6.2 KB · Views: 2,230
  • SSDT-HDEF-HDAS-1.aml
    259 bytes · Views: 1,773
  • SSDT-USB.aml
    886 bytes · Views: 1,758
  • kexts 10.11.5.zip
    154.3 KB · Views: 2,214
Last edited:
Joined
Mar 25, 2016
Messages
34
Motherboard
Asus Z170 Deluxe
CPU
Intel i7 6700K
Graphics
ASUS GeForce STRIX GTX 980
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Hej kristof.petho,

thank you for your guide.

I already had my system up and running 10.11.4:
Asus Z170 Deluxe
Intel i7 6700K
ASUS GeForce STRIX GTX 980

But since you posted some stuff I still need to do, maybe you could help me out.

I guess, that I'd still need to modify the DSDT/SSDT files. But how?
How did you do it? And why to separate ones?

Unfortunately I am having no sound, this bothers me the most.
Do I have to run run the script "audio_cloverALC-110.command"?
Or should it also work without it? The Mainboard has an ALC 1150 installed.

Thank you so much in advance.
 
Joined
Jan 11, 2014
Messages
117
Motherboard
ASUS Z170 Pro Gaming
CPU
Intel i5-6500
Graphics
ASUS GTX970 Strix
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hej kristof.petho,

thank you for your guide.

I already had my system up and running 10.11.4:
Asus Z170 Deluxe
Intel i7 6700K
ASUS GeForce STRIX GTX 980

But since you posted some stuff I still need to do, maybe you could help me out.

I guess, that I'd still need to modify the DSDT/SSDT files. But how?
How did you do it? And why to separate ones?

Unfortunately I am having no sound, this bothers me the most.
Do I have to run run the script "audio_cloverALC-110.command"?
Or should it also work without it? The Mainboard has an ALC 1150 installed.

Thank you so much in advance.

Hey, the SSDT is needed for 100% USB compatibility. You might not need it for your motherboard, you can definitely try without. As to my SSDT, I found it somewhere in the forums, will look it up where.

Sound. Without any patches, etc, with my config.plist and the audio-SSDT file in place, first mount your EFI partition, then run the command it. If everything is OK, then it will first ask if ALC1150 should be patched. Then asks to inject into Clover, then asks for Audio ID. Everything should be OK, so answer Yes three times.
Reboot, and select the first Built-In audio out source as default and you will have sound! :)

EDIT: I found the SSDT for the motherboard HERE. Thanks to ammulder for this!!!
 
Joined
Feb 19, 2014
Messages
4
Motherboard
Asus Z170 PRO Gaming
CPU
i5-6600K
Graphics
RTX 2070
Mac
  1. iMac
Mobile Phone
  1. iOS
hi,
can you post your config.plist for OSX 10.11.3 ? (thank you so much for the guide of 10.11.4)
thanks :)
 
Joined
Jan 11, 2014
Messages
117
Motherboard
ASUS Z170 Pro Gaming
CPU
Intel i5-6500
Graphics
ASUS GTX970 Strix
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
hi,
can you post your config.plist for OSX 10.11.3 ? (thank you so much for the guide of 10.11.4)
thanks :)

Sorry, that got deleted as soon as 10.11.4 was stable for me. :(

10.11.4 is must for anyone using Skylake, for much better support...
 
Joined
Feb 19, 2014
Messages
4
Motherboard
Asus Z170 PRO Gaming
CPU
i5-6600K
Graphics
RTX 2070
Mac
  1. iMac
Mobile Phone
  1. iOS
Sorry, that got deleted as soon as 10.11.4 was stable for me. :(

10.11.4 is must for anyone using Skylake, for much better support...
no problem , i'm going to use your guide for 10.11.4 . i have asked it because i hadn't already downloaded the 10.11.4
(sorry for my english ahah but i'm Italian xD)
 
Joined
Jan 11, 2014
Messages
117
Motherboard
ASUS Z170 Pro Gaming
CPU
Intel i5-6500
Graphics
ASUS GTX970 Strix
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
no problem , i'm going to use your guide for 10.11.4 . i have asked it because i hadn't already downloaded the 10.11.4
(sorry for my english ahah but i'm Italian xD)

No worries, I have two Italian colleagues at work, so I fully understand you... :)

I also suggest for you to use your CPU's SSDT from THIS post (it's towards the end). Remember to name it SSDT.aml and put it in the ACPI/patches folder.
 
Joined
Mar 25, 2016
Messages
34
Motherboard
Asus Z170 Deluxe
CPU
Intel i7 6700K
Graphics
ASUS GeForce STRIX GTX 980
Mac
  1. iMac
  2. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Hej kristof.petho,

just a quick question: Which Guide did you follow regarding SN, MLB, ...?

Edit: And another one:
Why did you choose "- PCH Configuration > IOAPIC > Disabled" and "- System > Serial > Disable serial port"?
 
Joined
Jan 11, 2014
Messages
117
Motherboard
ASUS Z170 Pro Gaming
CPU
Intel i5-6500
Graphics
ASUS GTX970 Strix
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
Hej kristof.petho,

just a quick question: Which Guide did you follow regarding SN, MLB, ...?

Edit: And another one:
Why did you choose "- PCH Configuration > IOAPIC > Disabled" and "- System > Serial > Disable serial port"?

I used this guide HERE.

IOAPIC and Serial Port both gave me kernel panics when enabled (though I have not tried enabling them in 10.11.4 yet to be honest, maybe it would work just fine with them enabled. Does it work for you?

EDIT: I just tried IOAPIC enabled in BIOS with 10.11.4 and it works just fine! :)
 
Joined
Dec 4, 2015
Messages
3
Motherboard
ASUS Z170 Pro Gaming
CPU
i5-6600
Graphics
GTX 960
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Thanks for the guide! Successfully installed on ASUS Z170 Pro Gaming with i5-6600 and GTX 960, using your the exact same kexts and SSDTs.

Had an issue when first trying to boot from USB(stuck at plus signs "+++++++++"), which I fixed by adding the OsxAptioFix2Drv-64 driver in clover, no problems after that.

Now I have a problem with my resolution(too low), but my graphics card is recognized correctly so I think the problem is with my old VGA monitor(with DVI adapter). I'm going to get another one next week anyway, so will see how it works with that.
EDIT: Got the new monitor, graphics work on 1080p now :D
 
Last edited:
Top