Contribute
Register

<< Solved >> Stuck at [EB|#LOG:EXITBS:START]

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,649
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I'm still having the issue

The realloc setting is 128mb (I checked it under Windows, didn't saw the option in my BIOS). I have an NVIDIA graphic card, but it was already disabled with -wegnoegpu

The only line I kept under PciRoot(0x0)/Pci(0x2,0x0) is AAPL,ig-platform-id=00009B3E

I also figured that I've left AudioDevice=PciRoot(0x0)/Pci(0x1b,0x0), so I corrected it.



I checked my config.plist with slowgeek's sanity checker, here's the result if it can help :
https://opencore.slowgeek.com/?file=laptopcoffeelakeplus060DVM9zr&rs=laptopcoffeelakeplus060

I also join the last version of my EFI folder
you have those "Quirks" that seem to be incorrect, according to your link.......
 
Joined
Sep 13, 2019
Messages
17
Motherboard
Aero 15 OLED - OpenCore
CPU
I7-10875H
Graphics
Intel UHD 630 - 3840 x 2160
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I changed the quirks because I had another issue before (post #6), but I will try enable some of them again and see if it make any change
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,649
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I changed the quirks because I had another issue before (post #6), but I will try enable some of them again and see if it make any change
you may need to trial and error all or few of those and see how you get on
 
Joined
Mar 29, 2011
Messages
855
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
The SetupVirtualMap change is a new thing with Comet Lake, I think. Ran into that one myself.

You could always go through the alternative ig-platform-id values for UHD 630. I'm still not sure what's going on here! If the removing of the extra properties--stolenmem, etc.--didn't help, then I guess put them back in before trying other possibilities.
 
Joined
Sep 13, 2019
Messages
17
Motherboard
Aero 15 OLED - OpenCore
CPU
I7-10875H
Graphics
Intel UHD 630 - 3840 x 2160
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS

Attachments

  • EFI.zip
    924.2 KB · Views: 258
Joined
Mar 8, 2017
Messages
723
Motherboard
Lenovo ThinkPad T480s (OpenCore)
CPU
i7-8550U
Graphics
UHD 620, 2560x1440
Mobile Phone
  1. Android
@blackchou32

Getting the trackpad to work should be pretty easy. If you need any help, just post your extracted (native) DSDT and I will send you the SSDT for it.
 
Joined
Sep 13, 2019
Messages
17
Motherboard
Aero 15 OLED - OpenCore
CPU
I7-10875H
Graphics
Intel UHD 630 - 3840 x 2160
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Here is my DSDT (and my attempt to make the trackpad work : it didn't work.).
I did the installation in russian, and it worked. Now Catalina is installed on my laptop.

For now, there are only 3 issues that I found (but I can still use MacOS with these one)
  • The trackpad that didn't work (I did the installation with an USB mouse)
  • The fans aren't recognized (checked with Macs Fan Control)
  • On the bottom of the screen, there is a black band
I will check the post-install guide, but overall, it look fine. Here is the EFI if someone need it

(edit: the audio don't work for the moment, with and without an headset. The battery didn't show ether)
 

Attachments

  • DSDT.aml
    276.1 KB · Views: 94
  • SSDT-GPI0.dsl
    287 bytes · Views: 84
  • EFI.zip
    939.6 KB · Views: 127
Last edited:
Joined
Mar 8, 2017
Messages
723
Motherboard
Lenovo ThinkPad T480s (OpenCore)
CPU
i7-8550U
Graphics
UHD 620, 2560x1440
Mobile Phone
  1. Android
@blackchou32

Your GPHD should be Zero, if I read the DSDT correctly. Try the attached file. Also, do you inject VoodooI2C?
 

Attachments

  • SSDT-GPI0.aml
    71 bytes · Views: 53
Joined
Sep 13, 2019
Messages
17
Motherboard
Aero 15 OLED - OpenCore
CPU
I7-10875H
Graphics
Intel UHD 630 - 3840 x 2160
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I tried your .aml and with VoodooI2C, but it didn’t worked.

I followed the post install guide, and know this computer work good. Only the battery and the trackpad didn’t show, but since I will mostly use it while in charge and with a mouse, it’s not a big deal.

A huge thanks to everyone for helping me with this.
 
Top