<< Solved >> Strange display issue

Jul 13, 2011
Intel Xeon W3580
GTX 760 (192-bit)
Hi everyone.

I have a working dual-monitor setup with a NVIDIA GeForce GTX 760.
Until short my monitors consisted of 1) some AOC 21,5" (1920x1080) monitor and 2) an quite old Acer 22" (1680x1050).
"Until short" means, the second monitor (the Acer) died a couple of days ago and I replaced it with an PB Viseo243D (still had this somewhere in storage).

Now, my issue is: MacOS does not seem to recognize the new monitor but thinks that the Acer is still connected and thus I cannot change the resolution of that monitor to full-hd.

So, how do I make my machine recognize the changed monitor configuration?

Further information:
- I tried to use the button in the display system panel that pops up when you press option. This literally did nothing at all.
- this is old, Mojave, still booting with Clover
- there are no graphic related injections of any kind active in the config

Pease help!

Kind regards,
In case anyone is interested, I could sort this issue. It is quite unlikely that any other person on this planet will run into exactly THIS problem.

There is one device in my setup that I kept quiet about, because I didn't think, it would matter (or if it mattered then not in this way). I use a GREATHTEK DVI-2-port-switch ( for switching my entire workplace (keyboard, mouse, audio and both monitors) between my hack and my company laptop without needing to plug cables from one to the other.

While I ofc shut down my computer and all monitors when I tried to make my computer recognize the new monitor, I never thought of unplugging that little f*cker. It seems to somehow remember the connected displays and always seems to somewhat send this signature to the connected computers and THAT'S why my computer did not recognize the new monitor... it had no idea that the monitor had changed! I stumbled over it, when my company laptop ALSO told me that my second montitor was an Acer with crappy resolution.

So, thanks to everyone who thought about this problem but didn't or had no answer ;)